DNS: host resolution is slow

RESOLVED INVALID

Status

()

Core
Networking
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: James Rome, Assigned: Darin Fisher)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
I thought I was imagining things, but someone else reported this as well:
http://groups.google.com/groups?dq=&hl=en&lr=&ie=UTF-8&group=alt.os.linux.suse&selm=c8d5tl%2416sc%40newton.cc.rl.ac.uk
I have build 2004051305 on SuSE Pro 9.1 running on a dual opteron. When I browse
or get mail, there is a significant delay during which a "resolving host"
message is shown in the status bar.

Comment 1

14 years ago
This is happening to me on SuSE 8.2 since installing 1.7rc2.
Assignee: general → darin
Component: Browser-General → Networking
QA Contact: general → benc
(Assignee)

Comment 2

14 years ago
Felix: what version of mozilla were you previously running?

Comment 3

14 years ago
11 April trunk
(Assignee)

Comment 4

14 years ago
hmm.. i wonder if the patch for bug 240759 is somehow to blame for this :(

Comment 5

14 years ago
Created attachment 148777 [details]
log with NSPR_LOG_MODULES=nsHostResolver:5

On request from darin on moznet
(Reporter)

Comment 6

14 years ago
I do not see this problem on the 4/30 windows XP build.

Comment 7

14 years ago
(if you came to this bug by following a checkin comment that has to do with
nsILocalFile, you're really looking for bug 243937).

Updated

14 years ago
Summary: host resolution is slow → DNS: host resolution is slow

Comment 8

14 years ago
I am running Mozilla 1.7 on XP:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616

Trying to access popular sites such as:
http://google.com.au
http://google.com
http://smh.com.au
http://www.groklaw.net
http://bugzilla.mozilla.org

I see a message "Resolving host XYZ" in the footer, then am told the host cannot
be found. This is an intermittent problem, it's happened about 8-10 times since
I upgraded to 1.7 yesterday. I am on a 28.8K dial-up, though I see this problem
when there is no other network activity. I can resolve the names perfectly fine
using nslookup from a shell while Mozilla reports that the host cannot be found.

Once Mozilla fails to resolve a hostname - it seems that it refuses to resolve
anything else for a period of time, maybe 30-60 seconds. After this period of
time it then can resolve all hostnames.  

This is so frustrating I am regretting the upgrade now. I first noticed this
problem in Mozilla 1.7RC2, but naively assumed this was a problem on my end.

Please let me know if I can provide any further info.
(Assignee)

Comment 9

14 years ago
hi servalan:

can you please collect a Mozilla log file for us captured while demonstrating
the problem?  here's what you'd need to do:

open a DOS prompt and cd into the directory containing Mozilla 1.7, something
like this:

 C:\> cd Program Files\Mozilla.org\Mozilla

Then type the following commands:

      set NSPR_LOG_MODULES=nsHostResolver:5
      set NSPR_LOG_FILE=C:\log.txt

Finally, run Mozilla from the DOS prompt like so:
     
      .\mozilla.exe

Reproduce the problem, then close Mozilla, and upload C:\log.txt to this bug
report as a new attachment.

Thanks!  Hopefully this log file will reveal something about the problem you are
seeing.  

It may also be useful if you can capture a tcpdump using ethereal
(www.ethereal.com).  It can be a tricky tool to learn how to use, but the
resulting log files will definitely be informative.  It would be great if we
could compare tcpdumps of mozilla versus nslookup.

Comment 10

14 years ago
My naive assumption was correct. The issue was with my end. I also use ZoneAlarm
& the upgrade to version 5 completely messed up my system, including disbaling
virus protection & giving the appearance that the Mozilla upgrade was the root
of the problem.

I have used the instructions at:
http://forum.zonelabs.org/zonelabs/board/message?board.id=inst&message.id=11594

to go back to ZoneAlarm version 4 & all is well with Mozilla again. Apologies
for the hassles & I hope this comment saves someone else the agony I went
through to diagnose & fix the problem. 
OK, thanks - marking invalid, then, as it seems to be a zonealarm issue.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.