Links for stacks should be split between signature and line

RESOLVED FIXED

Status

Core Graveyard
Talkback Client
RESOLVED FIXED
14 years ago
7 years ago

People

(Reporter: timeless, Assigned: jay)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
Currently lines are like this:

	<span class=stack><a href='http://bugzilla.mozilla.org/buglist.cgi?
query_format=&long_desc_type=substring&long_desc=nsFrameManager::GetPropertyList
For&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwor
dssubstr&status_whiteboard=&keywords_type=allwords&keywords=&emailassigned_to1=1
&emailtype1=exact&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=
1&emailtype2=exact&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=&chfield
to=Now&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-
0=noop&type0-0-0=noop&value0-0-0='>
	nsFrameManager::GetPropertyListFor
	[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/ba
se/src/nsFrameManager.cpp, line 1875]</a></span><BR>

	<span class=stack><a href='http://bugzilla.mozilla.org/buglist.cgi?
query_format=&long_desc_type=substring&long_desc=nsIFrame::GetView&bug_file_loc_
type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_w
hiteboard=&keywords_type=allwords&keywords=&emailassigned_to1=1&emailtype1=exact
&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailtype2=exac
t&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=&chfieldto=Now&chfieldval
ue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=noop&type0-0-
0=noop&value0-0-0='>
	nsIFrame::GetView
	[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/ba
se/src/nsFrame.cpp, line 2270]</a></span><BR>

---
I'd rather the lines look like this:
	<span class=stack><a href='http://bugzilla.mozilla.org/buglist.cgi?
query_format=&long_desc_type=substring&long_desc=nsFrameManager::GetPropertyList
For&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwor
dssubstr&status_whiteboard=&keywords_type=allwords&keywords=&emailassigned_to1=1
&emailtype1=exact&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=
1&emailtype2=exact&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=&chfield
to=Now&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-
0=noop&type0-0-0=noop&value0-0-0='>
	nsFrameManager::GetPropertyListFor</a>	<a 
href='http://bonsai.mozilla.org/cvsblame.cgi?
file=mozilla/layout/html/base/src/nsFrameManager.cpp&rev=1.186.2.1&tag=MOZILLA_1
_7_BRANCH&mark=1875#1850'>
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/base/src/n
sFrameManager.cpp, line 1875]</a></span><BR>

	<span class=stack><a href='http://bugzilla.mozilla.org/buglist.cgi?
query_format=&long_desc_type=substring&long_desc=nsIFrame::GetView&bug_file_loc_
type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_w
hiteboard=&keywords_type=allwords&keywords=&emailassigned_to1=1&emailtype1=exact
&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailtype2=exac
t&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=&chfieldto=Now&chfieldval
ue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=noop&type0-0-
0=noop&value0-0-0='>
	nsIFrame::GetView</a>	<a href='http://bonsai.mozilla.org/cvsblame.cgi?
file=mozilla/layout/html/base/src/nsFrame.cpp&rev=3.475&tag=MOZILLA_1_7_BRANCH&m
ark=2270#2250'>
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/base/src/n
sFrame.cpp, line 2270]</a></span><BR>

rev and tag can be pulled from CVS/Entries
tag doesn't mean anything to bonsai today, but i'd probably be willing to teach 
it about tags.
(Assignee)

Comment 1

14 years ago
I was thinking about this too, but it was just too much work to split the stack
frames...since I'm getting the entire line directly from the db.

I'll see what I can do.  I can at least put the file name and line no. together
and have a link to bonsai for the location of the crash.

Doing the same for each stack frame might take a little more work.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 2

14 years ago
I've made some changes to the single incident results.  The source file and line
no. are now on the same line and for valid source paths, I've done the following:

1. For source files with a complete path and line no.
(c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpcom/string/src/nsTAString.cpp,
line 279) I've created a link to bonsai that takes you to the line of the crash: 
http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/xpcom/string/src/nsTAString.cpp&mark=279#279

Example: 
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=12345

2. For source files that have relative paths displayed (
../../../dist/include/content\nsHTMLValue.h, line 100) I've created a link to
lxr that takes you to the query results for the file.  

Example:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=12932

That's the best I could do with the 2 most common types of source files we get
from Talkback.  With relative paths, it's difficult to map the file to the
complete path, so there's not much I can do there.

I'm working on applying the same links to all stack frames.  Should have
something soon.
(Assignee)

Comment 3

14 years ago
I have finished adding links to the stack frames as well.  It looks good so far,
but let me know if you see any problems.  I've covered most of the cases, but
I'm sure there are some odd stack frames out there that might break it.

Here's a good example that has all 3 types of frames (/mozilla/..., ../../dist,
and just .dlls):

http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=12932

I also changed the color of the source files in the stack for easier viewing. 
Marking fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
hmm, would it be better if relative links linked to
http://bonsai.mozilla.org/cvsguess.cgi?file=foo instead? saves one click if the
name is unique. It looks like that even does "the right thing" if you make it:
http://bonsai.mozilla.org/cvsguess.cgi?file=foo&mark=42
(i.e. it scrolls a few lines above the marked line, and does mark it)
(Assignee)

Comment 5

14 years ago
Yeah, that works!  I don't use bonsai enough, so didn't know you could "guess" a
file.  I've changed the relative links from
http://lxr.mozilla.org/seamonkey/find?string=nsHTMLValue.h to
http://bonsai.mozilla.org/cvsguess.cgi?file=nsHTMLValue.h&mark=100#100

The bonsai link above takes a bit longer to load, but for cases where the file
is unique, this will definitely be better than before.  And it's cool how the
results for multiple file matches keep your line no. mark in their links.  

Thanks for the suggestion Christian.
(Reporter)

Comment 6

14 years ago
yeah, guess is great. i have a bookmark keyword 'gu' which does that. at some 
point i might teach bonsai about h=>idl files.
(Reporter)

Updated

9 years ago
Component: Talkback Client → Talkback Client
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.