If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

View Source of frames shows up blank

VERIFIED WORKSFORME

Status

()

Core
Layout: HTML Frames
P3
normal
VERIFIED WORKSFORME
18 years ago
16 years ago

People

(Reporter: Jennifer Huebert, Assigned: Eric Pollmann)

Tracking

(Blocks: 1 bug)

Trunk
Future
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Tried 5 times to view source of a selected frame on a company intranet page. Got
results 2 out of 5 times, otherwise a blank window. Basic navigation in
JavaScript pop-up windows on same system also flaky performance - sometimes
content of pop-up loaded, sometimes not.

Updated

18 years ago
Assignee: karnaze → rickg

Comment 1

18 years ago
Reassigning to Rick.

Updated

18 years ago
Assignee: rickg → petersen

Comment 2

18 years ago
I need samples. Every frameset/frame I tried works. Petersen, can you reproduce?

Comment 3

18 years ago
With the Jan 26 build, I'm able to reproduce this problem. However, I suggest 
that the reporter provide a url or test case that we can use.
Assignee: petersen → rickg
(Reporter)

Updated

18 years ago

Comment 4

18 years ago
Eric -- I doubt that this is a parser problem. I'm handing it off to you because 
of the frames issue. If you need further help from me, just say the word.
Assignee: rickg → pollmann

Comment 5

18 years ago
I'm encountering this problem under Linux with Build ID: 2000022709 (nightly

build).  Here's a quick rundown of the problem.  I have a page (index.html)

that consists of a frameset directive with a single frame, index.php3.

Index.php3 in turn has two frames, left.php3 and right.php3.  Now, if one goes

directly to index.php3, one can view the frame source of either left or right

by clicking on the appropriate frame and selecting view frame source from the

context menu.  However, if one goes to index.html, then, no matter where one

clicks, you only get the frame source of the first frame (left.php3).



I hope that explanation made sense.

(Assignee)

Comment 6

18 years ago
nhsilber@yahoo.com, the "wrong frame source" problem is a symptom of the problem
behind bug 28142.  I have a fix for that in my tree now and am testing it. 
Please attach further comments along those lines in bug 28142.  We'll keep this
bug "view source of frames shows up blank"

I am not able to reproduce this.
Summary: View Source of frames flaky → View Source of frames shows up blank
(Assignee)

Comment 7

18 years ago
*** Bug 29234 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

18 years ago
*** Bug 29234 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M17
(Assignee)

Comment 9

17 years ago
This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another 
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration.
Target Milestone: M17 → Future

Comment 10

17 years ago
View|Viewer Demos|#9 Frames   test does nothing, and prints error:

  JavaScript error: 
  chrome://communicator/content/contentAreaUtils.js line 31: contentFrames has
no properties

Updated

17 years ago
Blocks: 10445

Comment 11

17 years ago
QA Contact update
QA Contact: petersen → amar
(Assignee)

Comment 12

16 years ago
Viewing the source of a frame via the context menu works for me every time now
(tested on warp.mcom.com, and a few other random sites).  Marking WORKSFORME.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 13

16 years ago
 Worksforme. Marking verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.