checksetup with answers script isn't silent on windows

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
Installation & Upgrading
P3
trivial
RESOLVED FIXED
14 years ago
5 years ago

People

(Reporter: glob, Assigned: glob)

Tracking

unspecified
Bugzilla 2.18
x86
Windows XP
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Assignee)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040517 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040517 Firefox/0.8.0+

checksetup with answers script isn't silent on windows.

instead it always outputs information about activestate's ppm repository.

Reproducible: Always
Steps to Reproduce:
create an answers file for non-interactive checksetup.pl
run on windows
Actual Results:  
Most ActivePerl modules are available at Apache's ppm repository.
A list of mirrors is available at
    http://www.apache.org/dyn/closer.cgi/perl/win32-bin/ppms/
You can add the repository with the following command:
    ppm rep add apache http://www.apache.org/dist/perl/win32-bin/ppms/


Expected Results:  
no output
(Assignee)

Comment 1

14 years ago
Created attachment 148833 [details] [diff] [review]
don't show ppm information if $silent
(Assignee)

Updated

14 years ago
Attachment #148833 - Flags: review?

Comment 2

14 years ago
Comment on attachment 148833 [details] [diff] [review]
don't show ppm information if $silent

r=joel
Attachment #148833 - Flags: review? → review+

Comment 3

14 years ago
Zach - this looks right, but I could not test it.  Also, I doubt Byron has CVS
access.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Target Milestone: --- → Bugzilla 2.18
Hmmm...  looking at this code, it looks like (even with this patch) it's
printing it regardless of whether all the modules are present or not.  If
everything Bugzilla might possibly want is installed already, then it shouldn't
be displayed at all, even if --silent is specified.  But I guess that's another
bug. :)

This looks fine for fixing what the summary says :)
Assignee: zach → bugzilla
Flags: approval+
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED

Comment 5

14 years ago
FIXED.

Checking in checksetup.pl;
/cvsroot/mozilla/webtools/bugzilla/checksetup.pl,v  <--  checksetup.pl
new revision: 1.280; previous revision: 1.279
done
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.