Printouts from Mozilla uses "stick" font

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
15 years ago
14 years ago

People

(Reporter: iliano, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040114
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040114

Anything I print from any Mozilla component (except PS and PDF handled as
plug-ins) is rendered using stick-like fonts for normal text and comic-like
fonts for bold.  The result is not readable.  See example at
http://theory.stanford.edu/~iliano/TMP/mozilla.ps
I can print without problems from other programs (including browsers).

This version of Mozilla came with SuSE 9.1 (I contacted them but they said they
were not responsible for this problem).  I tried to run Mozilla both with and
without XPrint: the result was the same.

Reproducible: Always
Steps to Reproduce:
1. Print any page or mail from any Mozilla component (except plug-ins)
2.
3.

Actual Results:  
See file http://theory.stanford.edu/~iliano/TMP/mozilla.ps for an example
of the output to file -- it would look the same on a printer.

Expected Results:  
Use "standard" fonts (readable)
Odd.  The PS file has references to "Tork.Bold" and "Burnstown_Dam.Regular"...

Comment 2

15 years ago
The document uses the freetype extensions. Burnstown dam is the "stick" font;
Tork is the one for the subject, date, etc. labels. For some reason, the
freetype font substitution code is selecting those two fonts.

Judging from the underlines beneath the URLs, there's also a font metrics problem.

Comment 3

15 years ago
Is it a Gtk2+xft build?
At least using Xprint, Mozilla becomes useless for printing then. Fonts get
completely unpredictable, to the extent that they print at all. Allthough print
preview show them fine.
In mail, where body should print as Courier New, no fonts print at all. Only
eventual underlines. The "headers" field will print, but as Verdana instead of
Helvetica. (It used to work while building against Gtk1+xft)
(Reporter)

Comment 4

15 years ago
> Is it a Gtk2+xft build?

  I have no idea.  It's whatever was on the SuSE CD.

> At least using Xprint, Mozilla becomes useless for printing then. Fonts get
> completely unpredictable, to the extent that they print at all. Allthough print
> preview show them fine.
> In mail, where body should print as Courier New, no fonts print at all. Only
> eventual underlines. The "headers" field will print, but as Verdana instead of
> Helvetica. (It used to work while building against Gtk1+xft)

  I just tried preview, and things look good.  I tried printing again (for
  real, not preview) without Xprint,and it was all sticks.

  When trying this out, I started mozilla from the console, and on my first
  attempt a printing it wrote some 500 lines like the following

font /usr/X11R6/lib/X11/fonts/truetype/TSCu_Times.tt    307 glyphs (6 invalid)
font /usr/X11R6/lib/X11/fonts/truetype/luxisri.tt    374 glyphs (1 invalid)
font /usr/X11R6/lib/X11/fonts/truetype/fonts.scale   FreeType failed to open,
error=0
font /usr/X11R6/lib/X11/fonts/truetype/failed.tt    339 glyphs (160 invalid)
font /usr/X11R6/lib/X11/fonts/truetype/tork____.tt    518 glyphs (344 invalid)
font /usr/X11R6/lib/X11/fonts/truetype/fonts.scale.baekmuk   FreeType failed to
open, error=0
font /usr/X11R6/lib/X11/fonts/truetype/ariali.tt    949 glyphs
font /usr/X11R6/lib/X11/fonts/truetype/butterbe.tt    341 glyphs (148 invalid)
font /usr/X11R6/lib/X11/fonts/truetype/teen____.tt    295 glyphs
   (...)

  I don't know whether this is good or bad.  In the complete list, I spotted
  promising filenames for courier (cour.tt, couri.tt, courb.tt and courbd.tt)
  but nothing for helvetica.

Comment 5

15 years ago
i mentioned "courier new" and helvetica because i use them as monospace font and
UI font here. That would vary from profile to profile.

What does "about:buildconfig" in the urlbar say under "Configure arguments"?
(Reporter)

Comment 6

15 years ago
> What does "about:buildconfig" in the urlbar say under "Configure arguments"?

  Here's the whole output:
Build platform
target
i686-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 3.3.3 (SuSE Linux) 	-Wall -W -Wno-unused -Wpointer-arith
-Wcast-align -Wno-long-long -pedantic -O2 -march=i586 -mcpu=i686
-fmessage-length=0 -Wall -fno-strict-aliasing -pthread -pipe
c++ 	gcc version 3.3.3 (SuSE Linux) 	-fno-rtti -fno-exceptions -Wall
-Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor-privacy -Wno-long-long -pedantic -O2 -march=i586 -mcpu=i686
-fmessage-length=0 -Wall -fno-strict-aliasing -fshort-wchar -pthread -pipe
-I/usr/X11R6/include

Configure arguments
--disable-tests '--enable-optimize=-O2\ -march=i586\ -mcpu=i686\
-fmessage-length=0\ -Wall\ -fno-strict-aliasing' --enable-extensions=all
--enable-xinerama --enable-crypto --enable-reorder --enable-strip --enable-svg
--disable-profilesharing --disable-debug --disable-dtd-debug --disable-logging
--enable-xft --enable-default-toolkit=gtk2
--with-default-mozilla-five-home=/opt/mozilla/lib --libdir=/opt/mozilla/lib
--sysconfdir=/etc --mandir=/usr/share/man --prefix=/opt/mozilla
--with-system-jpeg --with-system-png --with-system-mng --with-system-zlib
--disable-xprint --enable-calendar --enable-ldap-experimental

Comment 7

15 years ago
bzbarsky@mit.edu wrote:
> Odd.  The PS file has references to "Tork.Bold" and "Burnstown_Dam.Regular"

Where are these fonts coming from ? My SuSE test installation does not have
it...
(Reporter)

Comment 8

15 years ago
> > Odd.  The PS file has references to "Tork.Bold" and "Burnstown_Dam.Regular"
> 
> Where are these fonts coming from ? My SuSE test installation does not have
> it...

This is a fresh install: either from the CD's or from the on-line update.

Comment 9

15 years ago
To see which package provided them:

rpm -qf /usr/X11R6/lib/X11/fonts/truetype/torkb___.tt

To see what else the package provided:

rpm -ql packagename-1.2-3

Could it be caused by bogus aliasing?

(btw.. odd that they are named *.tt instead of *.ttf. They are available for
free, but the original trademarked Tork fonts by Ray Larabie are named .ttf)
(Reporter)

Comment 10

15 years ago
> To see which package provided them:
> 
> rpm -qf /usr/X11R6/lib/X11/fonts/truetype/torkb___.tt

free-ttf-fonts-1.0-156

> To see what else the package provided:
> 
> rpm -ql packagename-1.2-3

/usr/X11R6/lib/X11/fonts/truetype
/usr/X11R6/lib/X11/fonts/truetype/!y2kbug.ttf
/usr/X11R6/lib/X11/fonts/truetype/1980port.ttf
/usr/X11R6/lib/X11/fonts/truetype/256bytes.ttf
/usr/X11R6/lib/X11/fonts/truetype/6809char.ttf
/usr/X11R6/lib/X11/fonts/truetype/Balker.ttf
/usr/X11R6/lib/X11/fonts/truetype/COPYING
/usr/X11R6/lib/X11/fonts/truetype/Dustismo.ttf
/usr/X11R6/lib/X11/fonts/truetype/Dustismo_Roman.ttf
/usr/X11R6/lib/X11/fonts/truetype/Dustismo_Roman_Bold.ttf
/usr/X11R6/lib/X11/fonts/truetype/Dustismo_Roman_Italic.ttf
/usr/X11R6/lib/X11/fonts/truetype/Dustismo_Roman_Italic_Bold.ttf
/usr/X11R6/lib/X11/fonts/truetype/El_Abogado_Loco.ttf
/usr/X11R6/lib/X11/fonts/truetype/Isabella.ttf
/usr/X11R6/lib/X11/fonts/truetype/It wasn't me.ttf
/usr/X11R6/lib/X11/fonts/truetype/Junkyard.ttf
/usr/X11R6/lib/X11/fonts/truetype/MarkedFool.ttf
/usr/X11R6/lib/X11/fonts/truetype/PenguinAttack.ttf
/usr/X11R6/lib/X11/fonts/truetype/Swift.ttf
/usr/X11R6/lib/X11/fonts/truetype/Wargames.ttf
/usr/X11R6/lib/X11/fonts/truetype/Winks.ttf
/usr/X11R6/lib/X11/fonts/truetype/abberanc.ttf
/usr/X11R6/lib/X11/fonts/truetype/adriator.ttf
/usr/X11R6/lib/X11/fonts/truetype/airmole.ttf
/usr/X11R6/lib/X11/fonts/truetype/airmolea.ttf
/usr/X11R6/lib/X11/fonts/truetype/airmoleq.ttf
/usr/X11R6/lib/X11/fonts/truetype/airmoles.ttf
/usr/X11R6/lib/X11/fonts/truetype/almonte.ttf
/usr/X11R6/lib/X11/fonts/truetype/almontew.ttf
/usr/X11R6/lib/X11/fonts/truetype/almosnow.ttf
/usr/X11R6/lib/X11/fonts/truetype/anglepoi.ttf
/usr/X11R6/lib/X11/fonts/truetype/anklepan.ttf
/usr/X11R6/lib/X11/fonts/truetype/arnprior.ttf
/usr/X11R6/lib/X11/fonts/truetype/astronbi.ttf
/usr/X11R6/lib/X11/fonts/truetype/astronbo.ttf
/usr/X11R6/lib/X11/fonts/truetype/astronbv.ttf
/usr/X11R6/lib/X11/fonts/truetype/astronbw.ttf
/usr/X11R6/lib/X11/fonts/truetype/axaxax.ttf
/usr/X11R6/lib/X11/fonts/truetype/babyjeep.ttf
/usr/X11R6/lib/X11/fonts/truetype/baileysc.ttf
/usr/X11R6/lib/X11/fonts/truetype/baltar.ttf
/usr/X11R6/lib/X11/fonts/truetype/barbatri.ttf
/usr/X11R6/lib/X11/fonts/truetype/baveuse.ttf
/usr/X11R6/lib/X11/fonts/truetype/baveuse3.ttf
/usr/X11R6/lib/X11/fonts/truetype/beatmygu.ttf
/usr/X11R6/lib/X11/fonts/truetype/berylibi.ttf
/usr/X11R6/lib/X11/fonts/truetype/beryliub.ttf
/usr/X11R6/lib/X11/fonts/truetype/beryliui.ttf
/usr/X11R6/lib/X11/fonts/truetype/berylium.ttf
/usr/X11R6/lib/X11/fonts/truetype/betsy.ttf
/usr/X11R6/lib/X11/fonts/truetype/biting.ttf
/usr/X11R6/lib/X11/fonts/truetype/bitingou.ttf
/usr/X11R6/lib/X11/fonts/truetype/bluebold.ttf
/usr/X11R6/lib/X11/fonts/truetype/bluecond.ttf
/usr/X11R6/lib/X11/fonts/truetype/bluehigd.ttf
/usr/X11R6/lib/X11/fonts/truetype/bluehigh.ttf
/usr/X11R6/lib/X11/fonts/truetype/bluehigl.ttf
/usr/X11R6/lib/X11/fonts/truetype/borg9.ttf
/usr/X11R6/lib/X11/fonts/truetype/boron2.ttf
/usr/X11R6/lib/X11/fonts/truetype/budmo.ttf
/usr/X11R6/lib/X11/fonts/truetype/budmob.ttf
/usr/X11R6/lib/X11/fonts/truetype/bullpen3.ttf
/usr/X11R6/lib/X11/fonts/truetype/bullpen_.ttf
/usr/X11R6/lib/X11/fonts/truetype/bullpeni.ttf
/usr/X11R6/lib/X11/fonts/truetype/burnstow.ttf
/usr/X11R6/lib/X11/fonts/truetype/butterbe.ttf
/usr/X11R6/lib/X11/fonts/truetype/carbonbl.ttf
/usr/X11R6/lib/X11/fonts/truetype/carbonph.ttf
/usr/X11R6/lib/X11/fonts/truetype/charlesi.ttf
/usr/X11R6/lib/X11/fonts/truetype/chineser.ttf
/usr/X11R6/lib/X11/fonts/truetype/cmex10.ttf
/usr/X11R6/lib/X11/fonts/truetype/cmmi10.ttf
/usr/X11R6/lib/X11/fonts/truetype/cmr10.ttf
/usr/X11R6/lib/X11/fonts/truetype/cmsy10.ttf
/usr/X11R6/lib/X11/fonts/truetype/colourba.ttf
/usr/X11R6/lib/X11/fonts/truetype/colourbb.ttf
/usr/X11R6/lib/X11/fonts/truetype/contourg.ttf
/usr/X11R6/lib/X11/fonts/truetype/coolveti.ttf
/usr/X11R6/lib/X11/fonts/truetype/counters.ttf
/usr/X11R6/lib/X11/fonts/truetype/crackman.ttf
/usr/X11R6/lib/X11/fonts/truetype/cranberr.ttf
/usr/X11R6/lib/X11/fonts/truetype/creditri.ttf
/usr/X11R6/lib/X11/fonts/truetype/creditva.ttf
/usr/X11R6/lib/X11/fonts/truetype/creditvb.ttf
/usr/X11R6/lib/X11/fonts/truetype/creditvi.ttf
/usr/X11R6/lib/X11/fonts/truetype/creditvz.ttf
/usr/X11R6/lib/X11/fonts/truetype/cretino_.ttf
/usr/X11R6/lib/X11/fonts/truetype/crystalr.ttf
/usr/X11R6/lib/X11/fonts/truetype/cuomotyp.ttf
/usr/X11R6/lib/X11/fonts/truetype/deftone.ttf
/usr/X11R6/lib/X11/fonts/truetype/degrassi.ttf
/usr/X11R6/lib/X11/fonts/truetype/deltahey.ttf
/usr/X11R6/lib/X11/fonts/truetype/dendriti.ttf
/usr/X11R6/lib/X11/fonts/truetype/dienasty.ttf
/usr/X11R6/lib/X11/fonts/truetype/dignity.ttf
/usr/X11R6/lib/X11/fonts/truetype/dirtydoz.ttf
/usr/X11R6/lib/X11/fonts/truetype/dreamobx.ttf
/usr/X11R6/lib/X11/fonts/truetype/dreamorb.ttf
/usr/X11R6/lib/X11/fonts/truetype/dreamori.ttf
/usr/X11R6/lib/X11/fonts/truetype/dreamorp.ttf
/usr/X11R6/lib/X11/fonts/truetype/droid___.ttf
/usr/X11R6/lib/X11/fonts/truetype/duality_.ttf
/usr/X11R6/lib/X11/fonts/truetype/dustismo_bold.ttf
/usr/X11R6/lib/X11/fonts/truetype/dustismo_bold_italic.ttf
/usr/X11R6/lib/X11/fonts/truetype/dustismo_italic.ttf
/usr/X11R6/lib/X11/fonts/truetype/dyspepsi.ttf
/usr/X11R6/lib/X11/fonts/truetype/earwigfa.ttf
/usr/X11R6/lib/X11/fonts/truetype/echec___.ttf
/usr/X11R6/lib/X11/fonts/truetype/echeci__.ttf
/usr/X11R6/lib/X11/fonts/truetype/echei___.ttf
/usr/X11R6/lib/X11/fonts/truetype/echelon_.ttf
/usr/X11R6/lib/X11/fonts/truetype/edenm___.ttf
/usr/X11R6/lib/X11/fonts/truetype/edenmb__.ttf
/usr/X11R6/lib/X11/fonts/truetype/edenmi__.ttf
/usr/X11R6/lib/X11/fonts/truetype/edmundis.ttf
/usr/X11R6/lib/X11/fonts/truetype/edmunds.ttf
/usr/X11R6/lib/X11/fonts/truetype/efflanti.ttf
/usr/X11R6/lib/X11/fonts/truetype/efflb___.ttf
/usr/X11R6/lib/X11/fonts/truetype/efflbi__.ttf
/usr/X11R6/lib/X11/fonts/truetype/effli___.ttf
/usr/X11R6/lib/X11/fonts/truetype/efflores.ttf
/usr/X11R6/lib/X11/fonts/truetype/electbgi.ttf
/usr/X11R6/lib/X11/fonts/truetype/electbgu.ttf
/usr/X11R6/lib/X11/fonts/truetype/electblu.ttf
/usr/X11R6/lib/X11/fonts/truetype/electroh.ttf
/usr/X11R6/lib/X11/fonts/truetype/engeboit.ttf
/usr/X11R6/lib/X11/fonts/truetype/engebold.ttf
/usr/X11R6/lib/X11/fonts/truetype/engeexbi.ttf
/usr/X11R6/lib/X11/fonts/truetype/engeexbo.ttf
/usr/X11R6/lib/X11/fonts/truetype/engeexit.ttf
/usr/X11R6/lib/X11/fonts/truetype/engeexpa.ttf
/usr/X11R6/lib/X11/fonts/truetype/engeital.ttf
/usr/X11R6/lib/X11/fonts/truetype/engeregu.ttf
/usr/X11R6/lib/X11/fonts/truetype/ennobled.ttf
/usr/X11R6/lib/X11/fonts/truetype/ethnocen.ttf
/usr/X11R6/lib/X11/fonts/truetype/euphorig.ttf
/usr/X11R6/lib/X11/fonts/truetype/fabian__.ttf
/usr/X11R6/lib/X11/fonts/truetype/fadgod.ttf
/usr/X11R6/lib/X11/fonts/truetype/failed.ttf
/usr/X11R6/lib/X11/fonts/truetype/fakerece.ttf
/usr/X11R6/lib/X11/fonts/truetype/flatline.ttf
/usr/X11R6/lib/X11/fonts/truetype/fluoride.ttf
/usr/X11R6/lib/X11/fonts/truetype/foo.ttf
/usr/X11R6/lib/X11/fonts/truetype/forgotbi.ttf
/usr/X11R6/lib/X11/fonts/truetype/forgottb.ttf
/usr/X11R6/lib/X11/fonts/truetype/forgotte.ttf
/usr/X11R6/lib/X11/fonts/truetype/forgotti.ttf
/usr/X11R6/lib/X11/fonts/truetype/forgotts.ttf
/usr/X11R6/lib/X11/fonts/truetype/fragileb.ttf
/usr/X11R6/lib/X11/fonts/truetype/frozen.ttf
/usr/X11R6/lib/X11/fonts/truetype/ghostmea.ttf
/usr/X11R6/lib/X11/fonts/truetype/goldengi.ttf
/usr/X11R6/lib/X11/fonts/truetype/goodfisb.ttf
/usr/X11R6/lib/X11/fonts/truetype/goodfisc.ttf
/usr/X11R6/lib/X11/fonts/truetype/goodfish.ttf
/usr/X11R6/lib/X11/fonts/truetype/goodfisi.ttf
/usr/X11R6/lib/X11/fonts/truetype/goodtime.ttf
/usr/X11R6/lib/X11/fonts/truetype/gotnohea.ttf
/usr/X11R6/lib/X11/fonts/truetype/graffiti.ttf
/usr/X11R6/lib/X11/fonts/truetype/greenfuz.ttf
/usr/X11R6/lib/X11/fonts/truetype/groovygh.ttf
/usr/X11R6/lib/X11/fonts/truetype/guanine_.ttf
/usr/X11R6/lib/X11/fonts/truetype/gunplay.ttf
/usr/X11R6/lib/X11/fonts/truetype/gunplay3.ttf
/usr/X11R6/lib/X11/fonts/truetype/gyparody.ttf
/usr/X11R6/lib/X11/fonts/truetype/heartswe.ttf
/usr/X11R6/lib/X11/fonts/truetype/heavyhea.ttf
/usr/X11R6/lib/X11/fonts/truetype/heck.ttf
/usr/X11R6/lib/X11/fonts/truetype/hellolar.ttf
/usr/X11R6/lib/X11/fonts/truetype/hemihead.ttf
/usr/X11R6/lib/X11/fonts/truetype/homeswee.ttf
/usr/X11R6/lib/X11/fonts/truetype/homesweo.ttf
/usr/X11R6/lib/X11/fonts/truetype/hots.ttf
/usr/X11R6/lib/X11/fonts/truetype/hurryup.ttf
/usr/X11R6/lib/X11/fonts/truetype/huskysta.ttf
/usr/X11R6/lib/X11/fonts/truetype/hydrogen.ttf
/usr/X11R6/lib/X11/fonts/truetype/inflamma.ttf
/usr/X11R6/lib/X11/fonts/truetype/interpla.ttf
/usr/X11R6/lib/X11/fonts/truetype/iomanoid.ttf
/usr/X11R6/lib/X11/fonts/truetype/joystix.ttf
/usr/X11R6/lib/X11/fonts/truetype/junegull.ttf
/usr/X11R6/lib/X11/fonts/truetype/kenyc___.ttf
/usr/X11R6/lib/X11/fonts/truetype/kenycb__.ttf
/usr/X11R6/lib/X11/fonts/truetype/kenycbi_.ttf
/usr/X11R6/lib/X11/fonts/truetype/kenyci__.ttf
/usr/X11R6/lib/X11/fonts/truetype/kickingl.ttf
/usr/X11R6/lib/X11/fonts/truetype/kimbalt_.ttf
/usr/X11R6/lib/X11/fonts/truetype/kimberle.ttf
/usr/X11R6/lib/X11/fonts/truetype/kingrich.ttf
/usr/X11R6/lib/X11/fonts/truetype/kingrici.ttf
/usr/X11R6/lib/X11/fonts/truetype/kirsty__.ttf
/usr/X11R6/lib/X11/fonts/truetype/kirsty_b.ttf
/usr/X11R6/lib/X11/fonts/truetype/kirsty_i.ttf
/usr/X11R6/lib/X11/fonts/truetype/kirstybi.ttf
/usr/X11R6/lib/X11/fonts/truetype/kirstyin.ttf
/usr/X11R6/lib/X11/fonts/truetype/kleptocr.ttf
/usr/X11R6/lib/X11/fonts/truetype/kredit1.ttf
/usr/X11R6/lib/X11/fonts/truetype/ladystar.ttf
/usr/X11R6/lib/X11/fonts/truetype/larabieb.ttf
/usr/X11R6/lib/X11/fonts/truetype/larabief.ttf
/usr/X11R6/lib/X11/fonts/truetype/let'seat.ttf
/usr/X11R6/lib/X11/fonts/truetype/lettera.ttf
/usr/X11R6/lib/X11/fonts/truetype/letterb.ttf
/usr/X11R6/lib/X11/fonts/truetype/letterc.ttf
/usr/X11R6/lib/X11/fonts/truetype/lewinsky.ttf
/usr/X11R6/lib/X11/fonts/truetype/lilliput.ttf
/usr/X11R6/lib/X11/fonts/truetype/livingby.ttf
/usr/X11R6/lib/X11/fonts/truetype/lockergn.ttf
/usr/X11R6/lib/X11/fonts/truetype/luckyape.ttf
/usr/X11R6/lib/X11/fonts/truetype/lunasol.ttf
/usr/X11R6/lib/X11/fonts/truetype/mailrays.ttf
/usr/X11R6/lib/X11/fonts/truetype/malache.ttf
/usr/X11R6/lib/X11/fonts/truetype/mapofyou.ttf
/usr/X11R6/lib/X11/fonts/truetype/marqueem.ttf
/usr/X11R6/lib/X11/fonts/truetype/metalord.ttf
/usr/X11R6/lib/X11/fonts/truetype/mexcel3d.ttf
/usr/X11R6/lib/X11/fonts/truetype/mexcelle.ttf
/usr/X11R6/lib/X11/fonts/truetype/minisyst.ttf
/usr/X11R6/lib/X11/fonts/truetype/minyn___.ttf
/usr/X11R6/lib/X11/fonts/truetype/minynb__.ttf
/usr/X11R6/lib/X11/fonts/truetype/minynbi_.ttf
/usr/X11R6/lib/X11/fonts/truetype/minyni__.ttf
/usr/X11R6/lib/X11/fonts/truetype/misirlod.ttf
/usr/X11R6/lib/X11/fonts/truetype/misirlou.ttf
/usr/X11R6/lib/X11/fonts/truetype/mobconcr.ttf
/usr/X11R6/lib/X11/fonts/truetype/modelwor.ttf
/usr/X11R6/lib/X11/fonts/truetype/monofont.ttf
/usr/X11R6/lib/X11/fonts/truetype/motorcad.ttf
/usr/X11R6/lib/X11/fonts/truetype/msam10.ttf
/usr/X11R6/lib/X11/fonts/truetype/msbm10.ttf
/usr/X11R6/lib/X11/fonts/truetype/mufferaw.ttf
/usr/X11R6/lib/X11/fonts/truetype/nafta.ttf
/usr/X11R6/lib/X11/fonts/truetype/nasaliza.ttf
/usr/X11R6/lib/X11/fonts/truetype/neurochr.ttf
/usr/X11R6/lib/X11/fonts/truetype/neuropol.ttf
/usr/X11R6/lib/X11/fonts/truetype/neurpoli.ttf
/usr/X11R6/lib/X11/fonts/truetype/newbrill.ttf
/usr/X11R6/lib/X11/fonts/truetype/numberpi.ttf
/usr/X11R6/lib/X11/fonts/truetype/octovill.ttf
/usr/X11R6/lib/X11/fonts/truetype/oilcrisa.ttf
/usr/X11R6/lib/X11/fonts/truetype/oilcrisb.ttf
/usr/X11R6/lib/X11/fonts/truetype/oliversb.ttf
/usr/X11R6/lib/X11/fonts/truetype/orangeki.ttf
/usr/X11R6/lib/X11/fonts/truetype/pakenham.ttf
/usr/X11R6/lib/X11/fonts/truetype/pantspat.ttf
/usr/X11R6/lib/X11/fonts/truetype/planetbe.ttf
/usr/X11R6/lib/X11/fonts/truetype/plasmati.ttf
/usr/X11R6/lib/X11/fonts/truetype/plasticb.ttf
/usr/X11R6/lib/X11/fonts/truetype/pobeef.ttf
/usr/X11R6/lib/X11/fonts/truetype/poke.ttf
/usr/X11R6/lib/X11/fonts/truetype/popup.ttf
/usr/X11R6/lib/X11/fonts/truetype/presgrg.ttf
/usr/X11R6/lib/X11/fonts/truetype/pricedow.ttf
/usr/X11R6/lib/X11/fonts/truetype/prima___.ttf
/usr/X11R6/lib/X11/fonts/truetype/primemin.ttf
/usr/X11R6/lib/X11/fonts/truetype/primer.ttf
/usr/X11R6/lib/X11/fonts/truetype/primerb.ttf
/usr/X11R6/lib/X11/fonts/truetype/pupcat__.ttf
/usr/X11R6/lib/X11/fonts/truetype/quadapto.ttf
/usr/X11R6/lib/X11/fonts/truetype/quixotic.ttf
/usr/X11R6/lib/X11/fonts/truetype/radiohar.ttf
/usr/X11R6/lib/X11/fonts/truetype/radiosin.ttf
/usr/X11R6/lib/X11/fonts/truetype/rafika__.ttf
/usr/X11R6/lib/X11/fonts/truetype/razorkee.ttf
/usr/X11R6/lib/X11/fonts/truetype/readme.latex-fonts
/usr/X11R6/lib/X11/fonts/truetype/relishga.ttf
/usr/X11R6/lib/X11/fonts/truetype/rina.ttf
/usr/X11R6/lib/X11/fonts/truetype/rustproo.ttf
/usr/X11R6/lib/X11/fonts/truetype/sandoval.ttf
/usr/X11R6/lib/X11/fonts/truetype/sappm___.ttf
/usr/X11R6/lib/X11/fonts/truetype/savedbyz.ttf
/usr/X11R6/lib/X11/fonts/truetype/screenge.ttf
/usr/X11R6/lib/X11/fonts/truetype/sexsmith.ttf
/usr/X11R6/lib/X11/fonts/truetype/shifty.ttf
/usr/X11R6/lib/X11/fonts/truetype/shlop___.ttf
/usr/X11R6/lib/X11/fonts/truetype/shouldve.ttf
/usr/X11R6/lib/X11/fonts/truetype/shouldvs.ttf
/usr/X11R6/lib/X11/fonts/truetype/skeletor.ttf
/usr/X11R6/lib/X11/fonts/truetype/sloegin.ttf
/usr/X11R6/lib/X11/fonts/truetype/sofachri.ttf
/usr/X11R6/lib/X11/fonts/truetype/sofachro.ttf
/usr/X11R6/lib/X11/fonts/truetype/spongy.ttf
/usr/X11R6/lib/X11/fonts/truetype/squealem.ttf
/usr/X11R6/lib/X11/fonts/truetype/squealer.ttf
/usr/X11R6/lib/X11/fonts/truetype/steelfib.ttf
/usr/X11R6/lib/X11/fonts/truetype/steelfis.ttf
/usr/X11R6/lib/X11/fonts/truetype/steelout.ttf
/usr/X11R6/lib/X11/fonts/truetype/stereofi.ttf
/usr/X11R6/lib/X11/fonts/truetype/stilltim.ttf
/usr/X11R6/lib/X11/fonts/truetype/streetcr.ttf
/usr/X11R6/lib/X11/fonts/truetype/strenu3d.ttf
/usr/X11R6/lib/X11/fonts/truetype/strenuou.ttf
/usr/X11R6/lib/X11/fonts/truetype/styrofoa.ttf
/usr/X11R6/lib/X11/fonts/truetype/subpear_.ttf
/usr/X11R6/lib/X11/fonts/truetype/sudbury.ttf
/usr/X11R6/lib/X11/fonts/truetype/sudbury3.ttf
/usr/X11R6/lib/X11/fonts/truetype/suigb___.ttf
/usr/X11R6/lib/X11/fonts/truetype/suigbi__.ttf
/usr/X11R6/lib/X11/fonts/truetype/suigener.ttf
/usr/X11R6/lib/X11/fonts/truetype/suigi___.ttf
/usr/X11R6/lib/X11/fonts/truetype/superglu.ttf
/usr/X11R6/lib/X11/fonts/truetype/sybig___.ttf
/usr/X11R6/lib/X11/fonts/truetype/teen____.ttf
/usr/X11R6/lib/X11/fonts/truetype/teenbdit.ttf
/usr/X11R6/lib/X11/fonts/truetype/teenbold.ttf
/usr/X11R6/lib/X11/fonts/truetype/teenital.ttf
/usr/X11R6/lib/X11/fonts/truetype/teenlita.ttf
/usr/X11R6/lib/X11/fonts/truetype/teenlite.ttf
/usr/X11R6/lib/X11/fonts/truetype/terylene.ttf
/usr/X11R6/lib/X11/fonts/truetype/thiamine.ttf
/usr/X11R6/lib/X11/fonts/truetype/tinsnips.ttf
/usr/X11R6/lib/X11/fonts/truetype/tork____.ttf
/usr/X11R6/lib/X11/fonts/truetype/torkb___.ttf
/usr/X11R6/lib/X11/fonts/truetype/torkbi__.ttf
/usr/X11R6/lib/X11/fonts/truetype/torki___.ttf
/usr/X11R6/lib/X11/fonts/truetype/trapperj.ttf
/usr/X11R6/lib/X11/fonts/truetype/triacsev.ttf
/usr/X11R6/lib/X11/fonts/truetype/trollbai.ttf
/usr/X11R6/lib/X11/fonts/truetype/typoderm.ttf
/usr/X11R6/lib/X11/fonts/truetype/unioncit.ttf
/usr/X11R6/lib/X11/fonts/truetype/unisb___.ttf
/usr/X11R6/lib/X11/fonts/truetype/unisbi__.ttf
/usr/X11R6/lib/X11/fonts/truetype/unisi___.ttf
/usr/X11R6/lib/X11/fonts/truetype/unispace.ttf
/usr/X11R6/lib/X11/fonts/truetype/univox.ttf
/usr/X11R6/lib/X11/fonts/truetype/unsteady.ttf
/usr/X11R6/lib/X11/fonts/truetype/urkelian.ttf
/usr/X11R6/lib/X11/fonts/truetype/vademecu.ttf
/usr/X11R6/lib/X11/fonts/truetype/vahika_.ttf
/usr/X11R6/lib/X11/fonts/truetype/vahikab.ttf
/usr/X11R6/lib/X11/fonts/truetype/vahikac.ttf
/usr/X11R6/lib/X11/fonts/truetype/vahikai.ttf
/usr/X11R6/lib/X11/fonts/truetype/vanilla.ttf
/usr/X11R6/lib/X11/fonts/truetype/vdub.ttf
/usr/X11R6/lib/X11/fonts/truetype/vectroid.ttf
/usr/X11R6/lib/X11/fonts/truetype/velvenda.ttf
/usr/X11R6/lib/X11/fonts/truetype/velvendc.ttf
/usr/X11R6/lib/X11/fonts/truetype/venusris.ttf
/usr/X11R6/lib/X11/fonts/truetype/vibroceb.ttf
/usr/X11R6/lib/X11/fonts/truetype/vibrocei.ttf
/usr/X11R6/lib/X11/fonts/truetype/vibrocen.ttf
/usr/X11R6/lib/X11/fonts/truetype/vibrocex.ttf
/usr/X11R6/lib/X11/fonts/truetype/vinque.ttf
/usr/X11R6/lib/X11/fonts/truetype/vipnagor.ttf
/usr/X11R6/lib/X11/fonts/truetype/wakebake.ttf
/usr/X11R6/lib/X11/fonts/truetype/walshes.ttf
/usr/X11R6/lib/X11/fonts/truetype/wasy10.ttf
/usr/X11R6/lib/X11/fonts/truetype/welfareb.ttf
/usr/X11R6/lib/X11/fonts/truetype/wildsewe.ttf
/usr/X11R6/lib/X11/fonts/truetype/wintermu.ttf
/usr/X11R6/lib/X11/fonts/truetype/worldofw.ttf
/usr/X11R6/lib/X11/fonts/truetype/xolto.ttf
/usr/X11R6/lib/X11/fonts/truetype/yonderre.ttf
/usr/X11R6/lib/X11/fonts/truetype/youregoi.ttf
/usr/X11R6/lib/X11/fonts/truetype/youregon.ttf
/usr/X11R6/lib/X11/fonts/truetype/yytriumd.ttf
/usr/X11R6/lib/X11/fonts/truetype/zekton__.ttf
/usr/X11R6/lib/X11/fonts/truetype/zektonbi.ttf
/usr/X11R6/lib/X11/fonts/truetype/zektonbo.ttf
/usr/X11R6/lib/X11/fonts/truetype/zektondo.ttf
/usr/X11R6/lib/X11/fonts/truetype/zektonit.ttf
/usr/X11R6/lib/X11/fonts/truetype/zeroes__.ttf
/usr/X11R6/lib/X11/fonts/truetype/zerohour.ttf
/usr/X11R6/lib/X11/fonts/truetype/zerothre.ttf
/usr/X11R6/lib/X11/fonts/truetype/zerotwos.ttf
/usr/X11R6/lib/X11/fonts/truetype/zodillin.ttf
/usr/X11R6/lib/X11/fonts/truetype/zorque.ttf
/usr/X11R6/lib/X11/fonts/truetype/zrnic___.ttf
/usr/share/doc/packages/free-ttf-fonts
/usr/share/doc/packages/free-ttf-fonts/README.txt
/usr/share/doc/packages/free-ttf-fonts/betsy.txt
/usr/share/doc/packages/free-ttf-fonts/counters.txt
/usr/share/doc/packages/free-ttf-fonts/installation.txt
/usr/share/doc/packages/free-ttf-fonts/license.txt
/usr/share/doc/packages/free-ttf-fonts/read_me.txt
/usr/share/doc/packages/free-ttf-fonts/teen.txt

> Could it be caused by bogus aliasing?

Here are the scripts that rpm executes:

postinstall scriptlet (through /bin/sh):


   if test "$YAST_IS_RUNNING" != "instsys" ; then
     if test -x /sbin/SuSEconfig -a -f /sbin/conf.d/SuSEconfig.fonts ; then
       /sbin/SuSEconfig --module fonts
     else
       echo -e "\nERROR: SuSEconfig or requested SuSEconfig module not
present!\n" ; exit 1
     fi
   fi
   if [ -x sbin/conf.d/SuSEconfig.pango ]; then


   if test "$YAST_IS_RUNNING" != "instsys" ; then
     if test -x /sbin/SuSEconfig -a -f /sbin/conf.d/SuSEconfig.pango ; then
       /sbin/SuSEconfig --module pango
     else
       echo -e "\nERROR: SuSEconfig or requested SuSEconfig module not
present!\n" ; exit 1
     fi
   fi
   fi
postuninstall scriptlet (through /bin/sh):


   if test "$YAST_IS_RUNNING" != "instsys" ; then
     if test -x /sbin/SuSEconfig -a -f /sbin/conf.d/SuSEconfig.fonts ; then
       /sbin/SuSEconfig --module fonts
     else
       echo -e "\nERROR: SuSEconfig or requested SuSEconfig module not
present!\n" ; exit 1
     fi
   fi
   if [ -x sbin/conf.d/SuSEconfig.pango ]; then


   if test "$YAST_IS_RUNNING" != "instsys" ; then
     if test -x /sbin/SuSEconfig -a -f /sbin/conf.d/SuSEconfig.pango ; then
       /sbin/SuSEconfig --module pango
     else
       echo -e "\nERROR: SuSEconfig or requested SuSEconfig module not
present!\n" ; exit 1
     fi
   fi
   fi

Comment 11

15 years ago
I think I have a similar problem. Parts of the print-out are in Greek-like fonts
(How much depends on the site. Eg. www.kitag.com). In the preview everything is ok.
(Reporter)

Comment 12

14 years ago
I solved the problem by removing the RPMs that came with SuSE 9.1 and
installing a fresh copy of Mozilla 1.7.  Works great now, in spite of
minor glitches during the conversion.

Comment 13

14 years ago
Not a bug in Mozilla then, but weirdness in a SuSE 9.1 font package.
Resolving as invalid per reporters comment #12.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.