Status

()

Core
Networking: Cookies
--
enhancement
RESOLVED WONTFIX
14 years ago
14 years ago

People

(Reporter: omri, Assigned: Darin Fisher)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040315
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040315

It would be nice if we were able to save the cookies in the bookmarks or in a
file, for multiple login accounts.
For example, if I have 3 web hosting accounts (quota isn't enough :)), and I
want to switch between them, well, usually I'm just using the one which has free
space, but some times I want to search for a file, so I have to logout, and
re-login with the other accounts, and look for that file.
The idea is to have a cookie "brifcase", which I will be able to load cookie
sets from it, one cookie set for each user.
For example:
cookie set 1: username=X, password=123, autologin=true
cookie set 2: username=Y, password=456, autologin=true
cookie set 3: username=Z, password=789, autologin=true

When I want to switch to another account, I just load one of the cookie sets and
just refresh the page :)

Reproducible: Always
Steps to Reproduce:
Feature request.
Actual Results:  
Feature request.

Expected Results:  
Feature request.

Feature request.

Comment 1

14 years ago
Ok i think it whould be comfertable,you got my voice :P 
Assignee: general → darin
Component: Browser-General → Networking: Cookies
QA Contact: general → core.networking.cookies
if you want multiple cookie sets, use multiple profiles.  Also, cookie sets
alone wouldn't necessarily work as well as you'd like, since if its an SSL
connection it may also be using that session information.

Using password manager, this should be a two or three click operation anyway, so
the benefit is dubious vs. the code it would take to support this.

WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.