PDF Plugin doesn't work when Java is disabled

VERIFIED FIXED

Status

Camino Graveyard
Plug-ins
VERIFIED FIXED
14 years ago
13 years ago

People

(Reporter: Eiichi, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040521 Camino/0.8b+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040521 Camino/0.8b+

1) Platform : Mac OS X 10.3.3, PDF Browser Plugin 2.0.1
2) PDF Browser Plugin doesn't work initially.
3) But after typing "about:plugins" in Location field and hitting "Return" or
"Enter" key, it works.

Reproducible: Always
Steps to Reproduce:
1) Launch Camino
2) Go to http://docs.info.apple.com/article.html?artnum=50053
3) Click any PDF file
Actual Results:  
PDF Browser Plugin doesn't work initially.

Expected Results:  
PDF Browser Plugin works initially.
(Reporter)

Comment 1

14 years ago
PDF Browser Plugin works in Firefox (0.8.0+) 20040519 NB without downloading PDF
file.
But Camino (v0.8b+) 20040522 NB downloads PDF file without "about:plugins".

Comment 2

14 years ago
WFM using Camino/0.8b and PDF Plug-in 2.0.1 on OS X 10.3.3. On first access the
Plug-in registration dialog appears; I select Personal Use Only and the
requested PDF file then displays just fine.
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)
When you quit and relaunch Camino, does PDF Plug-in work without downloading file?

Comment 4

14 years ago
Yes.
(Reporter)

Comment 5

14 years ago
I deleted my profile and plist, then on first access PDF Plug-in works fine.
But when I quit and relaunch Camino, PDF Plug-in doesn't work and downloads a file.

Comment 6

14 years ago
Eiichi, try with a new OS user profile.
(Reporter)

Comment 7

14 years ago
I'm yet to try with a new OS user profile.
But in Camino 0.7(Release) PDF Plug-in works fine.

Comment 8

14 years ago
Note that Camino 0.7 uses the ~/Library/Chimera profile, not the
~/Library/Camino. So if there's something wrong with your newer Camino profile,
it wouldn't show up it 0.7.

Have you tried just using a clean Camino profile by moving ~/Library/Camino?
(Reporter)

Comment 9

14 years ago
(In reply to comment #8)
Now I confirm ;
In Preferences / Web Features
1) When "Enable Java" is unchecked, PDF Plug-in doesn't work.
2) When "Enable Java" is checked, PDF Plug-in works.

Can you confirm this is reproducible?
(Reporter)

Updated

14 years ago
Summary: PDF Browser Plugin doesn't work initially → PDF Plugin doesn't work when Java is disabled

Comment 10

14 years ago
(In reply to comment #9)
> (In reply to comment #8)
> Can you confirm this is reproducible?

Yes, I can reproduce this. After turning off "Enable Java" and restarting Camino 0.8b, plug-ins in *full 
mode* don't work any more (tested with QuickTime and PDF Browser Plugin). Embedded they continue 
to work. Odd.
(Reporter)

Comment 11

14 years ago
For reference:

A. Camino 0.8b
1) PDF Plug-in doesn't work when Java is turned off.
2) Whenever Camino loads QuickTime and PDF Plugin, Console logs;
__________________________________________
/Applications/Camino.app/Contents/MacOS/Camino: can't map file:
/Library/Internet Plug-Ins/QuickTime Plugin.plugin ((os/kern) invalid argument)
/Applications/Camino.app/Contents/MacOS/Camino: can't map file:
/Library/Internet Plug-Ins/PDF Browser Plugin.plugin ((os/kern) invalid argument)
__________________________________________

B. Camino 0.7(Release) 
1) PDF Plug-in works fine though Java is turned off.
2) When Camino loads QuickTime and PDF Browser Plugin, Console logs nothing.

Comment 12

14 years ago
Marking Confirmed per comment 10.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 13

14 years ago
I think this and bug 199203 should be fixed in 0.8, because 0.7 didn't have
these bugs.
This is regression.
Probalby dupe/related on Bug 220730
(Reporter)

Comment 15

13 years ago
Testing with nightly build 3/1/05 this problem seems to be
resolved due to fixing Bug 220730.

Can anyone confirm this?

Comment 16

13 years ago
Probably fixed. Can someone test?
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Verified with v2.2.2 of the PDF plugin.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.