Privacy Policy Preferences does not display using LINK tag

RESOLVED DUPLICATE of bug 211096

Status

()

Core
Networking: Cookies
RESOLVED DUPLICATE of bug 211096
14 years ago
14 years ago

People

(Reporter: John Walsh, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007

On the "Privacy" tab of Page Info, I click on the "Summary" button for
http://home.iprimus.com.au/nikki_le_poidevin/ but nothing is displayed. The
Privacy Summary for the site should be displayed. The P3P validator at
http://www.w3.org/P3P/validator.html validates my code so the problem must be
with Mozilla. 
Most sites put the p3p files in a "w3c" directory and it displays a summary for
these sites. I use the (X)HTML LINK tag to point to my p3p files, which is part
of the P3P standard, but it doesn't display a summary when the LINK tag is used.
This also happens at http://venus.unive.it/philo/ which also validates for P3P
validator. 
BTW, I also noticed there is no help for the Privacy tab. 
This is the first time I have submitted a bug so I hope I gave you enough info.  

Reproducible: Always
Steps to Reproduce:
1. Go to http://home.iprimus.com.au/nikki_le_poidevin/
2. Press CTRL+I for Page Info
3. Click Privacy Tab
4. Click Summary button 
(The same happens for http://venus.unive.it/philo/)
Actual Results:  
"Unable to display privacy summary for
http://home.iprimus.com.au/nikki_le_poidevin/. Either the site does not have a
published privacy policy or it could not be found."

Expected Results:  
The Policy Summary should be displayed.
P3P is under cookies, I guess....
Assignee: db48x → darin
Component: Page Info → Networking: Cookies
QA Contact: core.networking.cookies
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> P3P is under cookies, I guess....

P3P uses XML files. I don't create cookies. The bug is on the Privacy tab of the
Page Info page. Why is it assigned as a cookie problem/component? 

Comment 3

14 years ago
the short answer is: because there's no component for p3p, and p3p is somewhat
related to cookies.

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 211096 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.