Update Classic theme with new icons

VERIFIED DUPLICATE of bug 150535

Status

SeaMonkey
Themes
--
enhancement
VERIFIED DUPLICATE of bug 150535
14 years ago
9 years ago

People

(Reporter: Prognathous, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
The current Classic icon set looks very outdated and too resembling of the one
used in the infamous Netscape 4.x. A new Classic icon set should show the same
roots (otherwise it won't be "Classic"...), but should also be updated enough to
look current and fresh.

Bug 192225 offers one option (adopting the freedesktop theme), but I don't think
we should use third party icons. Mozilla should have its own icon set. This will
help build brand and app recognition, blending with other applications won't.

Prog.
Someone needs to create some icons before there's anything to discuss...
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Someone needs to create some icons before there's anything to discuss...

Apparently Daniel Wang has "neoclassic graphics' in the oven:
http://bugzilla.mozilla.org/show_bug.cgi?id=218329#c8

Prog.

Comment 3

14 years ago
dupe of bug 150535, which was wontfixed in the days when phoenix was expected to
replace AppSuite.
(Reporter)

Comment 4

14 years ago
Indeed.

*** This bug has been marked as a duplicate of 150535 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 5

14 years ago
> Someone needs to create some icons before there's anything to discuss...

Why not simply respect freedesktop's icon theme standard, and use the icons from
whichever icon theme is in use ?

http://freedesktop.org/Standards/icon-theme-spec

Updated

14 years ago
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.