alternative to modal alert mechanism needed

RESOLVED DUPLICATE of bug 123440

Status

--
enhancement
RESOLVED DUPLICATE of bug 123440
15 years ago
14 years ago

People

(Reporter: moz, Assigned: sspitzer)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: 

One of the IMAP servers I have to connect to has a habit of dropping connections
and timing out.  When this happens, I am interrupted by an Alert box telling me
of the problem.

I know about the problem, I'm expecting it, and yet I still get interrupted by a
modal box.  What I'd like to happen, is that the alert should be logged, and
then viewed at my leisure.

I can think of two ways of handling this...
1) for integration with both firefox and thunderbird I see either a sidebar, or
something like the download manager, which shows queued alerts, where each can
be acknowledged as necessary.
2) for thunderbird only - it's a message system so why not "deliver" the message
 into a mailbox, either a box that exists already or a virtual one for alerts.


Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 123440 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.