Mozilla can't handle filenames with the #-character in them?

RESOLVED DUPLICATE of bug 151850

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 151850
14 years ago
14 years ago

People

(Reporter: Erik Åkerlund, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a1) Gecko/20040520
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a1) Gecko/20040520

I was working on a page and noticed that Mozilla wouldn't display any images if
they had a #-character in them ("Viktor och Kenan#1.JPG" for example).

I had to remove the #-sign to make it work.

Reproducible: Always
Steps to Reproduce:
1.See description
2.
3.

Actual Results:  
The image wouldn't show

Expected Results:  
The image was supposed to show

Comment 1

14 years ago
seems to wfm using FF 20040523 on Win2k, can you attach or point to such an
image (using IE6 if Mozilla doesn't work) ?
'#' signs in URLs denote fragment identifiers and need escaping.
(Reporter)

Comment 4

14 years ago
Created attachment 149261 [details]
This is one of them files that wouldn't work

I guess someone explained pretty good in the comments why the images wouldn't
show, but just for the record, here is one that wouldn't show.
Oh, and also, I made the page using Dreamweaver MX 2004 (so it generated the
HTML that wouldn't work in Mozilla but in IE6).
(Reporter)

Comment 5

14 years ago
Created attachment 149262 [details]
A zip-file containing one of the images that wouldn't work/show

I guess someone explained pretty good in the comments why the images wouldn't
show, but just for the record, here is one that wouldn't show.
Oh, and also, I made the page using Dreamweaver MX 2004 (so it generated the
HTML that wouldn't work in Mozilla but in IE6).

(the first file I uploaded got its filename changed by Bugzilla...not much use
for it then, so here's instead a ZIP-file containing that first file)
Attachment #149261 - Attachment is obsolete: true

Updated

14 years ago
Attachment #149262 - Attachment mime type: application/force-download → application/zip

Comment 6

14 years ago
exactly the same issue, let's track everything in a single bug report.

*** This bug has been marked as a duplicate of 151850 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.