If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

iframe's onload event bubbles to parent contrary to DOM 3 specification

RESOLVED DUPLICATE of bug 196057

Status

()

Core
DOM: Events
RESOLVED DUPLICATE of bug 196057
14 years ago
4 years ago

People

(Reporter: Justin Turner Arthur, Unassigned)

Tracking

({dom2})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

191 bytes, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040322
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040322

In an XUL document, upon the successful loading of an iframe element, I have
observed the bubbling of the load event, triggering the parent window's onload
script(s). According to the current W3 DOM specifications, the load event should
not bubble (see the table in this section -
http://www.w3.org/TR/2003/NOTE-DOM-Level-3-Events-20031107/events.html#Events-EventTypes-complete).
I will attach a testcase XUL document.

Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
Created attachment 149220 [details]
Testcase XUL document.

Simple XUL testcast. Notice how the alert occurs twice!
(Reporter)

Updated

14 years ago
Keywords: dom2
This is a known issue in XUL; we have a bug on it already....
Whiteboard: DUPEME
Probably a duplicate of bug 196057.
(Reporter)

Comment 4

14 years ago
Agreed, marking as dupe.

*** This bug has been marked as a duplicate of 196057 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.