Even for queries resulting in 3 hits, bugzilla says that "only the 200 most relevant bugs are shown"

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
User Interface
--
trivial
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: Patrick, Assigned: Frédéric Buclin)

Tracking

2.18
Bugzilla 2.18
Bug Flags:
approval +
approval2.18 +

Details

(URL)

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

14 years ago
The following query
http://bugzilla.mozilla.org/buglist.cgi?query_format=specific&bug_status=__all__&product=&content=ving.no
gives me three possible bugs. However, bugzilla still tells me that "Only the
200 most relevant bugs are shown."

This seems like some unpolished UI?

Comment 1

14 years ago
myk - can you still make this happen after bug 237176?
Should be able to, but isn't it as simple as s/the top 200/up to the top 200/?
Reassigning bugs that I'm not actively working on to the default component owner
in order to try to make some sanity out of my personal buglist.  This doesn't
mean the bug isn't being dealt with, just that I'm not the one doing it.  If you
are dealing with this bug, please assign it to yourself.
Assignee: justdave → query-and-buglist
QA Contact: mattyt-bugzilla → default-qa

Comment 4

13 years ago
Sounds like a UI issue, then, more than an actual buglist.cgi issue.
Assignee: query-and-buglist → myk
Component: Query/Bug List → User Interface
(Assignee)

Comment 5

13 years ago
Created attachment 186757 [details] [diff] [review]
fix regression + only display warning when appropriate, v1

Fix a regression due to bug 237176 + display the limitation to the first 200
bugs only if more than 200 bugs are found.
Assignee: myk → LpSolit
Status: UNCONFIRMED → ASSIGNED
Attachment #186757 - Flags: review?(kiko)
(Assignee)

Comment 6

13 years ago
Created attachment 186758 [details] [diff] [review]
2.18 backport, v1
Attachment #186758 - Flags: review?(kiko)
(Assignee)

Updated

13 years ago
OS: Windows XP → All
Target Milestone: --- → Bugzilla 2.18
Version: unspecified → 2.18
(Assignee)

Comment 7

13 years ago
Created attachment 186760 [details] [diff] [review]
patch for the tip, v1.1
Attachment #186757 - Attachment is obsolete: true
Attachment #186760 - Flags: review?(kiko)
(Assignee)

Comment 8

13 years ago
Created attachment 186761 [details] [diff] [review]
2.18 backport, v1.1
Attachment #186758 - Attachment is obsolete: true
Attachment #186761 - Flags: review?(kiko)
(Assignee)

Updated

13 years ago
Attachment #186757 - Flags: review?(kiko)
(Assignee)

Updated

13 years ago
Attachment #186758 - Flags: review?(kiko)

Updated

13 years ago
Attachment #186761 - Flags: review?(kiko) → review+

Updated

13 years ago
Attachment #186760 - Flags: review?(kiko) → review+
(Assignee)

Updated

13 years ago
Flags: approval?
Flags: approval2.18?
Flags: approval?
Flags: approval2.18?
Flags: approval2.18+
Flags: approval+
(Assignee)

Comment 9

13 years ago
Tip:

Checking in buglist.cgi;
/cvsroot/mozilla/webtools/bugzilla/buglist.cgi,v  <--  buglist.cgi
new revision: 1.295; previous revision: 1.294
done
Checking in template/en/default/global/messages.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/messages.html.tmpl,v
 <--  messages.html.tmpl
new revision: 1.28; previous revision: 1.27
done


2.18.1:

Checking in buglist.cgi;
/cvsroot/mozilla/webtools/bugzilla/buglist.cgi,v  <--  buglist.cgi
new revision: 1.255.2.8; previous revision: 1.255.2.7
done
Checking in template/en/default/global/messages.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/messages.html.tmpl,v
 <--  messages.html.tmpl
new revision: 1.22.2.2; previous revision: 1.22.2.1
done
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.