If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

DOM Inspector window closes upon "inspecting" browser.xul [Tabbrowser Extensions]

RESOLVED FIXED

Status

Other Applications
DOM Inspector
RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: Andrew Keyser, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2) Gecko/20040523 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2) Gecko/20040523 Firefox/0.8.0+

When doing theme development it is imperative at times to be able to see the
applied CSS styles on browser chrome elements. When inspecting browser.xul, the
DOM inspector crashes (not the browser) and these errors appear in the JS console:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIWebNavigation.sessionHistory]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://browser/content/browser.js :: prepareForStartup :: line 314"  data: no]
Error: uncaught exception: [Exception... "Component returned failure code:
0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsILocalFile.initWithPath]" 
nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)"  location: "JS frame ::
chrome://browser/content/search.xml :: initialize :: line 31"  data: no]
Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIWebNavigation.sessionHistory]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://browser/content/browser.js :: prepareForStartup :: line 314"  data: no]

Reproducible: Always
Steps to Reproduce:
1. Open up Firefox
2. Install TBE if not already installed
3. Tools -> DOM Inspector
4. File -> Inspect a Window -> <homepage's title>
5. Click Inspect to the right of the address bar.

Actual Results:  
DOM Inspector window closes instantly, reporting the aforementioned JS errors.

Expected Results:  
Be able to see the browser chrome in the Inspector.

Upon opening the DOM Inspector again, you can go File -> Inspect a Window -> and
see that there are now two DOM Inspector windows, one a ghost from the last
operation.
It should also be noted that if you "inspect" the DOM Inspector (in other words,
have 2 dom inspectors in one window, one inspecting the other), you can complete
this operation just fine in the nested DOM Inspector.

This may be a TBE problem, I have notified the author of TBE also.
Sounds like yet another TBE bug to me; this works fine without TBE....
(Reporter)

Comment 2

14 years ago
E-Mail I received from Piro -

"Hello,

>> Reproducible: Always
>> Steps to Reproduce:
>> 1. Open up Firefox
>> 2. Install TBE if not already installed
>> 3. Tools -> DOM Inspector
>> 4. File -> Inspect a Window -> <homepage's title>
>> 5. Click Inspect to the right of the address bar.
>> 
>> Actual Results:  
>> DOM Inspector window closes instantly, reporting the aforementioned JS errors.
>> 
>> Expected Results:  
>> Be able to see the browser chrome in the Inspector.


I confirmed the problem.
It is caused by codes for the "Single Window Mode". TBE reopens new
browser instances as new tabs and closes the window itself, even if the
browser instance is loaded in a frame of the DOM Inspector. I'll add a
code to escape this action for cases like this.

Thanks a lot!

-- SHIMODA "Piro" Hiroshi E-mail: piro@p.club.ne.jp Website:
http://white.sakura.ne.jp/~piro/"

Resolving, should be fixed soon.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Core → Other Applications
Assignee: dom-inspector → nobody
QA Contact: timeless → dom-inspector
You need to log in before you can comment on or make changes to this bug.