Firefox crashes when playing games at Yahoo! Games [@ ntdll.dll - nsEventListenerManager::`scalar deleting destructor' ] [@ 0x00000000 - nsLineLayout::ReflowFrame]

RESOLVED DUPLICATE of bug 240105

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 240105
14 years ago
8 years ago

People

(Reporter: Behrouz Bayat, Assigned: Blake Ross)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

I'm not sure if this happens with all the games at games.yahoo.com or only chess
(the one I play), but Firefox seems to crash "randomly" once the game applet is
loaded. This usually happens after I close a chess game. 

Could it possibly have to do with the pop-up blocker? I know that upon closing
game "tables", pop-up ads occasionally come up in other browsers (like IE), but
I'm getting crashes in Firefox instead of the ads.

Reproducible: Sometimes
Steps to Reproduce:
1.goto games.yahoo.com
2.goto chess
3.enter a room
4.sit down at a table and then close the table
5.repeat step 4 a few times, and then a crash usually occurs.

Actual Results:  
Error message pops up, asking if I want to debug or close Firefox.

Expected Results:  
Not crash.

Comment 1

14 years ago
WFM.

- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a2) Gecko/20040525
Firefox/0.8.0+
- J2SE 1.5.0-beta (build 1.5.0-beta-b32c)
- Microsoft Windows 2000 Pro 5.00.2195 SP4

Comment 2

14 years ago
closes itself while playing yahoo games (dominoes)

Comment 3

14 years ago
Works for me. Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040624 Firefox/0.9 (branch build), JRE 1.5.0 beta.

Can you reproduce this on a later build, please, like Firefox 0.9 or branch
nightly? Can you also try reproducing this on JRE 1.5.0 beta?
(Reporter)

Comment 4

14 years ago
The browser crashes in Firefox 0.9 as well, although it does so for me much less
often that on the previous version. By the way, I had and still have Java
1.5.0-beta.

I cannot reliably reproduce it because the crash does not happen very often (in
a 2 hour game session, Firefox might crash twice), and I have no idea why it occurs.
(Reporter)

Comment 5

14 years ago
I may have found a way to make Firefox crash every time. I repeated this
experiment 5 times, and it crashed all 5 times.

Log into Yahoo! Games and select a game (I chose chess). Once you're on the
"List of Game Rooms" page, no matter which page actually on (social, beginner,
etc.), refresh the browser. Keep refreshing, and eventually Firefox crashes.

It took me a maximum of 16 refresh clicks for one of the trials, but none the
less I got Firefox to crash 5 times in a row by refreshing.

Comment 6

14 years ago
That crashes Firefox (most likely) because there's a Java applet on that page
and Java's plugin doesn't manage its memory very well. If on the off chance I'm
correct, then this is not a Firefox bug.
(Reporter)

Comment 7

14 years ago
I don't think this is solely a Java bug. If that were the case, why don't I get
the same crash in IE? I've tried to recreate this crash in IE several times, but
cannot.

Comment 8

14 years ago
The Java plugin for IE and non-IE browsers are highly different. For IE, Java
uses ActiveX, and it is more well-maintained because IE has a higher user base.
For non-IE browsers, I think they use NPAPI, but I do know that it's not as
heavily maintained. In fact, this issue has even started a revival of NPAPI
(Netscape's Plugin API):
http://mozilla.org/press/mozilla-2004-06-30.html

Comment 9

14 years ago
Behrouz Bayat: Could you provide Talkback incident ID?
Keywords: crash
(Reporter)

Comment 10

14 years ago
Excuse me for my ignorance, but what is Talkback?

Comment 11

14 years ago
Talkback is a component of Mozilla which, when installed, automatically comes up
after a Mozilla crash and asks you to send some data to Mozilla. You can supply,
but that is no must, your email address, and it would be fine, if you can supply
the URL, where the crash happened, and a short description. You can look at the
collected data, if you select detail, and remove some of them, if you want to.
You then decide if you want to send the report, or not. Talkback is started
automatically at crash, but it doesn´t talkback automatically, you are always in
control.

To use Talkback:
- you have to download a talkback-enabled build
- you must have selected talkback for install at install time
- you must enable it after a crash (it is then waiting in the task bar) 
- you must click at submit button to send the report, or cancel to not send.

When a report is send, the server sends back a talkback ID. You can see this id,
if you start talkback.exe in your mozilla/components directory. You can do so,
while mozilla is running, and give this number here in a comment. Developers
then can see in which parts of the program Mozilla was crashing.
(Reporter)

Comment 12

14 years ago
Thanks for the info.

I crashed Firefox again and sent a report through Talkback. The ID is TB231546K.
However, when entering this ID in the Talkback FastFind, it tells me that no
incident was found. Does it take some time for the incident to be logged?

Comment 13

14 years ago
Incident was logged, but it have to be processed. Thank you!
Keywords: talkbackid

Comment 14

14 years ago
Behrouz: Due to a recent Talkback database upgrade aren't older incidents
available. Could I ask you again for TalkBack incident ID? I do apologize for
complication.

btw bug 250926 looks related
Keywords: talkbackid
(Reporter)

Comment 15

14 years ago
Not a problem.

New Talkback ID: TB320732G

Comment 16

14 years ago
TB320732G:
ntdll.dll + 0x33aed (0x77f83aed)
ntdll.dll + 0x8cca (0x77f58cca)
msvcrt.dll + 0x1ab2e (0x77c2ab2e)
nsEventListenerManager::`scalar deleting destructor'
nsGenericElement::~nsGenericElement 
[d:/builds/tinderbox/firefox-0.9.2/WINNT_5.0_Clobber/mozilla/content/base/src/nsGenericElement.cpp,
line 848]
Summary: Firefox crashes when playing games at Yahoo! Games → Firefox crashes when playing games at Yahoo! Games [@ ntdll.dll - nsEventListenerManager::`scalar deleting destructor' ]

Comment 17

13 years ago
using 0.9.2, cannot reproduce the bug.

Comment 18

13 years ago
TB1625845G: Sucessful reproduction using JRE 1.5.0 and FF1.0RC1

Comment 19

13 years ago
Could reproduce the bug on RC1 and RC2.

Ido

Comment 20

13 years ago
This is a topcrash for Firefox 1.0.  It seems like a common problem playing Java
games at Yahoo! and pogo.com and is being reported under ntdll.dll and
0x00000000 stack signatures.  The stack traces all look different, but here are
a few sets of crashes from the latest FF10 Talkback data:

Count   Offset    Real Signature
[ 9   ntdll.dll + 0x10f29 (0x7c910f29) fd379891 - JS_free ]
[ 5   ntdll.dll + 0x11e58 (0x7c911e58) ba008320 - JS_free ]
 
     Crash date range: 16-NOV-04 to 20-NOV-04
     Min/Max Seconds since last crash: 12 - 109548
     Min/Max Runtime: 21550 - 355090
 
     Count   Platform List 
     14   Windows XP [Windows NT 5.1 build 2600] 
 
     Count   Build Id List 
     14   2004110711
 
     No of Unique Users        14
 
 Stack trace(Frame) 

	 ntdll.dll + 0x10f29 (0x7c910f29)  
	 ntdll.dll + 0x10d5c (0x7c910d5c)  
	 msvcrt.dll + 0x1c2de (0x77c2c2de)  
	 JS_free
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/js/src/jsapi.c  line
1482] 
	 js_GC	[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/js/src/jsgc.c
 line 1324] 
	 js_ForceGC
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/js/src/jsgc.c  line
1000] 
	 nsAppShellService::Run
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp
 line 495] 
	 main
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/browser/app/nsBrowserApp.cpp
 line 58] 
	 kernel32.dll + 0x16d4f (0x7c816d4f)   
 
     (2080711)	URL: Yahoo.com/games
     (2080711)	Comments: Horrible service it always crashes on yahoo games going
back to explorer what a discrace.
     (2052432)	Comments: Downloading an on-line learning course
     (2037216)	Comments: closing tab
     (2020522)	URL: www.pogo.com
     (2020522)	Comments: closing my pogo game window
     (2005559)	URL: yahoo.games
     (2005559)	Comments: trying to open yahoo games
     (1993085)	URL: pogo.com

-----------------------------
Count   Offset    Real Signature
[ 223   0x00000000 8560629a - 0x00000000 ]
[ 14   firefox-bin + 0x0 (0x00000000) 37549f6a - firefox-bin + 0x0 (0x00000000) ]
 
     Crash date range: 14-NOV-04 to 21-NOV-04
     Min/Max Seconds since last crash: 0 - 804323
     Min/Max Runtime: 0 - 804323
 
     Count   Platform List 
     218   Windows XP [Windows NT 5.1 build 2600] 
     11   [Darwin 7.6.0]      
     2   MacOS X [Darwin 6.8]    
     1   Windows ME [Windows 98 4.90 build 73010104] 
     1   [Linux 2.6.8.1-12mdk]      
     1   [Linux 2.6.8.1-10mdk]      
     1   [Linux 2.6.4-52-default]      
     1   [Linux 2.4.22-10mdkenterprise]      
     1   [Darwin 7.5.0]      
 
     Count   Build Id List 
     233   2004110711
     4   2004110712
 
     No of Unique Users       213
 
 Stack trace(Frame) 

	 0x00000000   
 
     (2082647)	URL: www.wmmo.com
     (2082647)	Comments: Clicked on 'Last songs played' and then selected a drop
down box for the starting date/time.
     (2082413)	URL: cnn.com  sports illustrated  Ohio State/ Michigan article
     (2082413)	Comments: This is worse the IE. At least when that locks up you
can kill it; Firefox hogs the resources adn never gives control back. PLease
don't tell me I have to go back to IE. 
     (2082002)	URL: http://www.wigan-warriors.com/
     (2082002)	Comments: i had this link open in IE and opened firefox and
pasted the url and it just crashed!
     (2081481)	URL: http://linuxworld.com
     (2081122)	URL: www.mediaplaza.com
     (2080701)	URL: http://www.elunatic.org
     (2080701)	Comments: i was looking at a web page and it failed  this is the
first time it has failed..
     (2080626)	URL: http://random-international.squarespace.com/watch-paper/
     (2078727)	URL: bellsouth.net
     (2077684)	URL: www.pogo.com
     (2077653)	URL: www.pogo.com
     (2072702)	Comments: Closing a window w/ an applet in it
     (2072257)	URL: http://www.newgrounds.com
     (2066027)	URL: http://www.nny.com/holiday/snowcraft.htm
     (2065936)	Comments: downloading Zonealarm update
     (2064989)	URL: http://www.eagames.com/redesign/home.jsp
     (2063557)	URL: bellsouth.net
     (2062753)	Comments: Looking at NFL.com
     (2061478)	URL: www.pogo.com
     (2060991)	URL: Cabela's.com
     (2060585)	URL: www.ifilm.com
     (2060585)	Comments: Watching videos
     (2057816)	Comments: looking for quail eggs  using google image seach.  This
happened after pressing the back button.
     (2055636)	URL: www.aftonbladet.se
     (2049137)	URL: http://www.advfn.com/p.php?pid=quote&symbol=LSE:ZAR&java_vm=ms
     (2047625)	URL: http://www.megatokyo.com/index.php?strip_id=605
     (2047112)	URL: http://imakesense.blogspot.com
     (2045776)	URL: google.com
     (2045762)	URL: google.com
     (2045759)	URL: google.com
     (2045642)	URL: google.com
     (2045152)	URL: google.com
     (2045152)	Comments: I went to Google.com  and selected the IMAGE search. I
then proceeded to enter the word  "HEY" and hit search.    Then it errored and
closed. Tried it with different search words with the same results. 
     (2044839)	URL: http://www.archerytalk.com/vb/
     (2043569)	URL: http://www.fast-cd.com
     (2043569)	Comments: I was opening a page on the site www.fast-cd.com
     (2043105)	Comments: quicktime plugin of avi movie
     (2042644)	Comments: I clicked on a link in the news.com and error!
     (2042591)	URL: http://www.dbcradio.net/
     (2042575)	URL: http://www.advfn.com
     (2042575)	Comments: browsing java element on www.advfn.com
     (2042378)	URL: www.advfn.com
     (2042378)	Comments: Has failed may times on this.  It is an investment site
with live streaming share prices.
     (2042149)	URL: www.collincad.org
     (2041828)	URL: http://virtual.parkland.edu/cis134/Excel/
     (2040663)	URL:
http://www.peliplaneetta.net/download/?id=3938&url=/pelikonsolivideot/3d-raiskinta-toiminta/halo2_e3_realtimedemo_hires.mov
     (2040663)	Comments: I was watching this video. Then the error-message came.
Rock!!
     (2037451)	URL: games.yahoo.com
     (2033529)	URL: http://www.securitywizardry.com/radar.htm
     (2033529)	Comments: Refreshing page.
     (2033502)	URL: http://www.map24.com
     (2031601)	Comments: Qicktime is still not working right. After update.
     (2030976)	Comments: Competing an on-line training course. The next module
loaded ok  but there was no audio. When I exitted to reload  Firefox crashed.
     (2030208)	Comments: make a browser that does not crash.
     (2028984)	URL: http://www.babblefish.com/babblefish/
     (2028984)	Comments: Translating a german news article with babblefish.
     (2026475)	URL: www.imperian
     (2026475)	Comments: using a java application
     (2025516)	URL: http://www.ripamici.it/persone/7gennaio/convegno.html
     (2023123)	URL: http://www.soundproofing.org/infopages/vibrationpads.htm
     (2023024)	Comments: I was closing Firefox when it crashed. I closed it
using the upper right hand x box.
     (2022412)	Comments: just trying to log into ebay
     (2018541)	Comments: Trying to load a pogo.com game appellet (Riccochet
Xtreme Online).
     (2018157)	Comments: loading a search engine
     (2017637)	URL: http:\\www.alrai.com\
     (2017637)	Comments: The browser just lock when i choosr alrai.com as my
home page. also on another site lavalife.com the browser initiates an error
message. It seems to do so when java starts. Sometimes the browser freezes on
the first click anywhere on the mozilla or google
     (2017637)	Comments:  or alrai.com screen.
     (2014938)	URL: www.pogo.com
     (2014938)	Comments: Entering into a java based game.  This is becoming a
common occurance  
     (2011804)	Comments: Just visiting a site that uses Java - this is the only
reason I can't make Firefox my default browser...I run a website
(www.flagline.com) that uses Java applets that crash Firefox with alarming
frequency.  If there's info on making the design more
     (2011804)	Comments:  compatible with Firefox  I'd be glad to do so...
     (2009242)	Comments: viewing a number of url's  including one that was a
quicktime movie. unfortunately lost the url.
     (2009007)	Comments: D/L'ing a PDF file
     (2005973)	URL: http://www.advfn.com/p.php?pid=message&msg=0
     (2005973)	Comments: clicked back on browser after contended streaming java
session timed out
     (2005500)	URL:
https://update.mozilla.org/extensions/moreinfo.php?application=firefox&id=173&vid=504
     (2005500)	Comments: installing the extension to notify about gmail.
     (2002269)	URL: www.epicurious.com
     (2002269)	Comments: surfing
     (1995981)	Comments: signing up for Mozilla Quality Feedback Agent
     (1995667)	Comments: filling out a form  skipped a field and firefox kept
saying I needed to select a model. clicked ok and warning kept coming back  not
letting me fill out the field.
     (1993321)	Comments: Sun Java crash
     (1988380)	URL: http://sourceforge.net/search/
     (1988380)	Comments: Searcing for "evolution" in Software/Group
     (1987851)	URL: www.myway.com
     (1985364)	Comments: watchin mpeg avi files...
 
====================================================================================================
     Count   Offset    Real Signature
[ 48   0x00000000 54ef04e2 - nsLineLayout::ReflowFrame ]
[ 14   0x00000000 dac4dd5e - nsLineLayout::ReflowFrame ]
 
     Crash date range: 15-NOV-04 to 20-NOV-04
     Min/Max Seconds since last crash: 29 - 275631
     Min/Max Runtime: 232 - 548085
 
     Count   Platform List 
     62   Windows XP [Windows NT 5.1 build 2600] 
 
     Count   Build Id List 
     62   2004110711
 
     No of Unique Users        47
 
 Stack trace(Frame) 

	 0x00000000  
	 nsLineLayout::ReflowFrame
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsLineLayout.cpp
 line 1185] 
	 nsBlockFrame::ReflowInlineFrame
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp
 line 3748] 
	 nsBlockFrame::DoReflowInlineFrames
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp
 line 3446] 
	 nsBlockFrame::DoReflowInlineFramesAuto
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp
 line 3347] 
	 nsBlockFrame::ReflowInlineFrames
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp
 line 3292] 
	 nsBlockFrame::ReflowLine
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp
 line 2456] 
	 nsBlockFrame::ReflowDirtyLines
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp
 line 2098] 
	 nsBlockFrame::Reflow
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp
 line 817] 
	 nsBlockReflowContext::ReflowBlock
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp
 line 547] 
	 nsBlockFrame::ReflowBlockFrame
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp
 line 3068] 
	 nsBlockFrame::ReflowLine
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp
 line 2334] 
	 nsBlockFrame::ReflowDirtyLines
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp
 line 2098] 
	 nsBlockFrame::Reflow
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp
 line 817] 
	 nsBlockReflowContext::ReflowBlock
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockReflowContext.cpp
 line 547] 
	 nsBlockFrame::ReflowBlockFrame
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp
 line 3068] 
	 nsBlockFrame::ReflowLine
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp
 line 2334] 
	 nsBlockFrame::ReflowDirtyLines
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp
 line 2098] 
	 nsBlockFrame::Reflow
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsBlockFrame.cpp
 line 817] 
	 nsContainerFrame::ReflowChild
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp
 line 982] 
	 CanvasFrame::Reflow
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsHTMLFrame.cpp
 line 554] 
	 nsBoxToBlockAdaptor::Reflow
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBoxToBlockAdaptor.cpp
 line 884] 
	 nsBoxToBlockAdaptor::DoLayout
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBoxToBlockAdaptor.cpp
 line 626] 
	 nsBox::Layout
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBox.cpp
 line 1016] 
	 nsBox::Layout
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBox.cpp
 line 1016] 
	 nsGfxScrollFrameInner::LayoutBox
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp
 line 1264] 
	 nsGfxScrollFrame::DoLayout
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp
 line 1273] 
	 nsBox::Layout
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsBox.cpp
 line 1016] 
	 nsGfxScrollFrame::Reflow
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp
 line 873] 
	 nsContainerFrame::ReflowChild
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsContainerFrame.cpp
 line 982] 
	 ViewportFrame::Reflow
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsViewportFrame.cpp
 line 249] 
	 IncrementalReflow::Dispatch
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp
 line 904] 
	 PresShell::ProcessReflowCommands
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp
 line 6401] 
	 ReflowEvent::HandleEvent
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp
 line 6226] 
	 PL_HandleEvent
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/xpcom/threads/plevent.c
 line 674] 
	 0x778b0c24  
	 nsPrintObject::Init
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/content/base/src/nsPrintObject.cpp
 line 97] 
	 0x8bd6fff8   
 
     (2082625)	URL: http://games.yahoo.com/po
     (2082443)	URL: games.yahoo.com 
     (2082443)	Comments: I was getting ready to play pool. Once it started to
load the java applet  it stopped doing anything.
     (2082400)	URL: http://games.yahoo.com/po
     (2080859)	URL: yahoo.com  google.com
     (2080859)	Comments: i was accesing the Yahoo games  and it was the second
time it happened...
     (2079767)	URL: www.yahoo.com
     (2079767)	Comments: trying to load yahoo game: literati
     (2079375)	URL: http://games.yahoo.com/games/login2?page=do
     (2079375)	Comments: It crashes all the times on Yahoo Games (after logging
in) when trying to follow the link (to play Dominos) 
     (2070305)	URL: yahoo.com
     (2070305)	Comments: Cannot enter any Yahoo game rooms since 1.0.  No other
changes on this computer i.e. the only new quantity is the Firefox was updated
from 1.0PR to 1.0.
     (2068266)	URL: http://games.yahoo.com/pl
     (2065920)	URL: games.yahoo.com/ch (after login)
     (2065920)	Comments: I was awaiting the java applet to load for Yahoo! Chess
and I noticed it was taking a while and using up all of my processor  so I
attempted to close the browser resulting in the error. 
     (2062839)	URL: http://games.yahoo.com
     (2059200)	URL: http://games.yahoo.com/games/login2?page=mjs
     (2059135)	URL: http://games.yahoo.com/games/login2?page=mjs
     (2059135)	Comments: trying to play a yahoo game
     (2056429)	URL: http://www.games.yahoo.com
     (2056429)	Comments: page failed to load
     (2052864)	URL: www.yahoo.com
     (2052864)	Comments: trying to launch a java consol again for games
     (2052759)	URL: www.yahoo.com
     (2052759)	Comments: Tried to get into Yahoo Games and it crashed with the
launch of the java consol. 
     (2050190)	URL: http://games.yahoo.com/ch
     (2047312)	URL: yahoo.com\games
     (2047312)	Comments: games will not load usually a java problem i belive?
     (2044696)	URL: http://games.yahoo.com
     (2031053)	Comments: After installing AD Block Extension   Then closing and
restarting firefox  ... going to the yahoo games website and trying to load a
game crashes  Firefox.    I am also unale to use AlternaTIFF viewing software.
This sofware is used on websites that have
     (2031053)	Comments:  intense detail drawings. It works very well with out
the Ad Block. With the Ad Block  it doesnt ork but its doesnt crash firefox.
     (2015164)	URL: http://games.yahoo.com/games/login2?page=wg
     (2015164)	Comments: Trying to access the game room page of Spelldown in
Yahoo! Games. WOuld not display the rooms  instead freeze up for randomness.
     (2007568)	URL: yahoo.com
     (2007568)	Comments: This time  Firefox hangs trying to load the Tornado 21
game applet.
     (2007486)	URL: yahoo.com
     (2007486)	Comments: This time    1. I cleared the Java applet cache first
even though I know the applet was fine because it worked with Internet Explorer
and previous versions of Firefox.  2. Began an applet download.  3. After 120
seconds  I gave up and closed the Firefox
     (2007486)	Comments:  window.   4. Ran Internet Explorer with same applet
and had no trouble.    My Sun JVM is up to date.
     (2007358)	URL: yahoo.com
     (2007358)	Comments: Trying to load a Yahoo Java applet.  Same in Pogo.com
Java applets.  By the way  these crashes/hangs never happened in the preview
release of 1.0 or previous versions of Firefox.
     (2001597)	URL: http://www.yahoo.com
     (2001597)	Comments: trying to open my email.
     (2001019)	Comments: trying to download the java applet for yahoo.games
hearts card game
     (2000117)	URL: www.yahoo.com
     (1999756)	URL: www.yahoo.com
     (1995279)	URL: www.yahoo.com
     (1995279)	Comments: Entering Yahoo!Games/Chess  right after entering the
password (in secure mode) the browser simply stalls.
     (1993916)	URL: http://games.yahoo.com/gf
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: topcrash+
Summary: Firefox crashes when playing games at Yahoo! Games [@ ntdll.dll - nsEventListenerManager::`scalar deleting destructor' ] → Firefox crashes when playing games at Yahoo! Games [@ ntdll.dll - nsEventListenerManager::`scalar deleting destructor' ] [@ 0x00000000 - nsLineLayout::ReflowFrame]

Comment 21

13 years ago
*** Bug 269598 has been marked as a duplicate of this bug. ***

Comment 22

13 years ago
I suspect that Bug 210038, Bug 248709, and Bug 271574 may all be dups of the
issue in this bug (in some order).  As far as I have been able to discern, there
looks to be some sort of race condition or loop since Firefox pegs the CPU at
100%, though it doesn't look like the process is allocating memory or anything.
 I'll try to dig a little deeper in the next few days (determine if the race
ever resolves, minimum config to reproduce, etc.) using my meager skills and
resources.

I think the fact that some of these bugs mention "crash" and some "hang" is just
semantics and that they all describe the same effect: peg CPU at 100%, process
becomes unresponsive, trying to close the program can leave the process running
in the background, etc.

Comment 23

13 years ago

*** This bug has been marked as a duplicate of 240105 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

8 years ago
Keywords: topcrash+ → 4xp
Crash Signature: [@ ntdll.dll - nsEventListenerManager::`scalar deleting destructor' ] [@ 0x00000000 - nsLineLayout::ReflowFrame]
You need to log in before you can comment on or make changes to this bug.