no hints for PeekKeyAndIMEMessage on M175 crash [@ - nsWindow::DefaultWindowProc | nsWindow::WindowProc | PeekKeyAndIMEMessage]

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
15 years ago
7 years ago

People

(Reporter: jay, Unassigned)

Tracking

({crash, helpwanted, topcrash-})

Trunk
x86
Windows XP
crash, helpwanted, topcrash-
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: multi-line stack search, crash signature)

(Reporter)

Description

15 years ago
We don't have any user comments or urls to go on, so not sure what these users
are going, but this is a topcrash with Mozilla 1.7 rc2:

 Count   Offset    Real Signature
[ 3   0x1400615f bbf7fa50 - USER32.dll + 0x3a50 (0x77d13a50) ]
 
     Crash date range: 21-MAY-04 to 22-MAY-04
     Min/Max Seconds since last crash: 3677 - 59693
     Min/Max Runtime: 3677 - 59693
 
     Count   Platform List 
     3   [Windows NT 5.1 build 2600]   
 
     Count   Build Id List 
     3   2004051408
 
     No of Unique Users         3
 
 Stack trace(Frame) 

	 0x1400615f  
	 USER32.dll + 0x3a50 (0x77d13a50)  
	 USER32.dll + 0x3b1f (0x77d13b1f)  
	 USER32.dll + 0x44f5 (0x77d144f5)  
	 USER32.dll + 0x4525 (0x77d14525)  
	 ntdll.dll + 0x25da3 (0x77f65da3)  
	 USER32.dll + 0x3fd4 (0x77d13fd4)  
	 PeekKeyAndIMEMessage
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsAppShell.cpp
 line 91] 
	 nsAppShell::Run
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsAppShell.cpp
 line 138] 
	 nsAppShellService::Run
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp
 line 524] 
	 main1
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp
 line 1313] 
	 main
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp
 line 1783] 
	 WinMain
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp
 line 1809] 
	 WinMainCRTStartup()  
	 kernel32.dll + 0x214c7 (0x77e614c7)   
 
 
====================================================================================================
     Count   Offset    Real Signature
[ 2   0x1400615f 6ba274af - USER32.dll + 0x3a50 (0x77d43a50) ]
 
     Crash date range: 18-MAY-04 to 24-MAY-04
     Min/Max Seconds since last crash: 6102 - 16291
     Min/Max Runtime: 16291 - 148112
 
     Count   Platform List 
     2   [Windows NT 5.1 build 2600]   
 
     Count   Build Id List 
     2   2004051408
 
     No of Unique Users         2
 
 Stack trace(Frame) 

	 0x1400615f  
	 USER32.dll + 0x3a50 (0x77d43a50)  
	 USER32.dll + 0x3b1f (0x77d43b1f)  
	 USER32.dll + 0x44f5 (0x77d444f5)  
	 USER32.dll + 0x4525 (0x77d44525)  
	 ntdll.dll + 0x25da3 (0x77f75da3)  
	 USER32.dll + 0x3fd4 (0x77d43fd4)  
	 PeekKeyAndIMEMessage
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsAppShell.cpp
 line 91] 
	 nsAppShell::Run
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsAppShell.cpp
 line 138] 
	 nsAppShellService::Run
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp
 line 524] 
	 main1
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp
 line 1313] 
	 main
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp
 line 1783] 
	 WinMain
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp
 line 1809] 
	 WinMainCRTStartup()  
	 kernel32.dll + 0x214c7 (0x77e814c7)  

Count   Offset    Real Signature
[ 2   0x1400618f 7c22d78b - USER32.dll + 0x3a50 (0x77d43a50) ]
 
     Crash date range: 19-MAY-04 to 22-MAY-04
     Min/Max Seconds since last crash: 20749 - 97531
     Min/Max Runtime: 20749 - 97531
 
     Count   Platform List 
     2   [Windows NT 5.1 build 2600]   
 
     Count   Build Id List 
     2   2004051408
 
     No of Unique Users         2
 
 Stack trace(Frame) 

	 0x1400618f  
	 USER32.dll + 0x3a50 (0x77d43a50)  
	 USER32.dll + 0x3b1f (0x77d43b1f)  
	 USER32.dll + 0x44f5 (0x77d444f5)  
	 USER32.dll + 0x4525 (0x77d44525)  
	 ntdll.dll + 0x25da3 (0x77f75da3)  
	 USER32.dll + 0x58ce (0x77d458ce)  
	 nsWindow::DefaultWindowProc
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp
 line 1375] 
	 USER32.dll + 0x3a50 (0x77d43a50)  
	 USER32.dll + 0x3b1f (0x77d43b1f)  
	 USER32.dll + 0x5b2c (0x77d45b2c)  
	 USER32.dll + 0x5b4b (0x77d45b4b)  
	 nsWindow::WindowProc
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp
 line 1361] 
	 USER32.dll + 0x3a50 (0x77d43a50)  
	 USER32.dll + 0x3b1f (0x77d43b1f)  
	 USER32.dll + 0x44f5 (0x77d444f5)  
	 USER32.dll + 0x4525 (0x77d44525)  
	 ntdll.dll + 0x25da3 (0x77f75da3)  
	 USER32.dll + 0x3fd4 (0x77d43fd4)  
	 PeekKeyAndIMEMessage
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsAppShell.cpp
 line 91] 
	 nsAppShell::Run
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsAppShell.cpp
 line 138] 
	 nsAppShellService::Run
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp
 line 524] 
	 main1
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp
 line 1313] 
	 main
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp
 line 1783] 
	 WinMain
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp
 line 1809] 
	 WinMainCRTStartup()  
	 kernel32.dll + 0x214c7 (0x77e814c7) 

Any help on figuring out what's going on is greatly appreciated.
(Reporter)

Comment 1

15 years ago
The 0x1400615f and 0x1400618f stack signatures combine for about 100 of the
Talkback incidents for M17rc2.  Not sure what's going on here, but that makes
them the current #10 and #11 topcrashers.

The lack of user comments makes this a hard crash to reproduce, but hopefully
someone can look at the stack and maybe think of possible reasons for this crash.
(Reporter)

Comment 2

14 years ago
There aren't as many of these crashes in recent releases, so marking topcrash-
until we can get this reproduced.
Keywords: topcrash → topcrash-
Summary: M17rc2 crash [@ 0x1400615f | 0x1400618f - PeekKeyAndIMEMessage] → M17 crash [@ 0x1400615f | 0x1400618f - PeekKeyAndIMEMessage]
Product: Browser → Seamonkey
(Reporter)

Comment 3

14 years ago
This has been a topcrasher for Mozilla 1.7.3, but was reported under a different
stack signature:

9   0x14007dba   90 
 
====================================================================================================
     Count   Offset    Real Signature
[ 11   0x14007dba e5fcbed5 - PeekKeyAndIMEMessage ]
[ 10   0x14007dba caae2c0f - PeekKeyAndIMEMessage ]
[ 5   0x14007dba 8982e2b2 - PeekKeyAndIMEMessage ]
[ 4   0x14007dba 95f5957d - PeekKeyAndIMEMessage ]
[ 3   0x14007dba 9c4d76b9 - PeekKeyAndIMEMessage ]
[ 2   0x14007dba d2cec984 - PeekKeyAndIMEMessage ]
[ 2   0x14007dba ade497c3 - PeekKeyAndIMEMessage ]
[ 2   0x14007dba 8cd44122 - PeekKeyAndIMEMessage ]
[ 2   0x14007dba 847d0d1c - PeekKeyAndIMEMessage ]
 
     Crash date range: 18-OCT-04 to 28-OCT-04
     Min/Max Seconds since last crash: 553 - 551139
     Min/Max Runtime: 2845 - 733747
 
     Count   Platform List 
     37   Windows XP [Windows NT 5.1 build 2600] 
     4   Windows 2K [Windows NT 5.0 build 2195] 
 
     Count   Build Id List 
     41   2004091008
 
     No of Unique Users        32
 
 Stack trace(Frame) 

	 0x14007dba  
	 USER32.dll + 0x8709 (0x77d18709)  
	 USER32.dll + 0x87eb (0x77d187eb)  
	 USER32.dll + 0xb368 (0x77d1b368)  
	 USER32.dll + 0xb3b4 (0x77d1b3b4)  
	 ntdll.dll + 0xeae3 (0x7c91eae3)  
	 USER32.dll + 0x93df (0x77d193df)  
	 PeekKeyAndIMEMessage
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsAppShell.cpp
 line 91] 
	 nsAppShell::Run
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsAppShell.cpp
 line 138] 
	 nsAppShellService::Run
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp
 line 524] 
	 main1
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp
 line 1313] 
	 main
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp
 line 1783] 
	 WinMain
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp
 line 1809] 
	 WinMainCRTStartup()  
	 kernel32.dll + 0x16d4f (0x7c816d4f)   

There are quite a few of these crashes for M173:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=1&searchby=stacksig&match=contains&searchfor=0x14007dba&vendor=All&product=Mozilla17&platform=All&buildid=2004091&sdate=&stime=&edate=&etime=&sortby=bbid

If this crash doesn't go away with Mozilla 1.7.5, we will have to take a closer
look.
Keywords: topcrash- → topcrash
Summary: M17 crash [@ 0x1400615f | 0x1400618f - PeekKeyAndIMEMessage] → M173 crash [@ 0x14007dba | 0x1400615f | 0x1400618f - PeekKeyAndIMEMessage]
(Reporter)

Comment 4

14 years ago
Updating with M175 since this continues to be a topcrasher for Mozilla 1.7.5,
but marking topcrash- since the total number of crashes for that release is a
lot less than with 1.7.3. 

Here is the link for all current "0x14007dba" crashes in Talkback:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=1&searchby=stacksig&match=contains&searchfor=0x14007dba&vendor=All&product=All&platform=All&buildid=&sdate=&stime=&edate=&etime=&sortby=bbid
Keywords: topcrash → topcrash-
Summary: M173 crash [@ 0x14007dba | 0x1400615f | 0x1400618f - PeekKeyAndIMEMessage] → M175 crash [@ 0x14007dba | 0x1400615f | 0x1400618f - nsWindow::DefaultWindowProc | nsWindow::WindowProc | PeekKeyAndIMEMessage]

Updated

14 years ago
Version: Other Branch → 1.7 Branch

Comment 5

13 years ago
user32+0x8734 is USER32!InternalCallWinProc+0x28
user32+0x8816 is USER32!UserCallWinProcCheckWow+0xb7
user32+0xb4c0 is USER32!DispatchClientMessage+0x4d
user32+0xb50c is USER32!__fnDWORD+0x24
 ntdll+0xeae3 is  ntdll!KiUserCallbackDispatcher+0x13
user32+0x9402 is USER32!NtUserPeekMessage+0x25

FastFind
Talkback Incident ID
	
Talkback Reports
Mozilla Reports Mozilla     Firefox Reports Firefox     Thunderbird Reports Thunderbird     Camino Reports Camino
QuickSearch
Search By: Stack Signature Comments URL
Customize your search:
Vendor: Product: Platform: Build:
Start Date: 				End Date: 		
	(mm/dd/yyyy) 	(hh:mm:ss) 			(mm/dd/yyyy) 	(hh:mm:ss) 	
Sort By: ID Stack Signature Comments URL Build
  
Incident ID: 11231622
Stack Signature	0x35f7b86b b1a30f81
Product ID	ThunderbirdTrunk
Build ID	2005102906
Trigger Time	2005-10-29 17:08:14.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	
URL visited	
User Comments	deleting a large (sub)folder of email
Since Last Crash	2267 sec
Total Uptime	2267 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
0x35f7b86b
USER32.dll + 0x8734 (0x77d48734)
USER32.dll + 0x8816 (0x77d48816)
USER32.dll + 0xb4c0 (0x77d4b4c0)
USER32.dll + 0xb50c (0x77d4b50c)
ntdll.dll + 0xeae3 (0x7c90eae3)
USER32.dll + 0x9402 (0x77d49402)
PeekKeyAndIMEMessage  [e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/widget/src/windows/nsAppShell.cpp, line 91]
nsAppShell::Run  [e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/widget/src/windows/nsAppShell.cpp, line 128]
nsAppStartup::Run  [e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 162]
main  [e:/builds/tinderbox/thunderbird-trunk/WINNT_5.0_Depend/mozilla/mail/app/nsMailApp.cpp, line 62]
kernel32.dll + 0x16d4f (0x7c816d4f)
Assignee: general → win32
Component: General → Widget: Win32
Product: Mozilla Application Suite → Core
QA Contact: general → ian
Version: 1.7 Branch → Trunk

Comment 6

13 years ago
I'm not sure if this bug has much value to us at this point
Summary: M175 crash [@ 0x14007dba | 0x1400615f | 0x1400618f - nsWindow::DefaultWindowProc | nsWindow::WindowProc | PeekKeyAndIMEMessage] → no hints for PeekKeyAndIMEMessage on M175 crash [@ 0x14007dba | 0x1400615f | 0x1400618f - nsWindow::DefaultWindowProc | nsWindow::WindowProc | PeekKeyAndIMEMessage]

Comment 7

13 years ago
there are 4 stack signatures for  "PeekKeyAndIMEMessage 637070dd" for firefox 1.5 that look similar...

maybe multiline stack search can help to find more, and also point to a reason why sometimes execution continues past PeekKeyAndIMEMessage and ends up crashing further down the path.

comments for stack sig PeekKeyAndIMEMessage 637070dd were:
nothing! just crashed overnight
Searching for completed auctions on ebay


Source File, Line No.	c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/widget/src/windows/nsAppShell.cpp, line 90
Stack Trace 	
PeekKeyAndIMEMessage  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/widget/src/windows/nsAppShell.cpp, line 90]
nsAppShell::Run  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/widget/src/windows/nsAppShell.cpp, line 128]
nsAppStartup::Run  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 151]
main  [c:/builds/tinderbox/Fx-Mozilla1.8.0/WINNT_5.2_Depend/mozilla/browser/app/nsBrowserApp.cpp, line 61]
kernel32.dll + 0x16d4f (0x7c816d4f)
Whiteboard: multi-line stack search

Comment 8

13 years ago
the new multi-line stack search doesn't show much for this.  only two bboxes there today and only one has comment that someone was "creating a document"

http://talkback-public.mozilla.org/search/start.jsp?search=1&searchby=stack&match=contains&searchfor=PeekKeyAndIMEMessage&vendor=MozillaOrg&product=Firefox15&platform=All&buildid=&sdate=&stime=&edate=&etime=&sortby=stack

Updated

13 years ago
Summary: no hints for PeekKeyAndIMEMessage on M175 crash [@ 0x14007dba | 0x1400615f | 0x1400618f - nsWindow::DefaultWindowProc | nsWindow::WindowProc | PeekKeyAndIMEMessage] → no hints for PeekKeyAndIMEMessage on M175 crash [@ - nsWindow::DefaultWindowProc | nsWindow::WindowProc | PeekKeyAndIMEMessage]

Comment 9

10 years ago
Jay, are you still running into this in the latest release?
Assignee: win32 → nobody
QA Contact: ian → win32
This was a former topcrash, not a bug Jay was hitting himself.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ - nsWindow::DefaultWindowProc | nsWindow::WindowProc | PeekKeyAndIMEMessage]
You need to log in before you can comment on or make changes to this bug.