Various Firefox crashes on AMD64 with form elements and cut/paste

RESOLVED DUPLICATE of bug 236792

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 236792
15 years ago
11 years ago

People

(Reporter: narmat, Assigned: bugs)

Tracking

({crash})

unspecified
x86
Linux
Points:
---
Bug Flags:
blocking-aviary1.0PR -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6) Gecko/20040522 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6) Gecko/20040522 Firefox/0.8

I used this same version on the same machine with an i386 kernel and the same
problems don't exist.  The problem is, when using the forms, firefox often
crashes with errors similar to the following:

May 24 16:13:44 [kernel] firefox-bin[9490]: segfault at 0000000000000089 rip
0000002a973d18f2 rsp 0000007fbfffe2b0 error 4

This bug is also documented on the gentoo bug site:

http://bugs.gentoo.org/show_bug.cgi?id=42782

And the gentoo forums:

http://forums.gentoo.org/viewtopic.php?t=165401&highlight=firefox+amd64

I took a look through and this has not been posted as a bug yet, which surprised
me as it's been a problem for many for at least a month or so.

Is this a known bug as of yet?

Reproducible: Always
Steps to Reproduce:
1. Open firefox.
2. Try and cut/paste in search or "go" fields 
3. Do form data, click "yes" to save form elements typed in.

Actual Results:  
Firefox just died, I can start it again and half the time get it to work.  If
I'm not typing anything in (ie not searching on google or whatnot) it seems to
work alright.

Updated

15 years ago
Blocks: 237202

Updated

15 years ago
Flags: blocking-aviary1.0RC1?

Comment 1

15 years ago
Tamran Lengyel: Could you reproduce with Firefox 0.9.x release or night build?
Could you provide TalkBack incident ID?
Severity: normal → critical
Keywords: crash

Comment 2

15 years ago
Note that creating a new profile can help eliminate this error, although I 
still get less frequent random crashes even with a new profile. 
 
The last time I checked there were no nightly builds for the AMD64 version of 
Firefox.  The problem does not occur with a 32-bit version of Firefox.  I for 
one would be happy to try a nightly 64-bit build if it were available.  I 
would be happy to compile one if the source with the talkback code were 
available as well. 
 
I am fairly confident that using the 32-bit nightly builds, however, will fail 
to generate the bug. 
 
The downside to just using a 32-bit version of the browser is that it cannot 
be used with 64-bit java plugins. 

Comment 3

15 years ago
> I would be happy to compile one if the source with the talkback code were 
> available as well. 

AFAIK TalkBack code isn't available. =(
Flags: blocking-aviary1.0RC1? → blocking-aviary1.0RC1-

Comment 4

15 years ago
Looks like this may be a duplicate of bug 236792.

*** This bug has been marked as a duplicate of 236792 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.