Setting grey or silver as font color will result in black text when printing

RESOLVED INVALID

Status

()

Core
Printing: Output
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Martijn Kint, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040524 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040524 Firefox/0.8

If you use an alternate stylesheet to define print settings and you select
either grey, silver or #999, #888, #777 etc. etc. for font colors (ex. greyish
colors/tones), this will result in black printed text, other colors seem to be
fine (red, blue, green etc. etc.).

Selecting the option in the Print Preview window --> Page Setup --> Print
Background (color & images) solves this problem...

Reproducible: Always
Steps to Reproduce:
1. Ggo to http://www.drunk.nl/tweakers/print/print.htm
2. Select "print Preview" 
3. Text will show as black
4. Go to Page Setup, check Print Background (color & images)
5. Select "print Preview" again
6. Text will show as grey, as it should 

Actual Results:  
Text shows as grey

Expected Results:  
Text should show as grey without the option Print Background (color & images)
being checked.

Comment 1

14 years ago
dup of bug 51848?
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> dup of bug 51848?

Don't think so, completely other kind of bug. As i stated in my bug report, it
only happens when you set the color to a greyish or silver tone, other colors
just work fine.
This is by design. Say a page has white text on a black background.  If you
uncheck "Print Background", we will print a white background.  So we have to
change the text color too, so the text will show up.

So we make the color darker, while keeping the hue the same.  Which means all
shades of gray end up black, as is desired in this case.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.