FireFox makes an Invalid HTTP Request

VERIFIED INVALID

Status

Tech Evangelism Graveyard
English US
VERIFIED INVALID
14 years ago
3 years ago

People

(Reporter: Luis Nunes, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

Apparently FireFox is making an invalid HTTP request
(try:http://jump.2ch.net/imgs/8.jpg)

Apache is nice enough to tell us what the problem is exactly.

Bad Request
Your browser sent a request that this server could not understand.

client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23):
/imgs/8.jpg

Apache/1.3.20 Server at jump.2ch.net Port 80


Reproducible: Always
Steps to Reproduce:

Updated

14 years ago
Assignee: firefox → darin
Component: General → Networking: HTTP
Product: Firefox → Browser
QA Contact: core.networking.http
Version: unspecified → Trunk

Comment 1

14 years ago
If this is a regression (according to Bug 177919 this had worked), this
regression has been there for a long time, since it occours with current trunk,
Mozilla 1.7b, Mozilla 1.6 and Mozilla 1.4 

Comment 2

14 years ago
Created attachment 149289 [details]
network trace

Mozilla is sending a valid Host header.  The server appears to be at fault
here.

Comment 3

14 years ago
-> Tech Evang

someone should contact the site webmaster to get the problem fixed on their end.
 it might be helpful if someone could provide a similar network trace using IE
or some other browser that works on this page.
Assignee: darin → english-us
Component: Networking: HTTP → English US
Product: Browser → Tech Evangelism
QA Contact: core.networking.http → english-us
Version: Trunk → unspecified
(In reply to comment #3)
> -> Tech Evang
> 
> someone should contact the site webmaster to get the problem fixed on their end.
>  it might be helpful if someone could provide a similar network trace using IE
> or some other browser that works on this page.
Well, it doesn't work in any browser as far as I can see.
The link gives in IE6 and Opera7.23 a 400 Bad Request.
Using windows 2000.
So I think this bug is INVALID.
-> Invalid

The server seems to be broken because I get the same repsonse with Opera and IE
(but seems to work in wget)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 6

14 years ago
V/invalid.
Status: RESOLVED → VERIFIED
QA Contact: english-us → benc
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.