Closed Bug 244662 Opened 17 years ago Closed 17 years ago

Tools->Themes does not recognise a jar file, it can only save it

Categories

(Toolkit :: Add-ons Manager, defect)

x86
Windows 2000
defect
Not set
major

Tracking

()

RESOLVED INVALID

People

(Reporter: Peter6, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040516 Firefox/0.8.0+ (JTw)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040525 Firefox/0.8.0+ 

goto Tools->Themes->and search for a new theme (FF0.9 proof).
If you doubleclick on the jar file FF asks you what to do with it and the option
to save it.

Reproducible: Always
Steps to Reproduce:
Tools, Themes choose new theme.
A new browser window opens
select a FF0.9 theme (.jar file)
FF can only save that file
Actual Results:  
saved the file to disk.
Nothing happens after that

Expected Results:  
Lead me to installing the theme.
Flags: blocking0.9?
are we going to support themes in jars or only when packaged properly?
Mike, what we really need is one simple "dummy"theme supplied by FF dev (or at
least approved by) that has proven to install/uninstall properly.
At the moment false bugs are being filed simply because a correct test theme is
missing. (Same story for extensions.)
We need a benchmark for proper testing on a day to day basis.
(I wish I could write it myself)
Status: NEW → RESOLVED
Closed: 17 years ago
Flags: blocking0.9?
Resolution: --- → INVALID
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.