If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

tabbed windows act silly with 'focus' method

VERIFIED DUPLICATE of bug 244726

Status

()

Toolkit
Form Manager
VERIFIED DUPLICATE of bug 244726
14 years ago
9 years ago

People

(Reporter: TATMF, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.6) Gecko/20040206 Firefox/0.8

Opening 2 tabs, on authentication pages, at a time makes silly results:
when typing, I may fill in the wrong page's form.

I'd say it may happen only with pages using focus() method.

Reproducible: Always
Steps to Reproduce:
1. Open (fast) 2 URLs (maybe the same) in 2 tabs
2. Those URLs have to get focus on an INPUT area, so we choose a login page
3. Switch your tab, and type your login

Actual Results:  
Nothing seems to happen at first: your window hasn't realy got focus.
Back to the other tab: your login has been captured here.

Expected Results:  
The INPUT should get the focus when I'm back on the right tab, but not when I
don't see it.
The focus() method should wait for page's focus. Or maybe should there be 1
focus per tabbed window.
(Reporter)

Updated

14 years ago
Component: Tabbed Browser → Form Manager
Summary: Javascript focus() can set focus on INPUTs placed in unfocused tabs → tabbed windows act silly with 'focus' method

Comment 1

14 years ago
How is this bug different from bug 244726 that you also reported?

Comment 2

14 years ago
hmm, i get this too and it is really starting to annoy me.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040525
Firefox/0.8.0+

steps to reproduce.

open a tab -> goto google.com
open another tab which google.com is loading via ctrl-t
start typing an address

what should happen is that the address bad should take focus when the new tab is
open.

what happens is that the address you typed ends up in the google search..

this could be connected to another couple of bugs in bugzilla, 

search for address bar focus.
(Reporter)

Comment 3

14 years ago
Sorry, I happend to report this bug twice (244726 and 244727) by mistake.
I originaly wanted to add 2 different bug reports bu changed my mind...

The other 'bug' was an OnChange problem on 'file' typeds INPUTs.
I didn't check yet if it was already reported.

I learned that 244726 (this bug here) was already reported, though I *did* make
a previous search for it.

*** This bug has been marked as a duplicate of 244726 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.