adding search engines does not work for the recent firefox builds

VERIFIED DUPLICATE of bug 244704

Status

()

--
major
VERIFIED DUPLICATE of bug 244704
15 years ago
10 years ago

People

(Reporter: petrovicky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040524 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040524 Firefox/0.8.0+

when you try to add a search engine using mycroft.mozdev.org, nothing will happen.
e.g. javascript:addEngine('astalavista','gif','Tech News') returns:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004003 (NS_ERROR_INVALID_POINTER) [nsIRDFService.GetDataSource]"  nsresult:
"0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame ::
file:///C:/PROGRA~1/MOZILL~1/components/nsSidebar.js :: nsSidebar :: line 67" 
data: no]
--- AND ---
Error: [Exception... "Component returned failure code: 0x80004003
(NS_ERROR_INVALID_POINTER) [nsIRDFService.GetDataSource]"  nsresult: "0x80004003
(NS_ERROR_INVALID_POINTER)"  location: "JS frame ::
file:///C:/PROGRA~1/MOZILL~1/components/nsSidebar.js :: nsSidebar :: line 67" 
data: no]
Source File: file:///C:/PROGRA~1/MOZILL~1/components/nsSidebar.js
Line: 67

I guess it has something to do with the firefox 0.9 new extensions handling...
I am using the branch build "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.7) Gecko/20040524 Firefox/0.8.0+".

[been testing it in a clean profile.]

Reproducible: Always
Steps to Reproduce:
1. click on search bar
2. select "Add engines..."
3. try to add an engine

Actual Results:  
errors in JS console, written here...

Expected Results:  
search engine should be added to the search bar

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 244704 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Assignee: p_ch → nobody
Status: RESOLVED → VERIFIED
QA Contact: search
You need to log in before you can comment on or make changes to this bug.