Mozilla crashes when signing out of Bank of America website [@ nsCSSFrameConstructor::FindFrameWithContent ]

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
14 years ago
4 years ago

People

(Reporter: tom.williams, Unassigned)

Tracking

({crash, qawanted})

Trunk
x86
Windows 2000
crash, qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: See comment 7, crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040525 MultiZilla/1.6.2.1d
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040525 MultiZilla/1.6.2.1d

I can login to the Bank of America website just fine but when I try to logout,
Mozilla crashes when displaying the main BofA page.

Reproducible: Always
Steps to Reproduce:
1.Go to http://www.bankofamerica.com/
2.Login to the site
3.Click signoff to logout
4.Crash occurs

Actual Results:  
Mozilla crashes.

Expected Results:  
Mozilla should not crash.

Here is the most recent talklback indcident id for this crash:

TB61754Y
The stack is:

nsCSSFrameConstructor::FindFrameWithContent 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 10952]
nsCSSFrameConstructor::FindPrimaryFrameFor 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 11088]
nsFrameManager::GetPrimaryFrameFor 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsFrameManager.cpp,
line 460]
PresShell::GetPrimaryFrameFor 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 5389]
nsElementSH::PostCreate 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/dom/src/base/nsDOMClassInfo.cpp,
line 4764]
XPCWrappedNative::GetNewOrUsed 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 432]
XPCConvert::NativeInterface2JSObject 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcconvert.cpp,
line 1062]
nsXPConnect::WrapNative 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/nsXPConnect.cpp,
line 569]
nsDOMClassInfo::WrapNative 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/dom/src/base/nsDOMClassInfo.cpp,
line 1068]
nsNodeSH::PreCreate 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/dom/src/base/nsDOMClassInfo.cpp,
line 4537]
XPCWrappedNative::GetNewOrUsed 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 305]
XPCConvert::NativeInterface2JSObject 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcconvert.cpp,
line 1062]
nsXPConnect::WrapNative 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/nsXPConnect.cpp,
line 569]
nsXBLProtoImpl::InitTargetObjects 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/content/xbl/src/nsXBLProtoImpl.cpp,
line 115]
nsXBLProtoImpl::InstallImplementation 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/content/xbl/src/nsXBLProtoImpl.cpp,
line 76]
nsXBLPrototypeBinding::InstallImplementation 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/content/xbl/src/nsXBLPrototypeBinding.cpp,
line 428]
nsXBLBinding::InstallImplementation 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/content/xbl/src/nsXBLBinding.cpp,
line 816]
nsXBLService::LoadBindings 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/content/xbl/src/nsXBLService.cpp,
line 636]
nsCSSFrameConstructor::ConstructFrameInternal 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 7077]
nsCSSFrameConstructor::ConstructFrame 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 7034]
nsCSSFrameConstructor::ProcessChildren 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 11459]
nsCSSFrameConstructor::ConstructXULFrame 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 5667]
nsCSSFrameConstructor::ConstructFrameInternal 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 7149]
nsCSSFrameConstructor::ConstructFrame 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 7034]
nsCSSFrameConstructor::ProcessChildren 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 11459]
nsCSSFrameConstructor::ConstructXULFrame 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 5667]
nsCSSFrameConstructor::ConstructFrameInternal 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 7149]
nsCSSFrameConstructor::ConstructFrameInternal 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 7101]
nsCSSFrameConstructor::ConstructFrame 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 7034]
nsCSSFrameConstructor::ProcessChildren 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 11459]
nsCSSFrameConstructor::ConstructXULFrame 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 5667]
nsCSSFrameConstructor::ConstructFrameInternal 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 7149]
nsCSSFrameConstructor::ConstructFrame 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 7034]
nsCSSFrameConstructor::ProcessChildren 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 11459]
nsCSSFrameConstructor::ConstructXULFrame 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 5667]
nsCSSFrameConstructor::ConstructFrameInternal 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 7149]
nsCSSFrameConstructor::ConstructFrame 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 7034]
nsCSSFrameConstructor::CreateAnonymousFrames 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 5073]
nsCSSFrameConstructor::InitGfxScrollFrame 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 6008]
nsCSSFrameConstructor::BeginBuildingScrollFrame 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 5805]
nsCSSFrameConstructor::BuildScrollFrame 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 5958]
nsCSSFrameConstructor::InitializeSelectFrame 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 4268]
nsCSSFrameConstructor::ConstructSelectFrame 
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,
line 4152]

etc.
Is this a problem without Multizilla installed?  Also, can you attach the page
that the browser tries to load on logout (log out with IE and save what it gets,
say?) if that's the page that crashes Mozilla?
(Reporter)

Comment 3

14 years ago
Created attachment 149362 [details]
HTML page (complete) of BofA page that displays after signout.

Ok, I was able to successfully logout using Mozilla/5.0 (Windows; U; Windows NT
5.0; en-US; rv:1.7) Gecko/20040525 Firefox/0.8.0+.  This problem *might* be
Multizilla related.

Please let me know if you need more info from me.

Peace...
Tom, does loading the HTML in that attachment with the MultiZilla build crash?
(Reporter)

Comment 5

14 years ago
Nope, not when I load the HTML file directly.

When I saved the page in Firefox, I logged in first and then logged out and
saved the page that displayed after logout.

I'll try it again after installing Mozilla in a separate directory WITHOUT
Multizilla and see what happens.

Peace...
(Reporter)

Comment 6

14 years ago
Ok, I just discovered this.  This crash happens ONLY when I have the "Toy Story
1.5b+" theme loaded and I load the page from the remote web server.  

If I load the local page, the crash does not occur.

If I use the "Modern" theme w/ Multizilla, the crash does NOT occur.

If I use the "Modern" theme w/o Multizilla, the crash does NOT occur.

Hope that helps...

Peace...
Argh.  Someone's going to need to figure out what XBL binding is at fault and
what it's doing to call back into the frame constructor during frame construction...
Keywords: qawanted

Comment 8

14 years ago
I wonder if the Toy Story theme is based on Classic or Modern. i.e. do you also
see the crash with Classic theme (with/without MultiZilla enabled)?

P.s. MultiZilla 1.6.2.1d is very old, why don't you try a more recent version of
MultiZilla (1.6.3.3a or 1.6.4.0b depending on your Mozilla version)?

Comment 9

14 years ago
Is that 'Toy Story' or 'Toy Factory'?
Is this http://themes.mozdev.org/themes/toyfactory.html the theme you are using?
(Reporter)

Comment 10

14 years ago
Toy Factory is the theme I have installed, sorry about that.  (DVDs on the
brain...  :) ).

I HAVE noticed after switching back to the Modern theme that my back/forward
buttons have disappeared.  I'll try classic as well as WITHOUT Multizilla and a
more current Multizilla and report back my results.

Peace...
(Reporter)

Comment 11

14 years ago
(In reply to comment #8)

> P.s. MultiZilla 1.6.2.1d is very old, why don't you try a more recent version of
> MultiZilla (1.6.3.3a or 1.6.4.0b depending on your Mozilla version)?

Ok, I upgraded Multizilla to 1.6.4.0b adn when I use the Toy Factory 1.5b+
theme, I DO get the crash (talkback id: TB65103M).

I'll keep you posted.

Peace...
(Reporter)

Comment 12

14 years ago
Ok, I tried it with the Toy Factory theme applied and Multizilla NOT loaded and
DID get the crash (talkback id: TB65141M)

Peace...
Whiteboard: See comment 7

Updated

14 years ago
Keywords: crash
Summary: Mozilla crashes when signing out of Bank of America website → Mozilla crashes when signing out of Bank of America website [@ nsCSSFrameConstructor::FindFrameWithContent ]

Comment 13

14 years ago
*** Bug 248146 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Severity: normal → critical

Comment 14

14 years ago
*** Bug 243366 has been marked as a duplicate of this bug. ***

Comment 15

14 years ago
Bug 243366 has some repro on eBay.
Product: Browser → Seamonkey

Comment 17

14 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 18

14 years ago
Is anyone still seeing this crash?
(Reporter)

Comment 19

14 years ago
I have not been seeing this crash since I've been using Firefox with the Noia
theme and not Mozilla 1.7 w/ Toy Factory.  I can install that theme (I have
1.7.6 installed) and try it again and see what happens.

Peace...
(Reporter)

Comment 20

14 years ago
Ok, I just tried it with Mozilla 1.7.6 on Windows 2000 and everything worked
fine.  NO crash at all.

Peace...

Comment 21

14 years ago
great!
resolving WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 22

14 years ago
Ok, then what about the duplicate bug reports that reference this bug report? 
Shouldn't those be verified and updated?

Peace...
Crash Signature: [@ nsCSSFrameConstructor::FindFrameWithContent ]
You need to log in before you can comment on or make changes to this bug.