Last Comment Bug 244776 - Don't fire page loading events when jumping to named anchor
: Don't fire page loading events when jumping to named anchor
Status: RESOLVED FIXED
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Aaron Leventhal
:
: alexander :surkov
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-26 12:06 PDT by Aaron Leventhal
Modified: 2004-06-01 12:43 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Check aWebProgress->GetIsDocumentLoading(). If document is not loading, don't fire doc loading event. (845 bytes, patch)
2004-05-26 12:08 PDT, Aaron Leventhal
pkwarren: review+
darin.moz: superreview+
Details | Diff | Splinter Review

Description Aaron Leventhal 2004-05-26 12:06:34 PDT
When a user jumps to a named anchor link within the same page, the screen reader
should not say "loading page" or anything which indicates that a new page is
loading.

Window-Eyes currently does because it is watching for our "new page is loading"
event.

We shouldn't fire that event when the user is staying on the same page.
Comment 1 Aaron Leventhal 2004-05-26 12:08:13 PDT
Created attachment 149365 [details] [diff] [review]
Check aWebProgress->GetIsDocumentLoading(). If document is not loading, don't fire doc loading event.
Comment 2 Philip K. Warren 2004-05-26 12:22:13 PDT
Comment on attachment 149365 [details] [diff] [review]
Check aWebProgress->GetIsDocumentLoading(). If document is not loading, don't fire doc loading event.

Looks good to me.
Comment 3 Aaron Leventhal 2004-06-01 12:43:16 PDT
Checking in nsDocAccessible.cpp;
/cvsroot/mozilla/accessible/src/base/nsDocAccessible.cpp,v  <--  nsDocAccessible.cpp
new revision: 1.39; previous revision: 1.38
done

Note You need to log in before you can comment on or make changes to this bug.