Vertical scrollbar is truncated if window height is below some limit

REOPENED
Unassigned

Status

()

Core
Layout
REOPENED
14 years ago
14 years ago

People

(Reporter: jsp, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040316

With Mozilla 1.8a1, the vertical scrollbar appears to have a minimum height (on
the order of 135 pixels on my machine). If the height of the browser window is
reduced to the point where the area available for displaying the scrollbar is
less than that, the bottom part of the scrollbar is not drawn.

Reproducible: Always
Steps to Reproduce:
1. Load a page.
2. Reduce the browser window's height, keeping an eye on the vertical scrollbar.
 Assuming you've loaded a non-trivial page, you'll get a scrollbar at some
point, even if you started without one.


Actual Results:  
When the window's height falls below some value, the bottom of the scrollbar
begins to disappear.  If the window is shrunk further, more of the scrollbar
goes missing.

Expected Results:  
Whatever 1.7 does.  I think it always draws the whole scrollbar, and doesn't let
the window shrink below the size where a complete scrollbar can be rendered.

I reproduced this bug with Orbit 3+1 1.5 MiK and Modern themes.
(Reporter)

Comment 1

14 years ago
Please ignore the user agent string above.  I forgot that I changed it using the
UABar.  The UA string:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a1) Gecko/20040520

Also, I incorrectly characterized the behavior of 1.7rc2.  It too clips the
scrollbar, but more sensibly - mostly.  The scrollbar is clipped if:
- no sidebar is displayed and the window height is reduced to the point where
the thumb almost fills the paging region, or
- the sidebar is displayed and the height is reduced somewhat beyond the point
where the thumb disappears (!).
That's the behavior with the Orbit 3+1 1.5 MiK theme. With Modern, it's a bit
different.  It appears that the height at which the scrollbar stops shrinking
depends on how many sidebar tabs are displayed, and the thumb never disappears.
 Presumably the disappearing thumb is the fault of the Orbit theme.

Anyway...the 1.7rc2 behavior seems reasonable to me.  1.8a1 always clips the
scrollbar when the window falls below a certain height, regardless of the
presence or absence of a sidebar, which I find surprising.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 205566 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

14 years ago
I don't think this is a duplicate.  Bug 205566 takes issue with the behavior in
versions prior to 1.8a1.  This bug addresses a problem introduced in 1.8a1.  It
may be possible to fix both problems at once, but they cannot have the same
origin, since one existed long before the other.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
You need to log in before you can comment on or make changes to this bug.