reordering extensions in extension manager does not work correctly

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
P5
minor
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Teune van Steeg, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7) Gecko/20040526 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7) Gecko/20040527 Firefox/0.8.0+

When I open the extension manager with several extensions listed, and I use the
move up / move down / move to top functions in the contextmenu of an extension,
the DOM inspector extension seems to corrupt the ordening.

Reproducible: Always
Steps to Reproduce:
1.open the extension manager by Tools->Extensions
2.right-click on an extension choose move up / move to top / move down on
another extension then DOM inspector (which won't respond on the commands)
3.repeat this with other extensions or the same extension

Actual Results:  
the DOM inspector extension will not go lower then second place in the list,
only after move to top command on other extension. The other extensions listed
besides the DOMi extension, respond as if DOMi is not enlisted, leaving DOMi on
the second place or on top.

Expected Results:  
I should also be able to move DOMi, and DOMi should act on reordening as the
other extensions do.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040527
Firefox/0.8.0+ (zipper)

Confirmed, I think it's a (no offence) "weird" option, why would one like to
shuffle those ?

Comment 2

14 years ago
Confirming on Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040526
Firefox/0.8.0+
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

14 years ago
(In reply to comment #1)
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040527
> Firefox/0.8.0+ (zipper)
> 
> Confirmed, I think it's a (no offence) "weird" option, why would one like to
> shuffle those ?

I agree, the extensions should be just sorted alphabetically by name. 

Comment 4

14 years ago
After closing and reopening the extensions manager, DOMi is on top again.

Updated

14 years ago
Flags: blocking1.0?

Updated

14 years ago
Flags: blocking1.0? → blocking1.0+
Priority: -- → P5

Comment 5

14 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040828
Firefox/0.9.1+

DOMi isn't in the Extensions list anymore (bug 246316), and I can't reproduce
this with normal extensions.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

14 years ago
Summary: reordening extensions in extension manager does not work correctly → reordering extensions in extension manager does not work correctly

Updated

14 years ago
Flags: blocking-aviary1.0+
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.