AdBlock kills version 1.8

RESOLVED INVALID

Status

()

RESOLVED INVALID
15 years ago
14 years ago

People

(Reporter: beker, Unassigned)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a1) Gecko/20040520
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a1) Gecko/20040520

After a lot of frustrating attempts to go from 1.7 RC2 to 1.8a, I figured out
that installing AdBlock (which I LOVE) kills a successful installation of 1.8.

Something needs a fix.

Reproducible: Always
Steps to Reproduce:
1.use a profile with 1.8 with AdBlock OR install Adblock after 1.8 and it dies
2.Try to start Moz 1.8
3.Moz fails

Actual Results:  
Moz failks to install or to open properly

Expected Results:  
It should work.
Er... Sounds like a bug in adblock.  The nsIContentPolicy api (which adblock
almost certainly uses) has gotten changed recently.  Perhaps that's the issue? 
Have you reported this problem to the adblock folks?

Comment 2

15 years ago
AdBlock not working is a known AdBlock problem.

Since the original developer of AdBlock apparently is not doing maintenance,
others are working to get AdBlock compatible again.  See
http://forums.mozillazine.org/viewtopic.php?t=78895

Comment 3

15 years ago
Reporter if you have read the Adblock forums before you had know the reasons.
http://aasted.org/adblock/viewtopic.php?t=448&sid=b6a023d8065aa826d28ce84988ec4387

Bug 191839 changed the API. 

Please resolve this bug as INVALID (incompatible extension). You have to wait
for a new/patched Adblock versions.

I would find it a good idea to put something about the problems with extensions
like Adblock due to changes of bug 191839 to the release notes of Moz
1.8a2/1.8b/1.8 and FF 0.9.

Comment 4

15 years ago
(In reply to comment #3)
> I would find it a good idea to put something about the problems with extensions
> like Adblock due to changes of bug 191839 to the release notes of Moz
> 1.8a2/1.8b/1.8 and FF 0.9.

Because Adblock has many users and we will get a lot of dupes as soon as a lot
of people upgrade to 1.8x. For example see Bug 244584 and Bug 244353. 
> Please resolve this bug as INVALID (incompatible extension).

The bug is that the browser doesn't start, right?  This could be due to bad code
in the extension or bad code on the browser side introduced with the API change.
 Has anyone narrowed down which it is?

Comment 6

15 years ago
content/base/public/nsIContentPolicy.idl
revision 3.6 changed ShouldLoad

  NS_IMETHOD ShouldLoad(PRUint32 aContentType, nsIURI *aContentLocation, nsIURI
*aRequestOrigin, nsIDOMNode *aRequestingNode, const nsACString & aMimeTypeGuess,
nsISupports *aExtra, PRInt16 *_retval) = 0;

3.5
  boolean shouldLoad(in PRInt32 contentType, in nsIURI contentLocation,
                     in nsISupports ctxt, in nsIDOMWindow window);

This is causing errors during start, such as this
************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "Not enough arguments [nsIContentPolicy.shouldLoad]"  nsresult:
"0x80570001 (NS_ERROR_XPC_NOT_ENOUGH_ARGS)"  location: "JS frame ::
chrome://adblock/content/component.js :: anonymous :: line 56"  data: no]
************************************************************

Comment 7

15 years ago
Adblock d2 nightly 39 is now listed at
http://adblock.mozdev.org/dev.html

It should be compatible now. See the d2 changelog
http://aasted.org/adblock/viewtopic.php?t=155&sid=d59d1385e883ec56907ec591d36b4419

I will test it with 1.8a2 builds.

Comment 8

15 years ago
Adblock d2 nightly 39 works with Mozilla trunk build 2004062708 on WinNT4. I see
no difference to the old behavior on 1.7. Great!

Comment 9

14 years ago
Adblock was incompatible. Resolving.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.