[FIX]mailto protocol is not worked when using external mailer

RESOLVED FIXED in mozilla1.8alpha2

Status

Core Graveyard
File Handling
P1
major
RESOLVED FIXED
14 years ago
2 years ago

People

(Reporter: masayuki, Assigned: bz)

Tracking

({regression})

Trunk
mozilla1.8alpha2
regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040527
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040527

When I click the link of mailto protocol, Mozilla said "mailto is not a
registerd protocol".
However, In the case of normal setting, this problem does not reproduce.
This problem is only reproduced when having
'user_pref("network.protocol-handler.external.mailto", true);'.

Reproducible: Always
Steps to Reproduce:
1. Create a new profile.
2. Add a "[New] -> [Boolean]" in about:config.
3. Enter network.protocol-handler.external.mailto to the preference name,
   and its value set to true.
4. Click the any link that is mailto protocol.
Actual Results:  
Mozilla said "mailto is not a registerd protocol".
And external mailer was not launched.

Expected Results:  
External mailer should be luaunched.

This problem is reproduced on trunk only,
it works fine on 1.7 branch.
(Reporter)

Updated

14 years ago
Summary: mailto protocol does not be worked when using external mailer → mailto protocol is not worked when using external mailer

Comment 1

14 years ago
Is not problem in the registering of the 'mailto:' in Windows itself?
What happened when you try Srart->Run 'mailto:' -> will it start some application?
Met: My system has no problem.
It works fine from [start] -> [run]

See comment 0.
It *works fine* on 1.7 branch.

Comment 5

14 years ago
This bug also occurs under MacOSX 10.3.4 with the latest daily build. So, the
Hardware and OS categories need to be changed to "All" by the Reporter of this
bug or some other empowered party.
Is this problem reproduced with Linux and BSD?
Hardware and OS to All.
OS: Windows XP → All
Hardware: PC → All

Comment 7

14 years ago
Linux/FreeBSD issue is Bug 194717 which is old.
But confirmed the regression on 2004052208/Mac.
Marking New.
Over to File Handling.
Assignee: general → file-handling
Status: UNCONFIRMED → NEW
Component: Browser-General → File Handling
Ever confirmed: true
QA Contact: general → ian
Summary: mailto protocol is not worked when using external mailer → [Win,Mac] mailto protocol is not worked when using external mailer
confirming win2k 2004052909

I'd suspect:
1.173	bzbarsky%mit.edu	2004-05-20 17:28	 	Blocked protocols should still allow
URI creation; they should just fail
channel creation. Bug 244220, r+sr=darin
eh
bz:
    if (externalProtocol || NS_FAILED(rv)) {

      // If the pref for this protocol was explicitly set to false, we want to
      // use our special "blocked protocol" handler.  That will ensure we don't
      // open any channels for this protocol.
      if (listedProtocol) {
        rv = CallGetService(NS_NETWORK_PROTOCOL_CONTRACTID_PREFIX"default-blocked",
                            result);
        if (NS_FAILED(rv)) return NS_ERROR_UNKNOWN_PROTOCOL;

That codepath seems broken. We only want default-blocked if externalProtocol is
_false_, because if it is true, we want to make sure to get the default protocol
handler, because we _want_ to get the os handler.
Created attachment 149651 [details] [diff] [review]
Doh. Fix.
Assignee: file-handling → bzbarsky
Status: NEW → ASSIGNED
Comment on attachment 149651 [details] [diff] [review]
Doh. Fix.

We only want to use the blocked handler if we have the protocol listed as
"don't do external".  The old code did it if it was listed at all...
Attachment #149651 - Flags: superreview?(darin)
Attachment #149651 - Flags: review?(cbiesinger)
Priority: -- → P1
Summary: [Win,Mac] mailto protocol is not worked when using external mailer → [FIX]mailto protocol is not worked when using external mailer
Target Milestone: --- → mozilla1.8alpha2
Attachment #149651 - Flags: review?(cbiesinger) → review+

Updated

14 years ago
Attachment #149651 - Flags: superreview?(darin) → superreview+
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.