can't create tags with <xsl:text>

RESOLVED DUPLICATE of bug 98168

Status

()

Core
XSLT
--
major
RESOLVED DUPLICATE of bug 98168
14 years ago
14 years ago

People

(Reporter: niuxiao, Assigned: peterv)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

This is the XML file:

<?xml version="1.0"?>
<?xml-stylesheet type="text/xsl" href="a.xsl"?>
<a></a>

And this is the XSLT file:

<?xml version="1.0"?>
<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0">
	<xsl:template match="a">
		<html>
			<xsl:text disable-output-escaping="yes">&lt;b&gt;google&lt;/b&gt;</xsl:text>
		</html>
	</xsl:template>
</xsl:stylesheet>

Then you open the xml file with Mozilla, the output is "<b>google</b>" rather
than a bold "google", it is a bug. Both IE and xalan do the right thing.

This example is trivial, but I use this technique to create links dynamically,
it doesn't work on Mozilla, which is my favorite browser. I hope this bug will
be fixed when 1.7 released.

Any way, please contact me!

Reproducible: Always
Steps to Reproduce:
1. Create a XML file:
<?xml version="1.0"?>
<?xml-stylesheet type="text/xsl" href="a.xsl"?>
<a></a>

2.Create a XSLT file:
<?xml version="1.0"?>
<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0">
	<xsl:template match="a">
		<html>
			<xsl:text disable-output-escaping="yes">&lt;b&gt;google&lt;/b&gt;</xsl:text>
		</html>
	</xsl:template>
</xsl:stylesheet>

3.Open the XML file with Mozilla.

Actual Results:  
<b>google</b>

Expected Results:  
a bold "google"
Assignee: hjtoi-bugzilla → peterv
Component: XML → XSLT
QA Contact: ashshbhatt → keith
(Assignee)

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 98168 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.