Closed Bug 244987 Opened 16 years ago Closed 13 years ago

Mac Firefox hangs on this Flash site

Categories

(Core :: Plug-ins, defect, critical)

PowerPC
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: marc, Unassigned)

References

()

Details

(Keywords: hang, Whiteboard: [asaP2])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

On complicated flash files firebird freezes and animations stop. 
- When the mouse button is down the animation starts to run again
- When released it stops. 
- Firefox is disable and I need to force quit and restart to browse again
- Safari is able to run this animation without freezing
- I was able to reproduce this on 10.3.4 on G5 and a Powerbook G4

Reproducible: Always
Steps to Reproduce:
1.launch the above URL
Summary: http://www.toyota.com/vehicles/2004/highlander/minisite/index.html → mac flash freeze
Confirmed using Firefox 2004-05-04-07-trunk. It WFM using Mozilla-Mac/1.7RC2.
Assignee: nobody → firefox
Severity: normal → critical
Status: UNCONFIRMED → NEW
Component: Plug-ins → General
Ever confirmed: true
Keywords: hang
Product: Browser → Firefox
QA Contact: core.plugins → firefox.general
Summary: mac flash freeze → Mac Firefox hangs on this Flash site
Version: Trunk → unspecified
WFM

Mac OS X 10.3.4
Shockwave Flash 7.0 r19
2004-05-29 AVIARY_1_0_20040515_BRANCH build
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040529
Firefox/0.8.0+
Hmm.. while performance is not wonderful on that site, it doesn’t hang for me. 

WFM Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a2)
Gecko/20040527 Firefox/0.8.0+
It does appear to WFM using the more recent 2004-05-29-trunk build. Marc, can
you still reproduce this using a current nightly build?
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a2) Gecko/20040530
Firefox/0.8.0+

(Today's build)

WFM
Installed: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040530 Firefox/
0.8.0+

Also tried reinstalling flash.

Still dies on my Powerbook 17", I'll try it on the G5 at work when I go in. 
WFM with "Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7)
Gecko/20040530 Firefox/0.8.0+" (AVIARY based offical nighty)
sorry for the spam, forgot to add that it also works with my latest trunk
nighty, "Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a2)
Gecko/20040531 Firefox/0.8.0+ (MMx)"
*** Bug 243153 has been marked as a duplicate of this bug. ***
you can also check http://www.djyahel.com/ (enter the site)

runs very very slow - works great on safari.

running osx 10.3.4, powerbook 17" 1.5ghz, 1gb ram.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040531
Firefox/0.8.0+
confirmed. very very annoying.
OS X 10.3.4 (7H63), flash 7r19, firefox 0.9
I have a problem viewing www.samsung.ca, which is a flash heavy site. Firefox
freezes inexplicably everytime I visit this site. I visited the toyota site, its
slow, but does not freeze in a similar fashion as the samsung site.
(In reply to comment #13)
> I have a problem viewing www.samsung.ca, which is a flash heavy site. Firefox
> freezes inexplicably everytime I visit this site. I visited the toyota site, 
> it's slow, but does not freeze in a similar fashion as the samsung site.

Can I emphasise this. My comment 6 should be read as the index site
http://www.toyota.com/vehicles/2004/highlander/minisite/index.html not
crashing. It is slow and doesn't display the complete loaded status in
the status bar.

There are other sites and recipes mentioned here that do cause a crash. I am
unclear whether we have two or more problems with Flash.
> There are other sites and recipes mentioned here that do cause a crash. I am
> unclear whether we have two or more problems with Flash.

In my experience, this behavior _always_ occurs in Firefox on Mac OS X using the Flash 7 plugin with a 
flash file that includes progressive/streaming video - that is, the flv video is not embedded in the flash 
file but imported after the initial swf loads. I quit using Firefox because of this bug, since many movie 
sites (like imdb.com) are now including flash movie trailers in their banner ads. Basically the whole 
browser freezes up until you hold down the left mouse button. Holding down the mouse button does 
not release the freeze, it simply allows the flash video to continue playing. Sometimes the browser will 
be freed up again when the video makes it to the end. Sometimes not. Not much fun. I was hoping this 
would be fixed in Firefox 1.0 (released this week), but it did not. My specs...

Powerbook G4 400mhz 512mb RAM
Mac OS 10.3.5
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0


Example site: Redbull Co-Pilot : http://www.redbullcopilot.com/supermoto/launch.html
--- choose "the Race"
(i realize this is a complex flash site, but i have seen the same behavior on much simpler sites)
Freezes are not limited to streaming video from an external source.
www.rollobikes.com sometimes chokes my machine and it is a standalone file.
I can confirm this, using iMac G5 with Firefox 1, MacOs X 10.3.6. Websites with
two or more flash movies renders slowly and makes the system slow down. Hogs up
sysem resources. Works perfectly fine on Camino, Safari etc..
I am having problems with Flash Player in Firefox and other Mozilla products. I
couldn't reproduce the freeze on the Toyota site, but this page consistently
freezes all the Mozilla browsers I have tried it with, including Firefox build
20041107 (that's 1.0), Mozilla build 20041204, and Camino build 20040927. The
page does not freeze when viewed in Safari or Opera, and also does not freeze in
the Windows version of Firefox.

http://www.homestarrunner.com/yellodellomenu.html

I am voting for this bug because it is the only major problem I am having with
an otherwise excellent browser.
Any web sites where they use Flash animation causes this problem.

Try browsing these sites : www.joins.com, www.chosun.co.kr, www.hani.co.kr and
so on. Korean news paper web sites use flash animations heavily.

This also happens on Windows machine too.

I think this bug has reported multiple times under different subject name.
So, probably many people will be aware of this.
Another example site to freeze the browser: http://lunarpages.com/

In a single window, open two or more links for lunarpages.com pages in tabs. 
The same Flash header will be on each of these pages.  Within seconds, Firefox
will become unresponsive; the Flash animation will stop or slow to a crawl, but
will resume normal speed when the mouse button is held down.

However, the rest of Firefox will be completely unusable; if you manage to get a
click to close the window, through, Firefox will once again become responsive.

Getting the window closed is quite a challenge, though; you must click on the
close button many, MANY times, and pray it gets through the lag.  My best
strategy has been clicking rapidly on the Firefox window close button when
another app is in the foreground, and then switching back and forth between
Firefox and the other app rapidly.  This usually works to close the window, but
on some occasions I've had to Force Quit Firefox because it's locked up.


There are way too many bugs dealing with this issue; Frankie made a list of some
of them in Bug 106397 Comment #24.  Some place the blame on Mozilla's event
handling, others the Mac version of the Flash plugin.  I wish these bugs would
be treated more seriously; Flash may be annoying, but it is everywhere on the
web, and this is a bug that consistently causes the app to hang.
Flags: blocking-aviary1.1?
Also 

http://is0.info/portal/content/2001/pistenpano_neu/orimport.html

makes Firefox unresponsive. Versions: Firefox 1.0.1, Shockwave Flash 7.0 r24 on
Mac OS X 10.3.8

In the Flash animation the cable cars are moving, the colour of the buttons in
the animation change when you press them, but the animation is not responding.
Component: General → Plug-ins
Product: Firefox → Core
Version: unspecified → 1.0 Branch
Whiteboard: [asaP2]
Mac OSX 10.3.8, FireFox 1.0.3

I agree with everyone else. I love FireFox so far except for this problem. I
have problems with streaming FLV files. The sound plays fine, but the video does
not show up unless I hold down the mouse button. 

http://www.estdesigns.com/siteupdate

Yes, I know it's a large video file, but it still plays in IE.
Now, this might be something related to the **** performance of Firefox with
Flash, when opening Firefox and attempting to view flash content, I get this
message on my console.log 
*************

/Applications/Firefox.app/Contents/MacOS/firefox-bin: can't map file:
/Library/Internet Plug-Ins/Flash Player.plugin ((os/kern) invalid argument)
## Component Manager: attempting to find symbols in a component alias of type
(regR/carP/x!bt)

**********************
Needless to say, I have the Flash plugin there, all my other browsers use it
just fine.

 Open your "Console" on the Utilities folder and see what you get when opening
Firefox and finding flash content.

I actually perceived a minor improvement with flash on the last version.
Blocks: 300398
Flags: blocking1.8b4?
Flags: blocking-aviary1.1?
Flags: blocking-aviary1.1-
Flags: blocking1.8b4? → blocking1.8b4-
Assignee: firefox → nobody
QA Contact: general → plugins
Version: 1.0 Branch → Trunk
Sorry for the long absence. This bug appears to be fixed.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Marc, FYI the proper resolution is WORKSFORME if it works but you don't know what patch/bug fixed it.  In addition, we don't know if it was solved in FF or the plugin. Thanks for closing the bug.
Resolution: FIXED → WORKSFORME
My bad. Sorry about that.
You need to log in before you can comment on or make changes to this bug.