html code which can freeze mozilla 1.6

RESOLVED WORKSFORME

Status

()

Core
HTML: Parser
--
critical
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Michael Prager, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.6) Gecko/20040528
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.6) Gecko/20040528

when visiting http://www.boardmod.org/stuff/mozilla_16_hard_crash.html with
Mozilla 1.6 (win and linux versions tested) the browser will freeze. I've
stripped the html code down to pin the problematic code down but it looks like
this problem is caused by multiple tags. Check out the minimal code to freeze
Mozilla here:

http://www.boardmod.org/stuff/mozilla_16_crash.html

Note that with the stripped code, the browser is not frozen completely. All the
menus and buttons won't work anymore but you can still click links on the
currently loaded webpage. I know that the html code does not use 100% valid html
but still, with this code it's possible to freeze the browser which may result
in data lost for the user. The problem does not occure using Mozilla 1.5.

Reproducible: Always
Steps to Reproduce:
1. open http://www.boardmod.org/stuff/mozilla_16_crash.html
 with mozilla 1.6
2.
3.

Actual Results:  
browser freezes

Expected Results:  
browser should display the page

Comment 1

14 years ago
WFM Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2) Gecko/20040526
(Reporter)

Comment 2

14 years ago
The problem does not affect Mozilla 1.5 or 1.7, it only freezes Mozilla 1.6!
So in other words this has been fixed since 1.6?

Marking worksforme, since it does.  1.6 is not a long-lived branch, so
maintenance releases for it are not going to happen (especially since 1.7 is
about to ship).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

14 years ago
Oh ok I thought that 1.6 was long-lived branch. Never mind.
Ah, ok.  Yeah, the only long-lived branches to date are 1.0, 1.4, and 1.7.
You need to log in before you can comment on or make changes to this bug.