"Remove Site" from Cookie Sites dialog is extremely slow

VERIFIED WORKSFORME

Status

()

Core
Networking: Cookies
VERIFIED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Graham, Assigned: Darin Fisher)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040528 Debian/1.6-7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040528 Debian/1.6-7

I appreciate all the work that has gone into Mozilla to speed it up. But this is
rather annoying.

I have a Celeron 850MHz -- not the fastest machine on the block, but certainly
still usable. My "cookperm.txt" is about 48kB.

When I select one item from the Cookie Sites list and then click Remove Site, it
takes about 9 seconds.

When I select multiple items, the time required to complete the operation
increases linearly -- ie., about 18 seconds to remove two sites.

If I ask it to remove, say, 50 sites, then mozilla is essentially frozen with
the CPU pinned at 100% for... well, far too long. Long enough that if you don't
already know that it's going to take an insanely long time, you might be
inclined to think Mozilla is dead and you might as well kill it and restart it.

What is mozilla doing for these 9 seconds? If it is only deleting one line from
"cookperm.txt" then it should be easy to make this faster, shouldn't it?

Thanks

-- graham

Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
Wasn't this fixed by bug 226511 ? That wasn't in Mozilla 1.6, but it's in
Mozilla 1.7.
Assignee: general → darin
Component: Browser-General → Networking: Cookies
QA Contact: general → core.networking.cookies
reporter, can you retest with a current build (i.e. 1.7 RC2)?  There has been
considerable performance improvements within the cookie manager since 1.6,
please try a current build.
(Reporter)

Comment 3

14 years ago
Sorry about that. 1.6 is the latest Debian packaged version (aside from the
"snapshot" packages, which I don't particularly like using), so that's what is
on my system for now...

However, I do have 1.7b installed on Windows. You're right, the cookie manager
is blazing fast now -- fast enough that I can't even measure how long it takes
to remove a site from the list. Good job!

If this performance fix is platform independent (as I expect it is), then I'm
happy and you're welcome to close this bug.

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 4

14 years ago
V:
the cookie people (mvl, dwitte, mconner + darin) rock. I'm on holiday, so I can
be smug for a while.
Status: RESOLVED → VERIFIED
QA Contact: core.networking.cookies → benc
You need to log in before you can comment on or make changes to this bug.