Crash when opening the URL [@ nsHTMLReflowState::Init ]

RESOLVED DUPLICATE of bug 243528

Status

--
critical
RESOLVED DUPLICATE of bug 243528
15 years ago
8 years ago

People

(Reporter: thorgal, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040514
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040514

Mozilla crashes upon visiting http://scubatech.pl/cgi/sklep/sklep.cgi . No debug
information appears in the shell.

Reproducible: Always
Steps to Reproduce:
1. Just visit the URL.
(Reporter)

Comment 1

15 years ago
Sample Talkback incident IDs: TB66738W, TB66736E, TB66734Q.

Comment 2

15 years ago
WFM Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a2) Gecko/20040528
Shockwave Flash 7.0 r19,  Java Plug-in 1.4.2_04 

There is a lot of flash on this site, is your flash player working?

http://scubatech.pl/maski.swf

When I used the home button in the flash menu above, my Java plugin started.
Is your Java installed correctly?

Comment 3

15 years ago
wfm win98 2004052909
(Reporter)

Comment 4

15 years ago
Both java and javaless installations crash here in exactly the same way.
(Reporter)

Comment 5

15 years ago
Also, flash 7 is present. Fixing Version field, as this is not trunk but 1.7rc2.
Version: Trunk → Other Branch

Updated

15 years ago
Severity: normal → critical
Keywords: crash
Summary: Crash when opening the URL. → Crash when opening the URL [@ nsHTMLReflowState::Init ]
Version: Other Branch → Trunk

Comment 6

15 years ago
All talkback IDs give identical stack:

Stack Signature nsHTMLReflowState::Init() cb3c77f0 
Product ID Mozilla17 
Build ID 2004051407 
Trigger Time 2004-05-30 08:59:34.0 
Platform LinuxIntel 
Operating System Linux 2.6.4 
Module libgklayout.so + (000a33b9) 
URL visited scubatech.pl/cgi/sklep/sklep.cgi 
User Comments  
Since Last Crash 0 sec 
Total Uptime 20 sec 
Trigger Reason SIGSEGV: Segmentation Fault: (signal 11) 
Source File, Line No. N/A 
Stack Trace  

nsHTMLReflowState::Init()
nsHTMLReflowState::nsHTMLReflowState()
nsTableCellFrame::Reflow()
nsContainerFrame::ReflowChild()
nsTableRowFrame::IR_TargetIsChild()
nsTableRowFrame::IncrementalReflow()
nsTableRowFrame::Reflow()
nsContainerFrame::ReflowChild()
nsTableRowGroupFrame::IR_TargetIsChild()
nsTableRowGroupFrame::IncrementalReflow()
nsTableRowGroupFrame::Reflow()
nsContainerFrame::ReflowChild()
nsTableFrame::IR_TargetIsChild()
nsTableFrame::IncrementalReflow()
nsTableFrame::Reflow()
nsContainerFrame::ReflowChild()
nsTableOuterFrame::OuterReflowChild()
nsTableOuterFrame::IR_InnerTableReflow()
nsTableOuterFrame::IR_TargetIsInnerTableFrame()
nsTableOuterFrame::IR_TargetIsChild()
nsTableOuterFrame::IncrementalReflow()
nsTableOuterFrame::Reflow()
nsBlockReflowContext::ReflowBlock()
nsBlockFrame::ReflowBlockFrame()
nsBlockFrame::ReflowLine()
nsBlockFrame::ReflowDirtyLines()
nsBlockFrame::Reflow()
nsBlockReflowContext::ReflowBlock()
nsBlockFrame::ReflowBlockFrame()
nsBlockFrame::ReflowLine()
nsBlockFrame::ReflowDirtyLines()
nsBlockFrame::Reflow()
nsBlockReflowContext::ReflowBlock()
nsBlockFrame::ReflowBlockFrame()
nsBlockFrame::ReflowLine()
nsBlockFrame::ReflowDirtyLines()
nsBlockFrame::Reflow()
nsBlockReflowContext::ReflowBlock()
nsBlockFrame::ReflowBlockFrame()
nsBlockFrame::ReflowLine()
nsBlockFrame::ReflowDirtyLines()
nsBlockFrame::Reflow()
nsContainerFrame::ReflowChild()
CanvasFrame::Reflow()
nsBoxToBlockAdaptor::Reflow()
nsBoxToBlockAdaptor::DoLayout()
nsBox::Layout()
nsScrollBoxFrame::DoLayout()
nsBox::Layout()
nsContainerBox::LayoutChildAt()
nsGfxScrollFrameInner::LayoutBox()
nsGfxScrollFrameInner::Layout()
nsGfxScrollFrame::DoLayout()
nsBox::Layout()
nsBoxFrame::Reflow()
nsGfxScrollFrame::Reflow()
nsContainerFrame::ReflowChild()
ViewportFrame::Reflow()
IncrementalReflow::Dispatch()
PresShell::ProcessReflowCommands()
PresShell::FlushPendingNotifications()
nsDocument::FlushPendingNotifications()
nsHTMLDocument::FlushPendingNotifications()
nsHTMLExternalObjSH::GetPluginInstance()
nsHTMLExternalObjSH::PostCreate()
XPCWrappedNative::GetNewOrUsed()
XPCConvert::NativeInterface2JSObject()
nsXPConnect::WrapNative()
nsXBLPrototypeHandler::ExecuteHandler()
nsXBLPrototypeHandler::BindingAttached()
nsXBLPrototypeBinding::BindingAttached()
nsXBLBinding::ExecuteAttachedHandler()
nsBindingManager::ProcessAttachedQueue()
nsCSSFrameConstructor::ContentAppended()
PresShell::ContentAppended()
nsDocument::ContentAppended()
nsHTMLDocument::ContentAppended()
nsGenericElement::InsertChildAt()
nsGenericElement::doInsertBefore()
nsHTMLDivElement::InsertBefore()
InsertElementTxn::DoTransaction()
nsTransactionItem::DoTransaction()
nsTransactionManager::BeginTransaction()
nsTransactionManager::DoTransaction()
nsEditor::DoTransaction()
nsEditor::InsertNode()
nsEditor::InsertTextImpl()
nsTextEditRules::WillInsertText()
nsTextEditRules::WillDoAction()
nsPlaintextEditor::InsertText()
nsTextControlFrame::SetValue()
nsTextControlFrame::InitEditor()
nsTextControlFrame::PostCreateFrames()
nsCSSFrameConstructor::CreateAnonymousFrames()
nsCSSFrameConstructor::CreateAnonymousFrames()
nsCSSFrameConstructor::ConstructHTMLFrame()
nsCSSFrameConstructor::ConstructFrameInternal()
nsCSSFrameConstructor::ConstructFrame()
nsCSSFrameConstructor::ProcessInlineChildren()
nsCSSFrameConstructor::ConstructInline()

Comment 7

15 years ago

*** This bug has been marked as a duplicate of 243528 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Crash Signature: [@ nsHTMLReflowState::Init ]
You need to log in before you can comment on or make changes to this bug.