Closed Bug 245102 Opened 20 years ago Closed 20 years ago

GIFs displayed distorted

Categories

(SeaMonkey :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 239701

People

(Reporter: thomas.billert, Unassigned)

References

()

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a1) Gecko/20040520
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a1) Gecko/20040520

In some occasions, GIFs containing transparency are displayed distortedly. The
appear like consisting of multiple layers that are shifted against each other.
GIFs showing this problem may be displaed correctly in other places of a web
page (as seen with the two NEW-buttons on http://www.sonnenblen.de/, the left
one is distorted while the right one looks correctly). The problem was
introduced with version 1.6 (probably).

Dragging the browser window smaller helps sometimes, but not with all occurences
of the problem. An example of an image where this helps is
http://www.billert.de/images/decode.gif

Reproducible: Always
Steps to Reproduce:
1. Go the http://www.sonnenblen.de/
Actual Results:  
- Have a look at the rotating NEW-buttons
- The left one looks distorted, the right one looks correctly.

Expected Results:  
Display both buttons equally correct.
as seen in the attachment of comment 3, there was a slight problem in version
1.5 also - note that it is just the leftmost GIF that has a bit of speckling
around the border
(In reply to comment #2)
> Created an attachment (id=149632)
> Both images are the same file, one is displayed okay, the other not

They are made from the same file, same height, but different width:

<img src="images/newanimation1.gif" width="64" height="25" align="top">
<font size="+1">Seti@home Team st&uuml;rmt die deutschen Top100!</font> <font
size="+1"> </font>
<img src="images/newanimation1.gif" width="60" height="25" align="top">  

Of course that´s not the reason for the distortion, it´s the reason that they
may behave differently.
this should be fixed in latest nightly build, please reopen if not.

*** This bug has been marked as a duplicate of 239701 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: