non-static Firefox built in OS X.3 crashes in OS X.2

RESOLVED DUPLICATE of bug 232972

Status

()

RESOLVED DUPLICATE of bug 232972
15 years ago
15 years ago

People

(Reporter: MMx, Assigned: bryner)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
UA: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a2)
Gecko/20040530 Firefox/0.8.0+ (MMx)

I built some trunk nighties of Firefox lately and I got the feedback that it
crashes at startup on OS X.2.8. I tracked it down to the point that it does not
happen with static builds, only with non-static.
From the console output I get it looks that there are some symbols used that OS
X.2 das not have, so dyld fails to prebind.

Steps to reproduce:
1. build Firefox from CVS in 10.3, using default mozconfig and "--disable-debug
--disable-test --enable-optimze=-O2"
2. run it in 10.2

Result: it crashes on startup, generating console output and crashlog

expected: prebind correctly and start up

Additional information:
console output:
--------8<---------
*** eeeeeeee = [Exception... "Component returned failure code: 0x80520012
(NS_ERROR_FILE_NOT_FOUND) [nsIFile.remove]"  nsresult: "0x80520012
(NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame ::
file:///Users/martin/Desktop/Firefox.app/Contents/MacOS/components/nsExtensionManager.js
:: ensureExtensionsFiles :: line 217"  data: no]
/Users/martin/Desktop/Firefox.app/Contents/MacOS/firefox-bin: can't map file:
/Users/martin/Desktop/Firefox.app/Contents/MacOS/plugins/Default Plugin.plugin
((os/kern) invalid argument)
/Users/martin/Desktop/Firefox.app/Contents/MacOS/firefox-bin: can't map file:
/Library/Internet Plug-Ins/QuickTime Plugin.plugin ((os/kern) invalid argument)
/Users/martin/Desktop/Firefox.app/Contents/MacOS/firefox-bin: can't map file:
/Library/Internet Plug-Ins/Java Applet.plugin ((os/kern) invalid argument)
dyld: /Users/martin/Desktop/Firefox.app/Contents/MacOS/firefox-bin Undefined
symbols:
/Users/martin/Desktop/Firefox.app/Contents/MacOS/components/libgfx_mac.dylib
undefined reference to _PR_Realloc expected to be defined in Carbon
May 30 22:02:17 Maxwell crashdump: Crash report written to:
/Users/martin/Library/Logs/CrashReporter/firefox-bin.crash.log
-----------8<---------
(Reporter)

Comment 1

15 years ago
Created attachment 149646 [details]
crash log

crash log of the incident described above

Comment 2

15 years ago
How is it in the case where --with-macos-sdk is attached?
Although Installation of 10.2.8SDK is Also Needed...

Comment 3

15 years ago
Yes, you need to install Mac OS X 10.2.8 SDK by Xcode custom install,
and use --with-macos-sdk=/Developer/SDKs/MacOSX10.2.8.sdk like as 
official builds.

*** This bug has been marked as a duplicate of 232972 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.