Should send cache-friendly headers on /releases/ subdir on http://ftp.mozilla.org/

RESOLVED FIXED

Status

RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: yusufg, Assigned: kveton)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2) Gecko/20040531 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2) Gecko/20040531 Firefox/0.8.0+

To help firefox or any other project release from mozilla.org reach more people
with lesser strain to the mirror system. It would be nice if mozilla.org along
with its mirror admins sent out cache-friendly headers from files served from
within /releases/ subdir

Specifc details on configuring webservers for cache-friendly headers found here
http://www.mnot.net/cache_docs/

Making Firefox/Thunderbird/SeaMonkey "releases" serve out of the last mile ISP
would make download much faster and provide mirror servers with the capacity to
serve more users



Reproducible: Always
Steps to Reproduce:
1. curl -I
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/0.8/FirefoxSetup-0.8.exe
3.
2. Look for Expires header
Actual Results:  
No Expires headers found

Expected Results:  
An Expires header of one week or two week would be appropiate
Most proxy servers I know have a limit on the size of files that they'll
actually cache, and I would bet that the multi-megabyte Mozilla binaries are
probably bigger than that limit on most proxies...
(Assignee)

Comment 2

14 years ago
Since we are using Bouncer now this is bug is moot.  We have over 90 mirrors now
each with a different URL so the odds are very slim that having this header
would yield much good.  In addition, it would be difficult to coordinate with
each of the mirror admins to make this happen appropriately.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.