Listbox selections wider than dropdown scroll list unexpectedly

RESOLVED DUPLICATE of bug 232540

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 232540
14 years ago
14 years ago

People

(Reporter: Derek Upham, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040530 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040530 Firefox/0.8

I have a sample HTML page with a dropdown listbox (see attachment).  There are
many text elements in the listbox, and they are extremely long.  Single-clicking
on the dropdown button reveals the listbox as I would expect.  However, when I
move my mouse down over the listbox, it scrolls the box down without any other
actions on my part.  The problem appears to be triggered by listbox entries that
exceed the width of the listbox.


Reproducible: Always
Steps to Reproduce:
1. Click once on the "down arrow" button at the edge of the listbox, revealing
the scrolling area.
2. Move the mouse down the list of items without performing any button actions.

Actual Results:  
The listbox scrolled down to the bottom of the list as I moved the mouse down
the list.


Expected Results:  
The listbox should not have scrolled.  This is the behavior when the list
entries are not as wide as the scrolling window.  The current behavior makes it
difficult to select the topmost items in the listbox.


This is with the default theme.  I'm also able to reproduce it with plain Mozilla

  Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040528 Debian/1.6-7

I'll add an HTML testcase shortly.
(Reporter)

Comment 1

14 years ago
Created attachment 149731 [details]
HTML sample with dropdown that demonstrates the bug

Here's an HTML file that demonstrates the bug on my machines.
This is already fixed on trunk (and this bug is a duplicate).
Whiteboard: DUPEME

Comment 3

14 years ago
WFM: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040601

WFM: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2) Gecko/20040601 Firefox/0.8.0+

*** This bug has been marked as a duplicate of 232540 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.