onchange not triggered when drop down list is selected by mouse

RESOLVED DUPLICATE of bug 245096

Status

()

Core
DOM: Events
--
major
RESOLVED DUPLICATE of bug 245096
14 years ago
14 years ago

People

(Reporter: Kevin Ar18, Unassigned)

Tracking

({dom1, regression})

Trunk
dom1, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040531 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040531 Firefox/0.8.0+

You are unable to trigger the onchange event in a drop down list when you select
the items with the mouse.

Reproducible: Sometimes
Steps to Reproduce:
1. Go to http://anandtech.com/video/showdoc.html?i=2066
2. Find the drop down part way down the page (in the center column).
3. Select an item from the drop down
4. Click outside of the drop down to remove focus.

Actual Results:  
Nothing happens in most cases; based on a testcase, the onchange event is not
triggered.

Expected Results:  
The onchange event should be triggered after the drop down loses focus.

When selecting the items using the keyboard, the drop down works as expected.
(Reporter)

Updated

14 years ago
Keywords: dom1, regression
Fix checked in yesterday.

*** This bug has been marked as a duplicate of 245096 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.