Images inside links to "upload." do not display

RESOLVED INVALID

Status

()

RESOLVED INVALID
15 years ago
4 months ago

People

(Reporter: samc, Assigned: jdunn)

Tracking

({testcase})

Trunk
PowerPC
Mac OS X
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

399 bytes, text/html
Details
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040514
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040514

Images inside links whose HREFs end in files that are named "upload." (e.g.
"upload.txt", "upload.php", etc) do not display.

Reproducible: Always
Steps to Reproduce:
Try the following HTML:
     <a href="upload.txt"><img src="foo.gif"></a>
Nothing is displayed, whether "foo.gif" exists or not.

Now try:
     <a href="upload2.txt"><img src="foo.gif"></a>
Note that an image (or broken image placeholder) appears.
Actual Results:  
No image is displayed.

Expected Results:  
An image should be displayed.

This problem exists in Mozilla 1.7RC2 and 1.6.

Comment 1

15 years ago
Created attachment 149778 [details]
Test case

WFM on latest trunk nightly (2004053108) of Mozilla on Mac OS X 10.3.4. Test
case attached, showing the two hyperlinks. Whether the images point to an image
that exists or not made no difference, got the appropriate one of the image or
broken image link graphic for both images.
If it depends on the href, then chances are you're using an ad-blocker that
blocks those images for some reason....

I cannot reproduce the bug on Linux either.

Comment 3

15 years ago
Created attachment 149818 [details]
Revised HTML testcase

This testcase actually points to an image on the Web. WFM using Mac/1.8a1.
Attachment #149778 - Attachment is obsolete: true

Comment 4

15 years ago
Belongs on L:I though this is probably ultimately WFM.
Assignee: general → jdunn
Component: Browser-General → Layout: Images
Keywords: testcase
QA Contact: general → core.layout.images
(Reporter)

Comment 5

15 years ago
Please close this bug -- after more investigation, it has turned out to be an
error in my local configuration.

Sorry for the false alarm and thanks everyone for your time (and patience)!
Marking invalid.  Thanks for checking on the local configuration!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Updated

4 months ago
Product: Core → Core Graveyard

Updated

4 months ago
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.