Malformed install.rdf prevents Firefox from running

RESOLVED FIXED

Status

()

Toolkit
Add-ons Manager
P2
critical
RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: PikeUK, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({fixed-aviary1.0})

unspecified
x86
Windows 98
fixed-aviary1.0
Points:
---
Bug Flags:
blocking-aviary1.0PR +
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
The attached xpi file has an install.rdf with an <em:package> that points to a
non-existent location (in this case the jar is empty, though when I originally
saw this it was due to a typo). After attempting to install the xpi, every start
of Firefox will result in a "Finishing Extension Installation" dialog that never
disappears. Deleting the extensions sub-folder in the profile is the easiest way
of clearing the problem.

This could be considered to be an extension bug rather than a Firefox bug, but I
think that FF should handle the situation more gracefully so that the problem
can't be used as any sort of "attack" (though maybe with the white-list that has
been discussed in various places this won't be problem). I have no idea if
-no-extensions will bypass this problem as that feature seems broken at the
moment, I'll file a bug on that in a minute.
(Reporter)

Comment 1

14 years ago
Created attachment 149821 [details]
Installing this breaks Firefox (delete extensions sub-folder in profile to recover)
(Reporter)

Comment 2

14 years ago
I always forget how powerful extensions are, using this bug as an "attack" would
be pretty stupid, since a properly installed extension could do a lot more harm.
Anyway it would still be nice if broken install.rdf files were handled better.

Comment 3

14 years ago
Created attachment 150441 [details]
ieview XPI causing installer hang

Another XPI which causes the same problem.  Trying to upgrade IEView to live
within the 0.9 setup, but I'm running into this wall.  Obviously, something's
wrong with my XPI layout or the install.rdf, but there's no feedback as to
what.
(Reporter)

Comment 4

14 years ago
(In reply to comment #3)
> Another XPI which causes the same problem.  Trying to upgrade IEView to live
> within the 0.9 setup, but I'm running into this wall.  Obviously, something's
> wrong with my XPI layout or the install.rdf, but there's no feedback as to
> what.

You need to put the jar file into a chrome sub-folder.

Comment 5

14 years ago
Thanks - solves the install problem for this extension.  Nonetheless, the
behavior when running into bonehead install mistakes like mine is sub-optimal.

Comment 6

14 years ago
I ran into the same issue and filed bug 246369. IMHO, Firefox should gracefully
skip invalid extension install manifests.
Flags: blocking0.9?

Comment 7

14 years ago
I have tried to delete the subfolders, but it still hangs.  I then deleted the 
two extension sub-folders, but it still hangs.  I then reinstalled over the 
initial installation, and it still hangs.  Any suggestions?

Comment 8

14 years ago
Please try removing and/or completely renaming any of the following directories
you might have:

%APPDATA%\Firefox (ie. C:\Documents and Settings\Username\Application Data\Firefox)
%APPDATA%\Mozilla

And try again, with a completely clean profile.  Often the culprits are the
chrome directory and the extensions directory - but the XUL and localstore data
files can get corrupted too, in my experience.

-[Unknown]
Flags: blocking1.0?

Updated

14 years ago
Flags: blocking0.9?

Comment 9

14 years ago
Caught me out when upgrading my Diggler extension

Updated

14 years ago
Blocks: 248125
Flags: blocking-aviary1.0RC1+
Flags: blocking-aviary1.0?
Flags: blocking-aviary1.0+
Priority: -- → P2
Created attachment 153013 [details] [diff] [review]
patch

if chrome registration fails:
- show a warning to the user
- the warning has a "View Details" button extension authors can use to get full
details from the error console
- the extension is uninstalled so it does not leave cruft in the EM or cause
incompatibility headaches.
br & trunk fixed. 
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

14 years ago
*** Bug 248128 has been marked as a duplicate of this bug. ***

Comment 13

14 years ago
setting fixed-aviary1.0 for bugfixes checked into branch, for searching purposes.
sorry for bugspam.
Keywords: fixed-aviary1.0
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.