[Contacts side bar is empty in the compose window] and ["Add to Address Book ..." pane isn't filling in]

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: hariskar, Assigned: neil)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040601 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040601 Firefox/0.8.0+

When I open the window to write a new mail, the contacts side bar is empty,
allthough my address book shows my contacts normaly. This bug exists since 20040602

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

14 years ago
I forgot to mention that I use the trunk

Comment 2

14 years ago
Error: setting a property that has only a getter
Source File: chrome://messenger/content/addressbook/abContactsPanel.js
Line: 131

Addressbook searching uses the same code and is broken with the same error:
Error: setting a property that has only a getter
Source File: chrome://messenger/content/ABSearchDialog.js
Line: 113

Regression from bug 244624?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
(Assignee)

Comment 3

14 years ago
Created attachment 149901 [details] [diff] [review]
Use values correctly

I've only been able to test the Seamonkey version of address book search so in
particular the contacts sidebar changes are a bit of a guess but it's nice
being able delete Seth's code not once but three times :-)
Assignee: mscott → neil.parkwaycc.co.uk
Status: NEW → ASSIGNED
(Assignee)

Comment 4

14 years ago
Stephen, any chance you can test this for me? Or should I just ask Scott?

Comment 5

14 years ago
Everything's back to normal with your patch.  

Are there any tree problems with seamonkey ab search?  Only the left half of a
row is selected in my build.
(Assignee)

Comment 6

14 years ago
Sorry, I didn't understand that. Maybe a screenshot would help?
(Assignee)

Comment 8

14 years ago
Sorry, I can't reproduce that in my Seamonkey build.
(Assignee)

Updated

14 years ago
Attachment #149901 - Flags: superreview?(mscott)
Attachment #149901 - Flags: review?(mscott)
(Assignee)

Comment 9

14 years ago
Hmm... address book preferences does this too, sigh...

Comment 10

14 years ago
Comment on attachment 149901 [details] [diff] [review]
Use values correctly

thanks for fixing this regression.
Attachment #149901 - Flags: superreview?(mscott)
Attachment #149901 - Flags: superreview+
Attachment #149901 - Flags: review?(mscott)
Attachment #149901 - Flags: review+
(Assignee)

Comment 11

14 years ago
Created attachment 149945 [details] [diff] [review]
Patch pref-directory.js

Well I think this fixes everything, but it's tricky trying to figure out just
what the code was doing, or why it was doing it the way it was...
(Assignee)

Comment 12

14 years ago
Comment on attachment 149945 [details] [diff] [review]
Patch pref-directory.js

Stephen, would you mind double-checking that this fixes both global directory
preferences and account overrides and handles all cases of renaming or deleting
the currently selected server.

Comment 13

14 years ago
With the stray line
(http://lxr.mozilla.org/mozilla/source/mailnews/addrbook/prefs/resources/content/pref-directory.js#100)
removed evrything appears to be working, but someone that builds/uses ldap
should test this better.

Tools -> Options -> Attachments also suffers from this bug:
Error: setting a property that has only a getter
Source File: chrome://mozapps/content/downloads/pref-downloads.js
Line: 130

Comment 14

14 years ago
More of Seth's code for Neil to remove.

New List, New Card, etc: http://lxr.mozilla.org/mozilla/search?string=abPopup.label
(Assignee)

Comment 15

14 years ago
Created attachment 149988 [details] [diff] [review]
pref-directory.js patch v2
Attachment #149945 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #149988 - Flags: superreview?(mscott)
Attachment #149988 - Flags: review?(mscott)
(Assignee)

Comment 16

14 years ago
Created attachment 149993 [details] [diff] [review]
sidebar panel fixes

Also some tb contacts fixes I overlooked :-[
(Assignee)

Comment 17

14 years ago
Created attachment 150001 [details] [diff] [review]
new card/list fixes

Stephen, please check these too, thanks.

Comment 18

14 years ago
Latest set looks good.

Comment 19

14 years ago
*** Bug 245517 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

14 years ago
Attachment #149993 - Flags: superreview?(mscott)
Attachment #149993 - Flags: review?(mscott)

Comment 20

14 years ago
(In reply to comment #17)
> Created an attachment (id=150001)  new card/list fixes
I applied patch to Thunderbird version 0.6+ (20040604) (nightly) win2k
and my problem (add sender to address book) is fixed. Thanks!
(Assignee)

Updated

14 years ago
Attachment #150001 - Flags: superreview?(mscott)
Attachment #150001 - Flags: review?(mscott)
(Assignee)

Comment 21

14 years ago
It looks like chuang's bad code predates seth's, so it's not his fault really.
*** Bug 245613 has been marked as a duplicate of this bug. ***
> It looks like chuang's bad code predates seth's, so it's not his fault really

if it is addressbook, I'll take the blame.

mscott, this should fix the ["Add to Address Book ..." pane isn't filling in]
bugs that people are reporting for seamonkey and tbird.
Summary: Contacts side bar is empty in the compose window → [Contacts side bar is empty in the compose window] and ["Add to Address Book ..." pane isn't filling in]
Comment on attachment 150001 [details] [diff] [review]
new card/list fixes

the changes to mozilla/mailnews look good, but you need mscott to approve the
mozilla/mail version.
Attachment #150001 - Flags: superreview?(mscott)
Attachment #150001 - Flags: superreview+
Attachment #150001 - Flags: review?(mscott)
Attachment #150001 - Flags: review+

Comment 25

14 years ago
Comment on attachment 150001 [details] [diff] [review]
new card/list fixes

moa=bienvenu (for mscott)

Comment 26

14 years ago
*** Bug 245804 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Attachment #149993 - Flags: superreview?(mscott)
Attachment #149993 - Flags: superreview+
Attachment #149993 - Flags: review?(mscott)
Attachment #149993 - Flags: review+

Updated

14 years ago
Attachment #149988 - Flags: superreview?(mscott)
Attachment #149988 - Flags: superreview+
Attachment #149988 - Flags: review?(mscott)
Attachment #149988 - Flags: review+
(Assignee)

Comment 27

14 years ago
Fixes checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.