The default bug view has changed. See this FAQ.

can't switch to certain themes, exception thrown

RESOLVED FIXED

Status

()

Toolkit
Add-ons Manager
--
major
RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: Steffen Wilberg, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

unspecified
x86
Windows XP
Points:
---
Bug Flags:
blocking1.7 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
I tried the Pinball 0.8.1 and iCandy junior themes, which are said to be
compatible with the new theme manager:
http://forums.mozillazine.org/viewtopic.php?t=79513
Indeed, they show up in it. But upon clicking the "use theme" button, nothing
happens. It throws an exception:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004003 (NS_ERROR_INVALID_POINTER) [nsIXULChromeRegistry.isSkinSelected]" 
nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame ::
chrome://mozapps/content/extensions/extensions.js :: anonymous :: line 594" 
data: no]
(Reporter)

Comment 1

13 years ago
Same result with a new profile.
Tested with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040602 Firefox/0.8.0+ (Steffen)
Flags: blocking0.9?
(Reporter)

Comment 2

13 years ago
This works with the Spheregnome 0.9.1 theme, but it's probably still a Firefox bug.
(Reporter)

Updated

13 years ago
Summary: can't switch themes in the new theme manager → can't switch to certain themes, exception thrown
Could somebody with a debug build work this a little bit? set a breakpoint in
nsChromeRegistry::IsProviderSelected and see where this error code is coming from.
Keywords: helpwanted

Comment 4

13 years ago
Confirming with:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040604
Firefox/0.8.0+ - Clean Profile/Zip Build.

Apollo 0.9: http://www.cs.txstate.edu/~as1130/themes/apollo/apollo_fx_09.jar

Tried installing via drag-drop, and via
http://texturizer.net/firefox/themes/#install

Identical exception thrown.
Status: NEW → ASSIGNED
Flags: blocking0.9? → blocking0.9+
All of these themes are file not found. There's a separate bug on better network
error reporting, so can someone please give me a theme I can actually download
that reproduces thsi?
(Reporter)

Comment 6

13 years ago
http://www.steffen-wilberg.de/icandyjr_fx_09.jar

I can still reproduce the bug with that one.

Comment 7

13 years ago
Tried it and found that for me the "Use Theme" button does nothing.
Restarting Firefox does not change this

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040608
Firefox/0.8.0+

Zip Build. Clean profile. 

Comment 8

13 years ago
I had this problem with 'Le Breeze (Unofficial Release)' by Kevin Davis.
In this case, em:internalName property in install.rdf is not
same as chrome:name property of contents.rdf (inside jar file).
This causes the exeption pointed in comment #0.

When I modified em:internalName property to 'lebreeze/1.0',
I can succesfully change to the LeBreeze theme.


icandy Jr. linked from comment #5 misses em:internalname
property.


Ben says:
> em:internalname
> This must be the same as the chrome:name property used in your contents.rdf file,
# http://www.bengoodger.com/software/mb/extensions/packaging/themes.html
so I think this bug is 'INVALID'.

Comment 9

13 years ago
Confirming comment #8, the repackaged version of apollo throws no exception, and
switches. Perhaps a sanity check of said propertie(s) , with a
comment/error/notice about it not being compatible?
sorry, typo in my document. that should be "internalName"
I just updated my document to fix the typo. 
(Reporter)

Updated

13 years ago
Flags: blocking1.0?
Created attachment 151579 [details] [diff] [review]
patch to prevent installation where chrome:name does not match em:internalName

Also logs console error message
Created attachment 151641 [details] [diff] [review]
additional fixes

This additional patch makes sure redundant data isn't written to the extensions
ds when a theme with incorrect data is installed.

Comment 14

13 years ago
This bug was referenced in a checkin comment last night.  Is it fixed?
(Reporter)

Comment 15

13 years ago
It's fixed. Installing such a theme now displays the alert "Malformed File".
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040629
Firefox/0.9.0+ (Steffen)

first patch checkin:
0.9.1:  2004-06-24 03:19.
Aviary: 2004-06-24 14:40.
Trunk:  2004-06-28 16:37.

second patch checkin:
0.9.1:  2004-06-24 14:38.
aviary: 2004-06-28 16:33.
trunk:  2004-06-28 16:37.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Flags: blocking-aviary1.0?
Keywords: helpwanted
Resolution: --- → FIXED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.