inconsistant body margins

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: A`ja, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

http://a-ja.net/  also uses the same stylesheet, but doesn't get the margin added.
http://a-ja.net/events/spanksgiving/ margins look the same as http://a-ja.net/
in  IE6, NS7.1, Opera 7.50, K-Meleon 0.8.2, and Amaya 8.5, but different in
Firefox 0.8 and Mozilla 1.6.   

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

14 years ago
Just noticed that when using W3C CSS validator with
http://a-ja.net/events/spanksgiving/ referer, two copies of the stylesheet
contents appear, but when using http://a-ja.net/ referer only a single copy of
the stylesheet appears. Both "link rel" and "xml-stylesheet" are used in both
xhtml1.1 documents.  The two documents are obviously in different directories,
and therefore have different paths to the same stylesheet.
Summary: inconsistant body margins → inconsistant body margins
The margins look identical in size.  The only difference I see is  that
http://a-ja.net/ paints the background under the margin (since it's an HTML
page), while http://a-ja.net/events/spanksgiving/ does not (since it's an XHTML
page).  That's the right behavior given that the background isn't set on the
root element.

So what's the bug?
To be more precise, the site tells Mozilla that http://a-ja.net/ is a text/html
document while http://a-ja.net/events/spanksgiving/ is an application/xhtml+xml
document.

Now see http://www.w3.org/TR/CSS21/colors.html#q2 paragraph 4:

   For HTML documents, however, we recommend that authors specify the background
   for the BODY element rather than the HTML element. User agents should observe
   the following precedence rules to fill in the background of the canvas of
   HTML documents: if the value of the 'background' property for the HTML
   element is different from 'transparent' then use it, else use the value of
   the 'background' property for the BODY element. If the resulting value is
   'transparent', the rendering is undefined. This does not apply to XHTML
   documents.

Note that last sentence.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

14 years ago
Sorry about that...didn't realize there was an .htaccess affecting one page
(serving it as application/xhtml+xml) but not the other (W3C validator was
telling me it was text/html for both).  copied the .htaccess to base directory,
modified stylesheet and both xhtml documents to style html instead of body, and
it works just fine. 
You need to log in before you can comment on or make changes to this bug.