Input to search field is consumed by main window

RESOLVED DUPLICATE of bug 199019

Status

Thunderbird
Mail Window Front End
--
critical
RESOLVED DUPLICATE of bug 199019
14 years ago
13 years ago

People

(Reporter: Daniel Küstner, Assigned: Scott MacGregor)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040514
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040514

When typing into the search field (Subject or sender contains:), some keystrokes
are handled as keyboard shortcuts (k - ignore thread, r - mark thread as read, j
- mark message as junk, m - mark message read etc.). This happens at the same
time while other characters are appearing in the search field (so the focus is
somehow "splitted"). This is very annoying, as the user usually doesn't notice
this behaviour and types the key again and again. This makes it difficult to
reproduce the previous state of message base. It's not reproducable always, but
when it occurs, TB has to be restarted in order to make it work.

Reproducible: Sometimes
Steps to Reproduce:
(Reporter)

Updated

14 years ago
Keywords: dataloss

Comment 1

14 years ago
I can't reproduce this using mac 20040603 nightly build.

Comment 2

14 years ago
I am seeing the exact same bug in TB 0.8 on OSX. I believe it had gone away in
0.7 but it would appear that it has now made a come-back. It is extremely
annoying as it makes the search box unusable without thinking of all the letters
you have to avoid.

Comment 3

13 years ago
This appears to be fixed in 0.9 on OS X - I, at least, could type "jerk mark" (no offense to any Marks in 
the audience) into the the search field, and the offending characters appeared as input rather than 
acting as commands.

Should this be closed as confirmed, or should some other people who have seen it try it first?
(Reporter)

Comment 4

13 years ago
I just had it again in TB 0.9. The problem is, that it occasionally works.

There seem to be a lot of bugs with keyboard input eaten by the wrong UI parts
on the mac: bug 262387, bug 205035, bug 247140, bug 228298, bug 166199, bug
202656. Maybe there is a common cause for these bugs? Should I file a meta bug?

Comment 5

13 years ago
I've also seen it once in 0.9 on OS X, but all the other times I've tried it, it works; exiting Thunderbird 
and restarting it made the problem go away the one time I saw it.
(Assignee)

Comment 6

13 years ago
let me know if you can get a scenario were this is reproducible and we'll try to
fix it. I've never seen it myself on OS X. 

Comment 7

13 years ago
If the threading menu in View > Sort By is active, so that "Grouped By Sort" is active, if I type "g" in the 
search field, it's intercepted as the "G" accelerator for that menu item.  I've also had "m" consumed - it's 
"mark as read".

Comment 8

13 years ago
I just tried searching for something that began with "j", and Thunderbird marked the currently-selected 
message as junk and moved it to my junk box.  Fortunately, I saw the message disappear from the 
mailbox, and went searching through the menus for a menu item with an accelerator that was an 
unadorned "j", and saw that it was the "mark as junk" item, went to the junk mailbox, unmarked the 
message, and moved it back to its original mailbox.  Hopefully I haven't typed any other strings with "j" 
in them and had messages discarded as junk *without* my noticing....

If the problem with input to the search field being consumed by the main window cannot be fixed, can 
a preference at least be provided to disable all the unadorned accelerators, for the benefit of those of 
us who don't care about being able to just type letters at the main window and do things to messages 
and who don't always remember that some letters are unsafe to use in the search box?  Losing 
messages because you try to search for something with a "j" in it is not good....

Comment 9

13 years ago
Seems intermittent.  I just had this happen to me with the letter when I hit the
letter "c" (version 0.9 (20041103) on X 10.3.6).  When I restarted TB everything
seemed to be OK.  I'll see if I can come up with an exact scenario of what it
takes to make the problem reappear.

Comment 10

13 years ago
Still happens to me with 1.0 (20041206), but not all the time.  

This is another symptom of pervasive keyboard-focus problems under OS/X.

Similar keyboard-focus-related bugs still happening with the 20050222 build.

Comment 11

13 years ago
bug 267748 is probably a duplicate but it has some interesting infos

Comment 12

13 years ago
I see this bug on Thunderbird 1.0.6 on Mac OS X 10.3.9. I can't remember having
encountered it in prior versions.

Why is it still "unconfirmed" though several people have been confirming it
since June 2004?

Comment 13

13 years ago
I can reproduce it in TB version 1.0.2 (20050317) for MacOS X by 
1. selecting a message
2. selecting command with a single-key shortcut from the menu (e.g.,
Go->Next->Message (F))
3. select the search box and try to type F.  The selection and the focus switch
to the next message. 

Comment 14

13 years ago

*** This bug has been marked as a duplicate of 199019 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.