Closed Bug 245385 Opened 18 years ago Closed 13 years ago

the active theme should be selected instead of the last-selected one

Categories

(Toolkit :: Add-ons Manager, enhancement)

enhancement
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla1.9.3a1
Tracking Status
status1.9.2 --- beta1-fixed

People

(Reporter: steffen.wilberg, Assigned: mossop)

References

Details

(Keywords: verified1.9.2)

Attachments

(1 file)

While it's nice for extensions to have the one you've selected last being
selected again upon opening the manager, for themes it would be better to have
the active theme selected (and scrolled into view).
The advantage is that you don't have to look for the current theme.
Perhaps a viable alternative to scrolling into view, would be to place the
current theme either:

- In its own "Current Theme" frame, at the top of the themes dialog, or
- First in the list of themes
Assignee: bugs → robert.bugzilla
QA Contact: bugs → extension.manager
Assignee: robert.bugzilla → nobody
Product: Firefox → Toolkit
Duplicate of this bug: 474808
Target Milestone: --- → mozilla1.9.2
Attached patch patch rev 1Splinter Review
This is a pretty simple fix
Assignee: nobody → dtownsend
Status: NEW → ASSIGNED
Attachment #395025 - Flags: review?(robert.bugzilla)
Attachment #395025 - Flags: review?(robert.bugzilla) → review+
Landed: http://hg.mozilla.org/mozilla-central/rev/8cb946fd4488
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: [needs baking]
Target Milestone: mozilla1.9.2 → mozilla1.9.3a1
Verified fixed with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a1pre) Gecko/20090821 Minefield/3.7a1pre ID:20090821030931
Status: RESOLVED → VERIFIED
Dave, how long you wanna let it bake? Seems like that we don't have any regression. Is it ready for asking approval1.9.2?
Comment on attachment 395025 [details] [diff] [review]
patch rev 1

We should take this simple low-risk fix on the 1.9.2 branch
Attachment #395025 - Flags: approval1.9.2?
Whiteboard: [needs baking]
Attachment #395025 - Flags: approval1.9.2? → approval1.9.2+
Verified fixed on 1.9.2 with builds on OS X and Windows like Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a2pre) Gecko/20090914 Namoroka/3.6a2pre (.NET CLR 3.5.30729) ID:20090914045622

I believe we can inject this test into one of our Litmus tests.
Flags: in-litmus?
Keywords: verified1.9.2
Now covered by the following Litmus test for Firefox 3.6:
https://litmus.mozilla.org/show_test.cgi?id=8168
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.