MozBot using Net::IRC 0.75 quits with an Uncaught Perl Exception

VERIFIED FIXED in 2.6

Status

Webtools
Mozbot
VERIFIED FIXED
14 years ago
7 years ago

People

(Reporter: Benjamin Nave, Assigned: Hixie (not reading bugmail))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040113
Build Identifier: 

After MozBot joins the channel, any message sent with the format <MozBotName>:
<message> causes the bot to quit (ie "mozbot: help").

The following is the command line output:

Can't use string ("help") as an ARRAY ref while "strict refs" in use at
        /Library/Perl/5.8.1/Net/IRC/Event.pm line 73 (#2)
    (F) Only hard references are allowed by "strict refs".  Symbolic
    references are disallowed.  See perlref.
    
Uncaught exception from user code:
        Can't use string ("help") as an ARRAY ref while "strict refs" in use at
/Library/Perl/5.8.1/Net/IRC/Event.pm line 73.
        Net::IRC::Event::args('Net::IRC::Event=HASH(0x93bfc0)','help') called at
./mozbot.pl line 608
       
main::on_public('Net::IRC::Connection=HASH(0x918584)','Net::IRC::Event=HASH(0x93bfc0)')
called at /Library/Perl/5.8.1/Net/IRC/Connection.pm line 492
        Net::IRC::Connection::handler() called at
/Library/Perl/5.8.1/Net/IRC/Connection.pm line 1051
       
Net::IRC::Connection::parse('Net::IRC::Connection=HASH(0x918584)','IO::Socket::INET=GLOB(0x937c04)')
called at /Library/Perl/5.8.1/Net/IRC.pm line 178
        Net::IRC::do_one_loop('Net::IRC=HASH(0x91875c)') called at
/Library/Perl/5.8.1/Net/IRC.pm line 259
        Net::IRC::start('Net::IRC=HASH(0x91875c)') called at ./mozbot.pl line 2718
2004-06-03 04:01:34 UTC (1743) perl is shutting down...
2004-06-03 04:01:34 UTC (1743) Module Admin: garbage collected
2004-06-03 04:01:34 UTC (1743) Module General: garbage collected
2004-06-03 04:01:34 UTC (1743) Connection: garbage collected

Reproducible: Always
Steps to Reproduce:
1. Launch mozbot.pl
2. After bot logs on to channel type message "<mozbot name>: help"

Actual Results:  
mozbot.pl exits with an uncaught exception error as shown in details.

Expected Results:  
Should not exit
(Assignee)

Comment 1

14 years ago
What version of Net::IRC are you using?
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> What version of Net::IRC are you using?

cpan> m Net::IRC
Module id = Net::IRC
    DESCRIPTION  Internet Relay Chat interface
    CPAN_USERID  JEEK (T.J. Eckman <jeek@jeek.net>)
    CPAN_VERSION 0.75
    CPAN_FILE    J/JM/JMUHLICH/Net-IRC-0.75.tar.gz
    DSLI_STATUS  cdpO (pre-alpha,developer,perl,object-oriented)
    MANPAGE      Net::IRC - Perl interface to the Internet Relay Chat protocol
    INST_FILE    /Library/Perl/5.8.1/Net/IRC.pm
    INST_VERSION 0.75


cpan> 

If that's not what you were asking for, please let me know how to find the version.
(Assignee)

Comment 3

14 years ago
Wow. Weird. I wonder if 0.75 broke something then.
(Reporter)

Comment 4

14 years ago
(In reply to comment #3)
> Wow. Weird. I wonder if 0.75 broke something then.

It would appear so.  I installed version 0.74 and mozbot seems to be running
fine now.  Is this an OS X only bug?

Comment 5

14 years ago
Created attachment 151588 [details] [diff] [review]
patch to get mozbot.pl to work with Net::IRC 0.75

This issue occurs on my PC running Linux as well. They seem to have changed the
interface for the Net::IRC::Event::args function to require array refs. This
patch changes all calls to this function to use arrayrefs

Updated

14 years ago
Attachment #151588 - Flags: review?

Comment 6

14 years ago
summary should probably be generalized a bit. This seems to be an issue with Net::IRC 0.75 in 
general, rather than just on OS X.

(I just tried to do it myself, but don't appear to have the rights to :-7)

Updated

14 years ago
OS: MacOS X → All
Hardware: Macintosh → All
Summary: MozBot quits on MacOS X 10.3.4 with an Uncaught Perl Exception → MozBot using Net::IRC 0.75 quits with an Uncaught Perl Exception
(Assignee)

Comment 7

14 years ago
*** Bug 257341 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 8

14 years ago
Thanks for the fix mh!
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

13 years ago
Attachment #151588 - Flags: review?

Comment 9

12 years ago
*** Bug 325451 has been marked as a duplicate of this bug. ***
QA Contact: kerz → mozbot

Updated

9 years ago
Target Milestone: --- → 2.6
Verified Fixed.
Status: RESOLVED → VERIFIED

Updated

7 years ago
Blocks: 538396
You need to log in before you can comment on or make changes to this bug.