Font size auto-adjustment, based on document contents

RESOLVED DUPLICATE of bug 31961

Status

()

enhancement
RESOLVED DUPLICATE of bug 31961
15 years ago
6 years ago

People

(Reporter: vincent-moz, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040315
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040315

Many poorly designed pages change the default font size, making the pages
difficult to read. Rules in userContent.css don't always solve such problems.

Mozilla should provide options to be able to adjust the default font size
automatically, based on the contents of the HTML document. For instance, if most
of the text not in headings (> 50%) is smaller or larger than the medium size,
Mozilla should zoom the text (like with <Ctrl>+ and <Ctrl>-) to render it at the
medium size (and the remaining text proportionally).

Note: Of course, this is only a heuristic, and this may "break" the rendering of
some pages (perhaps not properly designed). But if this can improve the
readability of many pages, this is interesting.

Reproducible: Always
Steps to Reproduce:
1. n/a
Actual Results:  
n/a

Expected Results:  
n/a
Whiteboard: DUPEME

Comment 1

15 years ago
Bug 31961 asks essentially the same thing except not automatic.

Comment 2

15 years ago
Automation is also discussed there, see 
http://bugzilla.mozilla.org/show_bug.cgi?id=31961#c3

I guess this should be marked as duplicate.

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 31961 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE

Updated

6 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.