options, about, homepage buttons work on the previously selected extension; they should work on that you clicked on

RESOLVED FIXED in mozilla1.7.4

Status

()

P3
normal
RESOLVED FIXED
15 years ago
4 years ago

People

(Reporter: steffen.wilberg, Assigned: bugs)

Tracking

({fixed-aviary1.0})

unspecified
mozilla1.7.4
fixed-aviary1.0
Points:
---
Bug Flags:
blocking1.7 -
blocking-aviary1.0PR +
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040603 Firefox/0.8.0+ (Steffen)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040603 Firefox/0.8.0+ (Steffen)

Clicks on the little colored buttons always refer to the extension which is
currently selected, even if you click on buttons of another extension.

Reproducible: Always
Steps to Reproduce:
1. Open the extension manager.
2. Select one extension.
3. Click on the about button of another extension (which is not selected).

Actual Results:  
The about dialog of the extension selected in step 2 is opened.

Expected Results:  
The about dialog of the extension you clicked on is opened.

If no extension is selected and you click on one of the colored buttons, nothing
happens.
-->blocking0.9?

It's probably not worth twiddling the blocking0.9 flag as Ben will almost
certainly deal with it, but I'd hate to see this get overlooked.
Flags: blocking0.9?
OS: Windows XP → All
Hardware: PC → All
Yes I knew about this when i wrote it, and I felt sleazy. You're right, I should
fix it... but trying to keep the set of changes between now and 0.9 small... so
0.9-, 1.0+
Status: NEW → ASSIGNED
Flags: blocking1.0+
Flags: blocking0.9?
Flags: blocking0.9-

Comment 3

15 years ago
*** Bug 246071 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
*** Bug 246318 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
*** Bug 246326 has been marked as a duplicate of this bug. ***
Priority: -- → P3
Target Milestone: --- → Firefox1.0beta

Comment 6

15 years ago
*** Bug 246449 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
*** Bug 246551 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
*** Bug 246677 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
*** Bug 246843 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
*** Bug 246871 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
*** Bug 246884 has been marked as a duplicate of this bug. ***

Comment 12

15 years ago
*** Bug 247271 has been marked as a duplicate of this bug. ***

Comment 13

15 years ago
*** Bug 247611 has been marked as a duplicate of this bug. ***

Comment 14

15 years ago
*** Bug 247709 has been marked as a duplicate of this bug. ***

Comment 15

15 years ago
*** Bug 247751 has been marked as a duplicate of this bug. ***

Comment 16

15 years ago
*** Bug 248972 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 17

15 years ago
Make summary clearer.
Summary: options/about/homepage buttons work on the selected extension, not on that you clicked on → options, about, homepage buttons work on the previously selected extension; they should work on that you clicked on

Comment 18

15 years ago
*** Bug 248902 has been marked as a duplicate of this bug. ***
Flags: blocking-aviary1.0RC1+

Comment 19

15 years ago
I just noticed this myself.  Was very confused when I got the wrong "info" box.
 Firefox 0.9.1.  Can this please be fixed?  Would've been nice if it was fixed
before 0.9.1, but should certainly be fixed ASAP.
Thanks...

Comment 20

15 years ago
(In reply to comment #19)
> I just noticed this myself.  Was very confused when I got the wrong "info" box.
>  Firefox 0.9.1.  Can this please be fixed?  Would've been nice if it was fixed
> before 0.9.1, but should certainly be fixed ASAP.
> Thanks...

Yup, it is here in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040706 Firefox/0.9.0+ (bangbang023)

Comment 21

15 years ago
*** Bug 250507 has been marked as a duplicate of this bug. ***
br & trunk fixed. 
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 23

15 years ago
*** Bug 251847 has been marked as a duplicate of this bug. ***

Comment 24

15 years ago
*** Bug 253958 has been marked as a duplicate of this bug. ***

Comment 25

15 years ago
setting fixed-aviary1.0 for bugfixes checked into branch, for searching purposes.
sorry for bugspam.
Keywords: fixed-aviary1.0

Comment 26

15 years ago
*** Bug 254861 has been marked as a duplicate of this bug. ***
*** Bug 258450 has been marked as a duplicate of this bug. ***
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.