Thunderbird aviary branch hammers IMAP server with repeated SELECT on every subscribed folder

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: mozbugs, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040601 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040601 Firefox/0.8.0+


Aviary branch thunderbird builds on Linux are hammering my IMAP server with
repeated "SELECT" operations on what appears to be every folder to which I am
subscribed (not just those that I have configured to check for new messages).
It doesn't do it all the time, and I haven't been able to figure out what
triggers it, but once it starts, it can blast the server with several rounds
of select requests per minute. A couple of snippets from my server's log:

root[sh]@bvms3-1# grep '03/Jun/2004:12:.*user/im50766/root/cron' imap
[03/Jun/2004:12:07:44 -0600] bvms3-1 imapd[2706]: Account Information: select
[192.18.104.13:54086] im50766 user/im50766/root/cron
[03/Jun/2004:12:14:46 -0600] bvms3-1 imapd[2706]: Account Information: select
[192.18.104.13:54086] im50766 user/im50766/root/cron
[03/Jun/2004:12:15:03 -0600] bvms3-1 imapd[2706]: Account Information: select
[192.18.104.13:54086] im50766 user/im50766/root/cron
[03/Jun/2004:12:15:19 -0600] bvms3-1 imapd[2706]: Account Information: select
[192.18.104.13:54086] im50766 user/im50766/root/cron
[03/Jun/2004:12:15:47 -0600] bvms3-1 imapd[2706]: Account Information: select
[192.18.104.13:54086] im50766 user/im50766/root/cron
[03/Jun/2004:12:15:54 -0600] bvms3-1 imapd[2706]: Account Information: select
[192.18.104.13:54127] im50766 user/im50766/root/cron
[03/Jun/2004:12:15:59 -0600] bvms3-1 imapd[2706]: Account Information: select
[192.18.104.13:54127] im50766 user/im50766/root/cron
[03/Jun/2004:12:16:07 -0600] bvms3-1 imapd[2706]: Account Information: select
[192.18.104.13:54127] im50766 user/im50766/root/cron
root[sh]@bvms3-1# grep -c '03/Jun/2004:12:.*select' imap
582
root[sh]@bvms3-1# grep -c '03/Jun/2004:12:.*select.*im50766' imap
571
root[sh]@bvms3-1# date
Thu Jun  3 12:23:35 MDT 2004
root[sh]@bvms3-1#

So I've done 571 select operations in the last 23 minutes. The other 20
active users on my server have done 10 combined. Note that my "root/cron"
folder is NOT one that I have told thunderbird to check for new messages.



Reproducible: Sometimes
Steps to Reproduce:
1.
2.
3.
(Assignee)

Comment 1

15 years ago
I haven't noticed anyone else complaining about this. Maybe I sucked in a bad
trunk patch. 
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 2

15 years ago
can you attach or e-mail me an imap protocol log showing the problem?

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap

What other builds have you run that *didn't* have this problem, so I can maybe
figure out when it got introduced...
(Reporter)

Comment 3

15 years ago
It wasn't immediately obvious to me as a user - the sysadmin of our mail server
brought it to my attention. The only oddness I've been seeing as a user recently
is what I reported in bug 245044 - may or may not be related.

I'll get cracking on the protocol log, and maybe try looking back through the
server logs to see if I can figure out when this started happening. It was
only brough to my attention this morning.

(Reporter)

Comment 4

15 years ago
OK, I'm (still) an idiot :(

Looks like this is being caused by an extension that I have installed to add
a "Compact" button to my toolbar. I hadn't paid close enough attention, and
assumed that this only compacts the current folder, but it appears that it
compacts *all* folders, with 'MsgCompactFolder(true);'. Does the "true" mean
"all subscribed folders"?

Now, if thunderbird had a standard toolbar button and keyboard shortcut for
"Compact this folder", I wouldn't have had to install this bad extension.
Can we please, please, please add this? Pretty please? Bug 216732 hints
at this, but maybe I need to open a new RFE.

Sorry for wasting your time on this one :( 
(Assignee)

Comment 5

15 years ago
marking invalid. 
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 6

15 years ago
yes, that compacts all folders. NP for the false alarm. Is there no keyboard
shortcut on linux that will bring up the context menu?
(Reporter)

Comment 7

15 years ago
(In reply to comment #6)
> yes, that compacts all folders. NP for the false alarm. Is there no keyboard
> shortcut on linux that will bring up the context menu?

Not sure, but even if there is, it'd be a pain. I handle deletion with
"Mark as deleted", picking off messages to delete in batches, then hit
"Compact" when I'm done with that folder. The compact also catches
deletions as a result of moving messages to other folders. With several
noisy mailing list folders in multiple IMAP accounts, this means I compact
quite often (hence the flood of IMAP traffic that started this report). To
have to go to the context menu for this is a pain. I think a toolbar button
and a keyboard shortcut are both appropriate...


(Reporter)

Comment 8

15 years ago
(In reply to comment #7)
> To have to go to the context menu for this is a pain. 

PS. I actually have to *change* context anyway - my context when deleting messages
is the message list pane - I have to go to the folder list to get the "Compact
this folder" option.


(Reporter)

Comment 9

15 years ago
Spun off bug 245607 as an RFE for this.
You need to log in before you can comment on or make changes to this bug.