If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox uses Quick Search from old profile after migration

RESOLVED INVALID

Status

()

Firefox
Migration
--
trivial
RESOLVED INVALID
14 years ago
12 years ago

People

(Reporter: Walter K., Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040604 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040604 Firefox/0.8.0+

After migration is done from FF0.8 to 0.9, Search Plugin icon is the icon of
last selected plugin in the FF0.8 profile, but the search engine itself was not
migrated.

Reproducible: Always
Steps to Reproduce:
1.In FF0.8 add new search engine and select this new engine for use
2.Install FF0.9. Make sure that no profile under Mozilla/Firefox exists
3.Start FF0.9.
Actual Results:  
After migration is over, Quick Search will have icon of the search engine from #1

Expected Results:  
FF either should migrate search plugins, or FF Quick Search toolbar should show
default Search in Page icon.
(Reporter)

Comment 1

14 years ago
Actually, it's not just icon. FF continues to use the engine itself from the old
profile. localstore.rdf stores absolute path to the engine.

Comment 2

14 years ago
Migrating search plugins is also the subject of bug 232638.
(Reporter)

Updated

14 years ago
Summary: Firefox migrates last used Quick Search icon, but not the engine → Firefox uses Quick Search from old profile after migration
This bug was last touched before 1.0.4. Is it still reproducable?
Try the latest branch build (1.0.5): http://www.mozilla.org/products/firefox/
Try the latest nightly trunk build (v1.0+): http://www.mozilla.org/developer
(Reviving old UNCONFs)

Comment 4

12 years ago
A complete overhaul of the search service is on the way:

  http://wiki.mozilla.org/Search_Service

Since, the concept is about to be redesigned and the bug cannot be directly duped with one of the existing trackers ===> INVALID

Further details, e.g.
- bug 317107 (main tracker)
- bug 232272
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.